aboutsummaryrefslogtreecommitdiff
path: root/databases/py-whisper
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2011-06-22 18:23:38 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2011-06-22 18:23:38 +0000
commitc88d74b4add960533cd69a1fe3cd237373d2b47e (patch)
tree94ac89c09608b2a2ec67224c77c28fb1197fd4f5 /databases/py-whisper
parent05e3aa05535c1b8da1589ea5f6b54ad20134c0f5 (diff)
downloadports-c88d74b4add960533cd69a1fe3cd237373d2b47e.tar.gz
ports-c88d74b4add960533cd69a1fe3cd237373d2b47e.zip
Whisper is a fixed-size database, similar in design to RRD
(round-robin-database). It provides fast, reliable storage of numeric data over time. WWW: http://graphite.wikidot.com/whisper
Notes
Notes: svn path=/head/; revision=276077
Diffstat (limited to 'databases/py-whisper')
-rw-r--r--databases/py-whisper/Makefile22
-rw-r--r--databases/py-whisper/distinfo2
-rw-r--r--databases/py-whisper/pkg-descr5
-rw-r--r--databases/py-whisper/pkg-plist10
4 files changed, 39 insertions, 0 deletions
diff --git a/databases/py-whisper/Makefile b/databases/py-whisper/Makefile
new file mode 100644
index 000000000000..7d631bb5dfaa
--- /dev/null
+++ b/databases/py-whisper/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-whisper
+# Date created: 2011-06-20
+# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= whisper
+PORTVERSION= 0.9.8
+CATEGORIES= databases python
+MASTER_SITES= http://launchpad.net/graphite/1.0/${PORTVERSION}/+download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Fixed-size database, similar in design to RRD
+
+FETCH_ARGS= "-pRr"
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/databases/py-whisper/distinfo b/databases/py-whisper/distinfo
new file mode 100644
index 000000000000..afbc2995b4a0
--- /dev/null
+++ b/databases/py-whisper/distinfo
@@ -0,0 +1,2 @@
+SHA256 (whisper-0.9.8.tar.gz) = b915836a69e924ccbd6d9be8f8791c4cab93cea106de6825bb60edb3cb42957e
+SIZE (whisper-0.9.8.tar.gz) = 12326
diff --git a/databases/py-whisper/pkg-descr b/databases/py-whisper/pkg-descr
new file mode 100644
index 000000000000..55c5b8c96bcb
--- /dev/null
+++ b/databases/py-whisper/pkg-descr
@@ -0,0 +1,5 @@
+Whisper is a fixed-size database, similar in design to RRD
+(round-robin-database). It provides fast, reliable storage of
+numeric data over time.
+
+WWW: http://graphite.wikidot.com/whisper
diff --git a/databases/py-whisper/pkg-plist b/databases/py-whisper/pkg-plist
new file mode 100644
index 000000000000..cd214e0e76e4
--- /dev/null
+++ b/databases/py-whisper/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/whisper.py
+%%PYTHON_SITELIBDIR%%/whisper.pyc
+%%PYTHON_SITELIBDIR%%/whisper.pyo
+bin/rrd2whisper.py
+bin/whisper-info.py
+bin/whisper-fetch.py
+bin/whisper-update.py
+bin/whisper-resize.py
+bin/whisper-create.py