aboutsummaryrefslogtreecommitdiff
path: root/databases/py-xapian
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /databases/py-xapian
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'databases/py-xapian')
-rw-r--r--databases/py-xapian/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/databases/py-xapian/Makefile b/databases/py-xapian/Makefile
index cf97ce71202d..ed4220660053 100644
--- a/databases/py-xapian/Makefile
+++ b/databases/py-xapian/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_aarch64= fails to build: Fatal Python error: swig_pythreadstate set in XapianSWIG_Python_Thread_Allow ctor
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=1.4.8:textproc/py-sphinx \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=1.4.8:textproc/py-sphinx@${FLAVOR} \
xapian-core>=${PORTVERSION}:databases/xapian-core
LIB_DEPENDS= libxapian.so:databases/xapian-core
@@ -34,6 +34,7 @@ CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR} \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USES= libtool python tar:xz
+USE_PYTHON= flavors
PORTDOCS= *