aboutsummaryrefslogtreecommitdiff
path: root/databases/py-zodbpickle
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2017-10-12 19:00:13 +0000
committerMark Felder <feld@FreeBSD.org>2017-10-12 19:00:13 +0000
commit3d558c1348e4b116873fb64a45ee72085ac28c29 (patch)
treea5f16f7594676b2863e2f0b0a4b1d982a8f1710d /databases/py-zodbpickle
parent443c1869c8937c736fc4485481fb567a1a3f0969 (diff)
downloadports-3d558c1348e4b116873fb64a45ee72085ac28c29.tar.gz
ports-3d558c1348e4b116873fb64a45ee72085ac28c29.zip
Under Python2, this package forks both Python 2.7's pickle and
cPickle modules, adding support for the protocol 3 opcodes. It also provides a new subclass of bytes, zodbpickle.binary, which Python2 applications can use to pickle binary values such that they will be unpickled as bytes under Py3k. Under Py3k, this package forks the pickle module (and the supporting C extension) from both Python 3.2 and Python 3.3. The fork add support for the noload operations used by ZODB. WWW: https://pypi.python.org/pypi/zodbpickle
Notes
Notes: svn path=/head/; revision=451925
Diffstat (limited to 'databases/py-zodbpickle')
-rw-r--r--databases/py-zodbpickle/Makefile19
-rw-r--r--databases/py-zodbpickle/distinfo3
-rw-r--r--databases/py-zodbpickle/pkg-descr11
3 files changed, 33 insertions, 0 deletions
diff --git a/databases/py-zodbpickle/Makefile b/databases/py-zodbpickle/Makefile
new file mode 100644
index 000000000000..58a82a1210f1
--- /dev/null
+++ b/databases/py-zodbpickle/Makefile
@@ -0,0 +1,19 @@
+# Created by: Mark Felder <feld@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= zodbpickle
+PORTVERSION= 0.7.0
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= Python pickling interface for ZODB
+
+LICENSE= PSFL ZPL21
+LICENSE_COMB= multi
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/databases/py-zodbpickle/distinfo b/databases/py-zodbpickle/distinfo
new file mode 100644
index 000000000000..8e0ba1b0e545
--- /dev/null
+++ b/databases/py-zodbpickle/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1507833956
+SHA256 (zodbpickle-0.7.0.tar.gz) = 95a247fb17bce980af8d548af70ac5bd1bad22773f242eb8efa24428efa909a8
+SIZE (zodbpickle-0.7.0.tar.gz) = 181263
diff --git a/databases/py-zodbpickle/pkg-descr b/databases/py-zodbpickle/pkg-descr
new file mode 100644
index 000000000000..3715b553459e
--- /dev/null
+++ b/databases/py-zodbpickle/pkg-descr
@@ -0,0 +1,11 @@
+Under Python2, this package forks both Python 2.7's pickle and
+cPickle modules, adding support for the protocol 3 opcodes. It also
+provides a new subclass of bytes, zodbpickle.binary, which Python2
+applications can use to pickle binary values such that they will be
+unpickled as bytes under Py3k.
+
+Under Py3k, this package forks the pickle module (and the supporting
+C extension) from both Python 3.2 and Python 3.3. The fork add support
+for the noload operations used by ZODB.
+
+WWW: https://pypi.python.org/pypi/zodbpickle