aboutsummaryrefslogtreecommitdiff
path: root/databases/pypy-sqlite3
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2015-08-31 19:38:23 +0000
committerDavid Naylor <dbn@FreeBSD.org>2015-08-31 19:38:23 +0000
commiteeb1443b97e50bd2070382879809fcf857973c0d (patch)
treee38ad343bb0776e7eeb5b7e1a6d397c3b069282f /databases/pypy-sqlite3
parent5c080d0f3d7607267b4e3b530dfbf448cbfa93ad (diff)
downloadports-eeb1443b97e50bd2070382879809fcf857973c0d.tar.gz
ports-eeb1443b97e50bd2070382879809fcf857973c0d.zip
lang/pypy: update to 2.6.1
Changes: - Add external cffi ports (a la python): - databases/pypy-gdbm - databases/pypy-sqlite3 - x11-toolkits/pypy-tkinter - Add bsd.pypy.mk for consistency between pypy ports. - Add bsd.pypy.cffi.mk for consistency with external cffi ports. - Switch back to using $PREFIX/pypy-X.Y (the '-' separator is required to differentiate between lang/pypy and lang/pypy3) - Remove all patches (upstreamed, see announcement below) ChangeLog: - Bug Fixes - Revive non-SSE2 support - Fixes for detaching _io.Buffer* - Clear up contention in the garbage collector between trace-me-later and pinning - Issues reported with our previous release were resolved after reports from users on our issue tracker at https://bitbucket.org/pypy/pypy/issues or on IRC at #pypy. - New features: - cffi was updated to version 1.3 - The python stdlib was updated to 2.7.10 from 2.7.9 - vmprof now supports multiple threads - The translation process builds cffi import libraries for some stdlib packages, which should prevent confusion when package.py is not used - better support for gdb debugging - FreeBSD should be able to translate PyPy "out of the box" with no patches - Numpy: - Better support for record dtypes, including the align keyword - Implement casting and create output arrays accordingly (still missing some corner cases) - Support creation of unicode ndarrays - Better support ndarray.flags - Support axis argument in more functions - Refactor array indexing to support ellipses - Allow the docstrings of built-in numpy objects to be set at run-time - Support the buffered nditer creation keyword - Performance improvements: - Delay recursive calls to make them non-recursive - Skip loop unrolling if it compiles too much code - Tweak the heapcache - Add a list strategy for lists that store both floats and 32-bit integers. The latter are encoded as nonstandard NaNs. Benchmarks show that the speed of such lists is now very close to the speed of purely-int or purely-float lists. - Simplify implementation of ffi.gc() to avoid most weakrefs - Massively improve the performance of map() with more than one sequence argument Differential Revision: https://reviews.freebsd.org/D3285
Notes
Notes: svn path=/head/; revision=395726
Diffstat (limited to 'databases/pypy-sqlite3')
-rw-r--r--databases/pypy-sqlite3/Makefile16
-rw-r--r--databases/pypy-sqlite3/pkg-descr8
2 files changed, 24 insertions, 0 deletions
diff --git a/databases/pypy-sqlite3/Makefile b/databases/pypy-sqlite3/Makefile
new file mode 100644
index 000000000000..cf4fb55a5da7
--- /dev/null
+++ b/databases/pypy-sqlite3/Makefile
@@ -0,0 +1,16 @@
+# Created by: David Naylor <dbn@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sqlite3
+PORTVERSION= ${PYTHON_PORTVERSION}
+CATEGORIES= databases python
+
+MAINTAINER= dbn@FreeBSD.org
+COMMENT= Standard PyPy binding to the SQLite3 library
+
+LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
+
+CFFI_NAME= _ffi
+
+.include "${.CURDIR}/../../lang/pypy/bsd.pypy.cffi.mk"
+.include <bsd.port.mk>
diff --git a/databases/pypy-sqlite3/pkg-descr b/databases/pypy-sqlite3/pkg-descr
new file mode 100644
index 000000000000..8d91da89239a
--- /dev/null
+++ b/databases/pypy-sqlite3/pkg-descr
@@ -0,0 +1,8 @@
+SQLite is a library that provides a SQL-language database that
+stores data in disk files without requiring a separate server
+process. pysqlite provides a SQL interface compliant with the DB-API
+2.0 specification described by PEP 249. This means that it should
+be possible to write the first version of your applications using
+SQLite for data storage. If switching to a larger database such as
+PostgreSQL or Oracle is later necessary, the switch should be
+relatively easy.