aboutsummaryrefslogtreecommitdiff
path: root/databases/qdbm
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /databases/qdbm
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadports-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
ports-074ea5282a00d556c73d86231bec5444990597dc.zip
converters/libiconv:
- Remove const qualifier from iconv(3) to match POSIX: http://pubs.opengroup.org/onlinepubs/9699919799/functions/iconv.html - Patch iconv.h to expose more GNU extensions when LIBICONV_PLUG is defined because the base system iconv supports these extensions too. Add/remove patches to/from ports to call iconv with non-const arguments. This breaks some ports on FreeBSD 10 because base system iconv.h still has the const qualifier. Fix this by letting USES=iconv add a build dependency on converters/libiconv so ports can use its iconv.h (with LIBICONV_PLUG defined) instead of the base system iconv.h. This exposed some ports that link with libiconv when it is available instead of using libc iconv. In these cases one of the following changes has been made: - patch configure scripts to test for libc iconv first - add ac_cv_lib_iconv_libiconv=no or similar to CONFIGURE_ARGS to disable some configure tests - converters/wkhtmltopdf: this includes Qt4 so add a patch from devel/qt4 - lang/gcc5-aux: respect CFLAGS and friends during configure such that LIBICONV_PLUG is defined in the iconv test, also switch to external gettext - mail/gnarwl: replace patches with CPPFLAGS/LIBS - multimedia/ffmpeg2theora: remove iconv test from SConstruct and use ICONV_LIB in port Makefile instead, also fix a bug in subtitles.c - net-im/licq: finish conversion to cmake - net-mgmt/bandwidthd, net-mgmt/icinga, net-mgmt/nagios, net-mgmt/nagios4: don't need iconv - textproc/p5-XML-TinyXML: finish conversion to USES=perl5 Other changes: - databases/qdbm and slaves: respect CFLAGS and friends, also enable bzip2 and lzo support - games/ldmud: respect CFLAGS and friends - graphics/inventor: replace some patches with MAKE_ARGS/MAKE_ENV to respect CFLAGS and friends, also remove FreeBSD/alpha patch and add missing xorg dependencies PR: 199099 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=384038
Diffstat (limited to 'databases/qdbm')
-rw-r--r--databases/qdbm/Makefile41
-rw-r--r--databases/qdbm/files/patch-Makefile.in27
-rw-r--r--databases/qdbm/files/patch-java__Makefile.in10
-rw-r--r--databases/qdbm/files/patch-plus__Makefile.in10
4 files changed, 24 insertions, 64 deletions
diff --git a/databases/qdbm/Makefile b/databases/qdbm/Makefile
index d13a66ede1e5..e7b94b2a71dd 100644
--- a/databases/qdbm/Makefile
+++ b/databases/qdbm/Makefile
@@ -3,36 +3,39 @@
PORTNAME= qdbm
PORTVERSION= 1.8.78
-PORTREVISION= 1
+PORTREVISION?= 2
CATEGORIES= databases
MASTER_SITES= http://fallabs.com/qdbm/
MAINTAINER= ports@FreeBSD.org
COMMENT?= Quick Database Manager
+LIB_DEPENDS= liblzo2.so:${PORTSDIR}/archivers/lzo2
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CFLAGS+= -fPIC
.if !defined(SLAVEPORT)
USES+= iconv
-CONFIGURE_ARGS= --enable-zlib \
+CONFIGURE_ARGS= --enable-bzip --enable-lzo --enable-zlib \
--enable-iconv \
--enable-pthread
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
-MAKE_ARGS= RELCFLAGS="${CFLAGS}" \
- MYDATADIR="${DOCSDIR}" MYDOCS="${PORTDOCS}"
+LIBS+= -L${LOCALBASE}/lib
+MAKE_ARGS= MYDATADIR="${DOCSDIR}" MYDOCS="${PORTDOCS}" \
+ MYPCDIR="${PREFIX}/libdata/pkgconfig"
PORTDOCS= ChangeLog NEWS
post-patch:
- @${REINPLACE_CMD} -e 's|@libdir@/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.in
+.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+ @${REINPLACE_CMD} 's/-DNDEBUG//' ${WRKSRC}/Makefile.in
+.endif
+ @${REINPLACE_CMD} 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/configure
post-build:
(cd ${WRKSRC}/lab && ${MAKE} CC="${CC}" CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${ICONV_LIB}" \
+ CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
fmtcnv031127)
post-install:
@@ -43,19 +46,15 @@ post-install:
LIB_DEPENDS+= libqdbm.so:${PORTSDIR}/databases/qdbm
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/java|${JAVA_HOME}|' ${WRKSRC}/configure
-.if ${SLAVEPORT}=="ruby"
- @${FIND} ${WRKSRC} -type f | \
- ${XARGS} -n 10 ${REINPLACE_CMD} -e \
- 's|/usr/bin/ruby -w|${SETENV} ruby|'
- @${FIND} ${WRKSRC} -name '*.bak' | ${XARGS} ${RM} -f
+.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+ @${REINPLACE_CMD} 's/-DNDEBUG//' ${WRKSRC}/Makefile.in
.endif
+ @${REINPLACE_CMD} -e 's/-liconv//' -e 's/-lstdc++//' ${WRKSRC}/configure
+.if ${SLAVEPORT} == "ruby"
+ @${REINPLACE_CMD} '/iconv/d' ${WRKSRC}/curia/extconf.rb \
+ ${WRKSRC}/depot/extconf.rb ${WRKSRC}/villa/extconf.rb
.endif
-.include <bsd.port.pre.mk>
-
-.if !defined(SLAVEPORT) && defined(WITH_DEBUG)
-CONFIGURE_ARGS+= --enable-debug
-.endif
+.endif # !defined(SLAVEPORT)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/qdbm/files/patch-Makefile.in b/databases/qdbm/files/patch-Makefile.in
index e6322eb12af3..1eeb64fc78e7 100644
--- a/databases/qdbm/files/patch-Makefile.in
+++ b/databases/qdbm/files/patch-Makefile.in
@@ -1,30 +1,11 @@
---- Makefile.in.orig 2010-08-04 20:14:34.000000000 +0300
-+++ Makefile.in 2014-05-03 18:41:01.000000000 +0300
-@@ -46,7 +46,7 @@
- MYMAN1DIR = @mandir@/man1
- MYMAN3DIR = @mandir@/man3
- MYDATADIR = @datadir@/$(PACKAGE)
--MYPCDIR = @libdir@/pkgconfig
-+MYPCDIR = /usr/local/libdata/pkgconfig
- DESTDIR =
-
- # Building binaries
-@@ -56,7 +56,6 @@
+--- Makefile.in.orig 2010-08-04 17:14:34 UTC
++++ Makefile.in
+@@ -56,7 +56,7 @@ CPPFLAGS = @CPPFLAGS@ -I$(srcdir) -I$(MY
-D_XOPEN_SOURCE_EXTENDED=1 -D_GNU_SOURCE=1 -D__EXTENSIONS__=1 -D_HPUX_SOURCE=1 \
-D_POSIX_MAPPED_FILES=1 -D_POSIX_SYNCHRONIZED_IO=1 \
-DPIC=1 -D_THREAD_SAFE=1 -D_REENTRANT=1 -DNDEBUG
-CFLAGS = -Wall -pedantic -fPIC -fsigned-char -O3 -fomit-frame-pointer -fforce-addr @MYOPTS@
++CFLAGS = @CFLAGS@ -Wall -pedantic -fPIC -fsigned-char
LD = @LD@
LIBS = -lqdbm @LIBS@
LIBLDFLAGS = @LDFLAGS@ -L. -L$(MYLIBDIR) -L$(HOME)/lib -L/usr/local/lib @LIBS@
-@@ -170,8 +169,10 @@
- cd $(srcdir)/man && cp -Rf $(MYMAN1S) $(DESTDIR)$(MYMAN1DIR)
- mkdir -p $(DESTDIR)$(MYMAN3DIR)
- cd $(srcdir)/man && cp -Rf $(MYMAN3S) $(DESTDIR)$(MYMAN3DIR)
-+.if $(MYDOCS) != ""
- mkdir -p $(DESTDIR)$(MYDATADIR)
- cd $(srcdir) && cp -Rf $(MYDOCS) $(DESTDIR)$(MYDATADIR)
-+.endif
- mkdir -p $(DESTDIR)$(MYPCDIR)
- cd $(srcdir) && cp -Rf $(MYPCS) $(DESTDIR)$(MYPCDIR)
- @printf '\n'
diff --git a/databases/qdbm/files/patch-java__Makefile.in b/databases/qdbm/files/patch-java__Makefile.in
deleted file mode 100644
index 82ec1027b52a..000000000000
--- a/databases/qdbm/files/patch-java__Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- java/Makefile.in.orig 2014-05-03 18:41:15.000000000 +0300
-+++ java/Makefile.in 2014-05-03 18:41:21.000000000 +0300
-@@ -56,7 +56,6 @@
- @MYDEFS@ -D_XOPEN_SOURCE_EXTENDED=1 -D_GNU_SOURCE=1 -D__EXTENSIONS__=1 -D_HPUX_SOURCE=1 \
- -D_POSIX_MAPPED_FILES=1 -D_POSIX_SYNCHRONIZED_IO=1 \
- -DPIC=1 -D_THREAD_SAFE=1 -D_REENTRANT=1 -DNDEBUG
--CFLAGS = -Wall -fPIC -fsigned-char -O2 @MYOPTS@
- LD = @LD@
- LIBS = -lqdbm @LIBS@
- LIBLDFLAGS = @LDFLAGS@ -L. -L$(srcdir)/.. -L$(MYLIBDIR) -L$(HOME)/lib -L/usr/local/lib $(LIBS)
diff --git a/databases/qdbm/files/patch-plus__Makefile.in b/databases/qdbm/files/patch-plus__Makefile.in
deleted file mode 100644
index 35e31fe36e35..000000000000
--- a/databases/qdbm/files/patch-plus__Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- plus/Makefile.in.orig 2014-05-03 18:41:29.000000000 +0300
-+++ plus/Makefile.in 2014-05-03 18:41:32.000000000 +0300
-@@ -44,7 +44,6 @@
- -D_XOPEN_SOURCE_EXTENDED=1 -D_GNU_SOURCE=1 -D__EXTENSIONS__=1 -D_HPUX_SOURCE=1 \
- -D_POSIX_MAPPED_FILES=1 -D_POSIX_SYNCHRONIZED_IO=1 \
- -DPIC=1 -D_THREAD_SAFE=1 -D_REENTRANT=1 -DNDEBUG
--CXXFLAGS = -Wall -ansi -pedantic -fsigned-char -fPIC -O2 -fno-strict-aliasing @MYOPTS@
- LD = @LD@
- LIBS = -lqdbm @LIBS@
- LIBLDFLAGS = @LDFLAGS@ -L. -L$(srcdir)/.. -L$(MYLIBDIR) \