aboutsummaryrefslogtreecommitdiff
path: root/databases/redis/Makefile
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2024-08-16 00:27:47 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2024-08-16 02:48:45 +0000
commit6bcc3e564860111e13797541f857e41a1f2749b3 (patch)
tree0bf559095a6271f7aecf7d0252d774405628156d /databases/redis/Makefile
parente0fe408f52b9c4b2c46c196ceb88ce77379edd23 (diff)
Diffstat (limited to 'databases/redis/Makefile')
-rw-r--r--databases/redis/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index ccd4f507cd88..a6730228079f 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -1,5 +1,5 @@
PORTNAME= redis
-DISTVERSION= 7.2.5
+DISTVERSION= 7.4.0
CATEGORIES= databases
MASTER_SITES= https://download.redis.io/releases/
@@ -7,8 +7,13 @@ MAINTAINER= yasu@FreeBSD.org
COMMENT= Persistent key-value database with built-in net interface
WWW= https://redis.io/
-LICENSE= BSD3CLAUSE
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE= RSALv2 SSPLv1
+LICENSE_COMB= dual
+LICENSE_NAME_RSALv2= Redis Source Available License v2
+LICENSE_NAME_SSPLv1= Server Side Public License v1
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+LICENSE_PERMS_RSALv2= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_SSPLv1= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
USES= compiler:c11 cpe gmake tcl:test
CPE_VENDOR= redislabs
@@ -56,7 +61,7 @@ REDIS_RUNDIR?= /var/run/redis
REDIS_LOGDIR?= /var/log/redis
post-patch-JEMALLOC-on:
- @${REINPLACE_CMD} '69s!Linux!FreeBSD!g' ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} '78s!Linux!FreeBSD!g' ${WRKSRC}/src/Makefile
post-build:
${SED} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \