aboutsummaryrefslogtreecommitdiff
path: root/databases/redis62
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2022-08-07 04:31:13 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2022-08-07 05:30:30 +0000
commitda202ea08068ed0be6487ea5f2bc368bbfb0d2c2 (patch)
tree83f7cf33e534285c882a115d5e328674cd53bf75 /databases/redis62
parent206e447a8330a3dba38f4e4a1210f4f04eb7e783 (diff)
downloadports-da202ea08068ed0be6487ea5f2bc368bbfb0d2c2.tar.gz
ports-da202ea08068ed0be6487ea5f2bc368bbfb0d2c2.zip
databases/redis{6,62}: Fix problem that pkg-message is misleading
When installing package of databases/redis62, following pkg-message is displayed. To setup "redis62" you need to edit the configuration file: /usr/local/etc/redis62.conf To run redis from startup, add redis62_enable="YES" in your /etc/rc.conf. But path of configuration file is /usr/local/etc/redis.conf and what should really be added to /etc/rc.conf is redis_enable="YES". Same problem also happens when installing databases/redis6 The source of the problem is that the value of ${PORTNAME} is used to create pkg-message from file/pkg-message.in. So fix it by changing the value of ${PORTNAME} to "redis" and set PKGNAMESUFFIX in Makefile of each port. While I'm here, * Pet portlint and portclippy * Tidy up Makefile with portfmt. PR: 265623 Reported by: FiLiS MFH: 2022Q3
Diffstat (limited to 'databases/redis62')
-rw-r--r--databases/redis62/Makefile6
-rw-r--r--databases/redis62/files/extra-patch-deps_lua_src_lua__cjson.c4
-rw-r--r--databases/redis62/files/extra-patch-src-Makefile.lua4
-rw-r--r--databases/redis62/files/extra-patch-src-Makefile.luajit4
-rw-r--r--databases/redis62/files/extra-patch-src-Makefile.luajit-or4
-rw-r--r--databases/redis62/files/patch-deps-Makefile4
-rw-r--r--databases/redis62/files/patch-deps-hiredis-Makefile4
-rw-r--r--databases/redis62/files/patch-deps-hiredis-net.c4
-rw-r--r--databases/redis62/files/patch-deps_Makefile4
-rw-r--r--databases/redis62/files/patch-redis.conf4
10 files changed, 21 insertions, 21 deletions
diff --git a/databases/redis62/Makefile b/databases/redis62/Makefile
index 09111d96983e..d9733798726c 100644
--- a/databases/redis62/Makefile
+++ b/databases/redis62/Makefile
@@ -1,9 +1,9 @@
-PORTNAME= redis62
+PORTNAME= redis
DISTVERSION= 6.2.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= https://download.redis.io/releases/
-DISTNAME= redis-${PORTVERSION}
+PKGNAMESUFFIX= 62
MAINTAINER= yasu@FreeBSD.org
COMMENT= Persistent key-value database with built-in net interface
diff --git a/databases/redis62/files/extra-patch-deps_lua_src_lua__cjson.c b/databases/redis62/files/extra-patch-deps_lua_src_lua__cjson.c
index 847b70d25dea..32e322d0d490 100644
--- a/databases/redis62/files/extra-patch-deps_lua_src_lua__cjson.c
+++ b/databases/redis62/files/extra-patch-deps_lua_src_lua__cjson.c
@@ -1,5 +1,5 @@
---- deps/lua/src/lua_cjson.c.orig 2019-12-08 07:56:31.419672000 -0500
-+++ deps/lua/src/lua_cjson.c 2019-12-08 07:56:52.389362000 -0500
+--- deps/lua/src/lua_cjson.c.orig 2019-12-08 12:56:31 UTC
++++ deps/lua/src/lua_cjson.c
@@ -1299,7 +1299,7 @@
*
* luaL_setfuncs() is used to create a module table where the functions have
diff --git a/databases/redis62/files/extra-patch-src-Makefile.lua b/databases/redis62/files/extra-patch-src-Makefile.lua
index 937eeac680a2..398d415bd6e4 100644
--- a/databases/redis62/files/extra-patch-src-Makefile.lua
+++ b/databases/redis62/files/extra-patch-src-Makefile.lua
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2021-01-12 09:21:03.000000000 -0500
-+++ src/Makefile 2021-01-13 11:52:33.070529000 -0500
+--- src/Makefile.orig 2021-01-12 14:21:03 UTC
++++ src/Makefile
@@ -16,7 +16,7 @@
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not')
diff --git a/databases/redis62/files/extra-patch-src-Makefile.luajit b/databases/redis62/files/extra-patch-src-Makefile.luajit
index 3e40ea4a77a0..eef0a18eb74e 100644
--- a/databases/redis62/files/extra-patch-src-Makefile.luajit
+++ b/databases/redis62/files/extra-patch-src-Makefile.luajit
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2021-01-12 09:21:03.000000000 -0500
-+++ src/Makefile 2021-01-13 12:25:07.823451000 -0500
+--- src/Makefile.orig 2021-01-12 14:21:03 UTC
++++ src/Makefile
@@ -16,7 +16,7 @@
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not')
diff --git a/databases/redis62/files/extra-patch-src-Makefile.luajit-or b/databases/redis62/files/extra-patch-src-Makefile.luajit-or
index 3926e8169300..ca57ef49c35c 100644
--- a/databases/redis62/files/extra-patch-src-Makefile.luajit-or
+++ b/databases/redis62/files/extra-patch-src-Makefile.luajit-or
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2021-01-12 09:21:03.000000000 -0500
-+++ src/Makefile 2021-01-13 12:27:19.444193000 -0500
+--- src/Makefile.orig 2021-01-12 14:21:03 UTC
++++ src/Makefile
@@ -16,7 +16,7 @@
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not')
diff --git a/databases/redis62/files/patch-deps-Makefile b/databases/redis62/files/patch-deps-Makefile
index c2a757c59b33..84a2f6dcbc60 100644
--- a/databases/redis62/files/patch-deps-Makefile
+++ b/databases/redis62/files/patch-deps-Makefile
@@ -1,5 +1,5 @@
---- deps/Makefile.orig 2021-01-12 09:21:03.000000000 -0500
-+++ deps/Makefile 2021-01-13 11:37:45.979445000 -0500
+--- deps/Makefile.orig 2021-01-12 14:21:03 UTC
++++ deps/Makefile
@@ -69,7 +69,7 @@
LUA_CFLAGS= -D__C99FEATURES__=1
endif
diff --git a/databases/redis62/files/patch-deps-hiredis-Makefile b/databases/redis62/files/patch-deps-hiredis-Makefile
index 9422ba8d3245..aec6b29a7b2e 100644
--- a/databases/redis62/files/patch-deps-hiredis-Makefile
+++ b/databases/redis62/files/patch-deps-hiredis-Makefile
@@ -1,5 +1,5 @@
---- deps/hiredis/Makefile.orig 2021-01-12 09:21:03.000000000 -0500
-+++ deps/hiredis/Makefile 2021-01-13 11:40:26.109827000 -0500
+--- deps/hiredis/Makefile.orig 2021-01-12 14:21:03 UTC
++++ deps/hiredis/Makefile
@@ -21,7 +21,7 @@
HIREDIS_SONAME=$(shell grep HIREDIS_SONAME hiredis.h | awk '{print $$3}')
diff --git a/databases/redis62/files/patch-deps-hiredis-net.c b/databases/redis62/files/patch-deps-hiredis-net.c
index 3fd2b5996f97..0dfde3135238 100644
--- a/databases/redis62/files/patch-deps-hiredis-net.c
+++ b/databases/redis62/files/patch-deps-hiredis-net.c
@@ -1,5 +1,5 @@
---- deps/hiredis/net.c.orig 2019-11-28 14:32:05.942453000 -0500
-+++ deps/hiredis/net.c 2019-11-28 14:39:08.326408000 -0500
+--- deps/hiredis/net.c.orig 2019-11-28 19:32:05 UTC
++++ deps/hiredis/net.c
@@ -178,14 +178,34 @@
__redisSetError(c,REDIS_ERR_OTHER,strerror(errno));
return REDIS_ERR;
diff --git a/databases/redis62/files/patch-deps_Makefile b/databases/redis62/files/patch-deps_Makefile
index 39dadb06b822..354558054689 100644
--- a/databases/redis62/files/patch-deps_Makefile
+++ b/databases/redis62/files/patch-deps_Makefile
@@ -1,5 +1,5 @@
---- deps/Makefile.orig 2021-01-13 11:43:05.174197000 -0500
-+++ deps/Makefile 2021-01-13 11:44:13.744658000 -0500
+--- deps/Makefile.orig 2021-01-13 16:43:05 UTC
++++ deps/Makefile
@@ -83,12 +83,12 @@
.PHONY: lua
diff --git a/databases/redis62/files/patch-redis.conf b/databases/redis62/files/patch-redis.conf
index f71797d9555e..b653f89a3211 100644
--- a/databases/redis62/files/patch-redis.conf
+++ b/databases/redis62/files/patch-redis.conf
@@ -1,5 +1,5 @@
---- redis.conf.orig 2021-01-12 09:21:03.000000000 -0500
-+++ redis.conf 2021-01-13 11:46:40.445746000 -0500
+--- redis.conf.orig 2021-01-12 14:21:03 UTC
++++ redis.conf
@@ -244,7 +244,7 @@
# By default Redis does not run as a daemon. Use 'yes' if you need it.
# Note that Redis will write a pid file in /var/run/redis.pid when daemonized.