aboutsummaryrefslogtreecommitdiff
path: root/databases/retcl/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2017-05-10 10:37:26 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2017-05-10 10:37:26 +0000
commit5e575adefaeae14b0c98dfd3af38be3d1375eb9c (patch)
tree227c293f6fe207c97ab569d118ac84e1b0ed9171 /databases/retcl/Makefile
parent570d9fb6fddbd8dde79b9d34bd871bc3105fe6bd (diff)
downloadports-5e575adefaeae14b0c98dfd3af38be3d1375eb9c.tar.gz
ports-5e575adefaeae14b0c98dfd3af38be3d1375eb9c.zip
Notes
Diffstat (limited to 'databases/retcl/Makefile')
-rw-r--r--databases/retcl/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/databases/retcl/Makefile b/databases/retcl/Makefile
new file mode 100644
index 000000000000..8288aecb70b9
--- /dev/null
+++ b/databases/retcl/Makefile
@@ -0,0 +1,28 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= retcl
+PORTVERSION= 0.2.0
+CATEGORIES= databases
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Tcl client library for Redis
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= tcl:run
+USE_GITHUB= yes
+GH_ACCOUNT= gahr
+
+NO_BUILD= yes
+
+LIBDIR= ${TCL_LIBDIR:S/${LOCALBASE}/${PREFIX}/}
+PLIST_FILES= ${LIBDIR}/${PORTNAME}-${DISTVERSION}.tm
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${LIBDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.tm \
+ ${STAGEDIR}${LIBDIR}/${PORTNAME}-${DISTVERSION}.tm
+
+.include <bsd.port.mk>