aboutsummaryrefslogtreecommitdiff
path: root/databases/rocksdb
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-12-28 06:56:08 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-12-28 06:56:08 +0000
commit588bb55bd2c3320409941af57013fc661c13a803 (patch)
treefb6d6f6f099afdc092549683105055ceda7c09dc /databases/rocksdb
parentba8d4b832800cfdbe59bce2bacd70e021d93ce4c (diff)
downloadports-588bb55bd2c3320409941af57013fc661c13a803.tar.gz
ports-588bb55bd2c3320409941af57013fc661c13a803.zip
Update to 6.5.2
Notes
Notes: svn path=/head/; revision=521053
Diffstat (limited to 'databases/rocksdb')
-rw-r--r--databases/rocksdb/Makefile4
-rw-r--r--databases/rocksdb/distinfo6
-rw-r--r--databases/rocksdb/files/patch-table-get_context.h10
3 files changed, 5 insertions, 15 deletions
diff --git a/databases/rocksdb/Makefile b/databases/rocksdb/Makefile
index 9c633264061f..42264060684f 100644
--- a/databases/rocksdb/Makefile
+++ b/databases/rocksdb/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rocksdb
-PORTVERSION= 6.4.6
+PORTVERSION= 6.5.2
DISTVERSIONPREFIX= v
CATEGORIES= databases
@@ -84,7 +84,7 @@ post-patch:
.if ${ARCH} != amd64 && ${ARCH} != i386
@${REINPLACE_CMD} -e 's| -march=native||' ${WRKSRC}/build_tools/build_detect_platform
.endif
- @${REINPLACE_CMD} -e 's|#include "gtest/gtest.h"|#include "gtest.h"|' ${WRKSRC}/third-party/gtest-1.7.0/fused-src/gtest/gtest-all.cc
+ @${REINPLACE_CMD} -e 's|#include "gtest/gtest.h"|#include "gtest.h"|' ${WRKSRC}/third-party/gtest-1.8.1/fused-src/gtest/gtest-all.cc
.if defined(WITHOUT_PROFILE)
@${REINPLACE_CMD} -e '/pg = / s| -pg||' ${WRKSRC}/Makefile
.endif
diff --git a/databases/rocksdb/distinfo b/databases/rocksdb/distinfo
index 0f602259dc2f..797e786ef981 100644
--- a/databases/rocksdb/distinfo
+++ b/databases/rocksdb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1573888131
-SHA256 (facebook-rocksdb-v6.4.6_GH0.tar.gz) = 540bbf9369a31e0891fcb4056a36ffa439c59fc179aa0b1f46e3478417f97643
-SIZE (facebook-rocksdb-v6.4.6_GH0.tar.gz) = 5651221
+TIMESTAMP = 1577145713
+SHA256 (facebook-rocksdb-v6.5.2_GH0.tar.gz) = a923e36aa1cdd1429ae93a0b26baf477c714060ce7dd1c52e873754e1468d7ff
+SIZE (facebook-rocksdb-v6.5.2_GH0.tar.gz) = 5785217
diff --git a/databases/rocksdb/files/patch-table-get_context.h b/databases/rocksdb/files/patch-table-get_context.h
deleted file mode 100644
index b566b6d87b02..000000000000
--- a/databases/rocksdb/files/patch-table-get_context.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- table/get_context.h.orig 2019-10-30 17:32:00 UTC
-+++ table/get_context.h
-@@ -88,7 +88,6 @@ class GetContext {
- ReadCallback* callback = nullptr, bool* is_blob_index = nullptr,
- uint64_t tracing_get_id = 0);
-
-- GetContext() = default;
-
- // This can be called to indicate that a key may be present, but cannot be
- // confirmed due to IO not allowed