aboutsummaryrefslogtreecommitdiff
path: root/databases/rrdtool/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-11-25 13:36:44 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-11-25 13:36:44 +0000
commit25f357e2717ecb05e290b320b1a37fff4dd2576b (patch)
treeabe7a0c8e3a6b2d1dc15f3a3ff2f53299c5094fa /databases/rrdtool/Makefile
parent368689629194005819e2b5259c85fd1ff75826af (diff)
downloadports-25f357e2717ecb05e290b320b1a37fff4dd2576b.tar.gz
ports-25f357e2717ecb05e290b320b1a37fff4dd2576b.zip
Notes
Diffstat (limited to 'databases/rrdtool/Makefile')
-rw-r--r--databases/rrdtool/Makefile27
1 files changed, 6 insertions, 21 deletions
diff --git a/databases/rrdtool/Makefile b/databases/rrdtool/Makefile
index f2f6887bf9b0..64674699a417 100644
--- a/databases/rrdtool/Makefile
+++ b/databases/rrdtool/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rrdtool
-PORTVERSION= 1.4.7
-PORTREVISION= 2
+PORTVERSION= 1.4.8
CATEGORIES= databases graphics
MASTER_SITES= http://oss.oetiker.ch/rrdtool/pub/
@@ -12,11 +11,11 @@ COMMENT= Round Robin Database Tools
LICENSE= GPLv2
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
- cairo.2:${PORTSDIR}/graphics/cairo \
- png15:${PORTSDIR}/graphics/png \
- xml2:${PORTSDIR}/textproc/libxml2 \
- pangocairo-1\.0.0:${PORTSDIR}/x11-toolkits/pango
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libcairo.so:${PORTSDIR}/graphics/cairo \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libxml2.so:${PORTSDIR}/textproc/libxml2 \
+ libpangocairo-1.0.so:${PORTSDIR}/x11-toolkits/pango
CONFLICTS= rrdtool-1.0* rrdtool-1.2*
@@ -42,7 +41,6 @@ PERL_MODULE_DESC= Build PERL module
PYTHON_MODULE_DESC= Build PYTHON bindings
RUBY_MODULE_DESC= Build RUBY bindings
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON_MODULE}
@@ -92,19 +90,6 @@ CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
##LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS:= ${CFLAGS:N-ffast-math}
-MAN1= bin_dec_hex.1 cdeftutorial.1 rpntutorial.1 rrd-beginners.1 \
- rrdbuild.1 rrdcached.1 rrdcgi.1 rrdcreate.1 rrddump.1 \
- rrdfetch.1 rrdfirst.1 rrdflushcached.1 rrdgraph.1 \
- rrdgraph_data.1 rrdgraph_examples.1 rrdgraph_graph.1 \
- rrdgraph_rpn.1 rrdinfo.1 rrdlast.1 rrdlastupdate.1 \
- rrdresize.1 rrdrestore.1 rrdthreads.1 rrdtool.1 rrdtune.1 \
- rrdtutorial.1 rrdupdate.1 rrdxport.1
-
-.if ${PORT_OPTIONS:MPERL_MODULE}
-MAN3= RRDp.3 RRDs.3
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}
-.endif
-
post-extract:
@${REINPLACE_CMD} -e 's/^POD3/#POD3/' ${WRKSRC}/doc/Makefile.in
.if ! ${PORT_OPTIONS:MDOCS}