aboutsummaryrefslogtreecommitdiff
path: root/databases/rrdtool12
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2012-10-05 15:02:43 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2012-10-05 15:02:43 +0000
commit3c40faf631062349c474d5d98e8553cef4bff0ec (patch)
treee763ddf9056af761224bb746fa64db2fcf10f9a7 /databases/rrdtool12
parent5acc115897b33077e2164648e79d94a983931596 (diff)
downloadports-3c40faf631062349c474d5d98e8553cef4bff0ec.tar.gz
ports-3c40faf631062349c474d5d98e8553cef4bff0ec.zip
- Convert to optionsng
- Trim Makefile header
Notes
Notes: svn path=/head/; revision=305303
Diffstat (limited to 'databases/rrdtool12')
-rw-r--r--databases/rrdtool12/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/databases/rrdtool12/Makefile b/databases/rrdtool12/Makefile
index 49ebe9256867..9edaf036cd82 100644
--- a/databases/rrdtool12/Makefile
+++ b/databases/rrdtool12/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rrdtool12
-# Date created: 2 September 2008
-# Whom: Jeremy Chadwick <koitsu@FreeBSD.org>
-#
+# Created by: Jeremy Chadwick <koitsu@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= rrdtool
PORTVERSION= 1.2.30
@@ -30,13 +26,12 @@ WANT_PERL= yes
CONFIGURE_ARGS= --disable-tcl
-OPTIONS= PYTHON_MODULE "Build PYTHON bindings" off \
- RUBY_MODULE "Build RUBY bindings" off \
- PERL_MODULE "Build PERL module" on
+OPTIONS_DEFINE= PYTHON RUBY PERL DOCS EXAMPLES
+OPTIONS_DEFAULT= PERL
.include <bsd.port.pre.mk>
-.if defined(WITH_PYTHON_MODULE)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
INSTALLS_EGGINFO=yes
PYDISTUTILS_EGGINFO=py_rrdtool-0.2.1-${PYTHON_VERSION:S/thon//}.egg-info
@@ -48,7 +43,7 @@ CONFIGURE_ARGS+= --disable-python
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
-.if defined(WITH_RUBY_MODULE)
+.if ${PORT_OPTIONS:MRUBY}
USE_RUBY= yes
.include "${PORTSDIR}/Mk/bsd.ruby.mk"
PLIST_SUB+= WITH_RUBY=""
@@ -58,7 +53,7 @@ CONFIGURE_ARGS+= --disable-ruby
PLIST_SUB+= WITH_RUBY="@comment "
.endif
-.if !defined(WITHOUT_PERL_MODULE)
+.if ${PORT_OPTIONS:MPERL}
USE_PERL5= yes
CONFIGURE_ARGS+= --enable-perl --enable-perl-site-install
PLIST_SUB+= WITH_PERL=""
@@ -78,24 +73,24 @@ MAN1= bin_dec_hex.1 cdeftutorial.1 rpntutorial.1 rrd-beginners.1 \
rrdthreads.1 rrdtool.1 rrdtune.1 rrdtutorial.1 rrdupdate.1 \
rrdxport.1 rrdlastupdate.1
-.if !defined(WITHOUT_PERL_MODULE)
+.if ${PORT_OPTIONS:MPERL}
MAN3= RRDp.3 RRDs.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.endif
post-extract:
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} -e 's/install-idocDATA install-ihtmlDATA//g' \
-e 's/^ cd .* rrdtool.html index.html/ #/' \
${WRKSRC}/doc/Makefile.in
.endif
-.if defined(NOPORTEXAMPLES)
+.if empty(PORT_OPTIONS:MEXAMPLES)
${REINPLACE_CMD} -e '/^SUBDIRS = /s| examples | |' \
${WRKSRC}/Makefile.in
.endif
post-install:
-.if !defined(BATCH) && !defined(NOPORTEXAMPLES)
+.if !defined(BATCH) && empty(PORT_OPTIONS:MEXAMPLES)
@${ECHO_MSG} ""
@${ECHO_MSG} "############################################################################"
@${ECHO_MSG} "# See ${PREFIX}/share/examples/rrdtool for some demonstration code #"