aboutsummaryrefslogtreecommitdiff
path: root/databases/rrdtool
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2016-01-27 11:48:09 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2016-01-27 11:48:09 +0000
commit780a75041fb23996c49a4c7f6c4a85fb68a4fb70 (patch)
tree1fdca7026d5f7b5658ecb4e30116244882b0addb /databases/rrdtool
parent370b5b17f388a8fb34132165f2572a08aac96162 (diff)
downloadports-780a75041fb23996c49a4c7f6c4a85fb68a4fb70.tar.gz
ports-780a75041fb23996c49a4c7f6c4a85fb68a4fb70.zip
Update to 1.5.5
Rework the DEJAVU option to actually work. [1] Before this commit rrdtool depends on x11-fonts/dejavu if that port is already installed, but not otherwise, and this sort of implicit dependencies are bad. Make the DEJAVU option default to on. If cairo and pango are built without X11 support, please consider disabling this option to avoid pulling in large parts of X11 Remove the JSON option. This is a third party patch that doesn't apply any more. Feel free to port it to this version of RRDTool. Discussed with: marino [1] PR: 205883 [1] Submitted by: marino [1]
Notes
Notes: svn path=/head/; revision=407355
Diffstat (limited to 'databases/rrdtool')
-rw-r--r--databases/rrdtool/Makefile17
-rw-r--r--databases/rrdtool/distinfo4
-rw-r--r--databases/rrdtool/files/patch-bindings-Makefile.in43
-rw-r--r--databases/rrdtool/files/patch-bindings_perl-shared_Makefile.PL11
-rw-r--r--databases/rrdtool/files/patch-configure6
-rw-r--r--databases/rrdtool/files/patch-doc-Makefile.in8
-rw-r--r--databases/rrdtool/files/patch-examples-Makefile.in12
-rw-r--r--databases/rrdtool/files/patch-examples_rrdcached_Makefile.in11
-rw-r--r--databases/rrdtool/files/patch-src-rrd_open.c12
-rw-r--r--databases/rrdtool/files/patch-src__rrd_graph.c68
-rw-r--r--databases/rrdtool/files/patch-src__rrdupdate.c16
-rw-r--r--databases/rrdtool/files/thirdparty-json.diff112
-rw-r--r--databases/rrdtool/pkg-plist17
13 files changed, 56 insertions, 281 deletions
diff --git a/databases/rrdtool/Makefile b/databases/rrdtool/Makefile
index 7fb2d10a6cfc..90e1996358e9 100644
--- a/databases/rrdtool/Makefile
+++ b/databases/rrdtool/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rrdtool
-PORTVERSION= 1.4.8
-PORTREVISION= 9
+PORTVERSION= 1.5.5
CATEGORIES= databases graphics
MASTER_SITES= http://oss.oetiker.ch/rrdtool/pub/
@@ -27,12 +26,11 @@ CONFIGURE_ARGS= --disable-tcl --disable-silent-rules
PORTEXAMPLES= 4charts.pl bigtops.pl cgi-demo.cgi minmax.pl perftest.pl \
piped-demo.pl shared-demo.pl stripes.pl
-OPTIONS_DEFINE= DEJAVU GRAPH JSON MMAP NLS PERL_MODULE PYTHON_MODULE \
+OPTIONS_DEFINE= DEJAVU GRAPH MMAP NLS PERL_MODULE PYTHON_MODULE \
RUBY_MODULE EXAMPLES DOCS
-OPTIONS_DEFAULT= GRAPH MMAP PERL_MODULE
+OPTIONS_DEFAULT= DEJAVU GRAPH MMAP PERL_MODULE
GRAPH_DESC= Enable the rrdtool graph command (needs cairo)
DEJAVU_DESC= Use DejaVu fonts (requires X11)
-JSON_DESC= Support of json export
MMAP_DESC= Use mmap in rrd_update
PERL_MODULE_DESC= Build PERL module
PYTHON_MODULE_DESC= Build PYTHON bindings
@@ -73,10 +71,6 @@ PLIST_SUB+= WITH_PERL="@comment "
CONFIGURE_ARGS+= --disable-mmap
.endif
-.if ${PORT_OPTIONS:MJSON}
-EXTRA_PATCHES+= ${FILESDIR}/thirdparty-json.diff
-.endif
-
.if ${PORT_OPTIONS:MGRAPH}
LIB_DEPENDS+= libfreetype.so:${PORTSDIR}/print/freetype2 \
libpng.so:${PORTSDIR}/graphics/png
@@ -94,7 +88,7 @@ USE_GNOME+= intltool
CONFIGURE_ARGS+=--disable-nls
.endif
-.if exists(${LOCALBASE}/share/fonts/dejavu) || ${PORT_OPTIONS:MDEJAVU}
+.if ${PORT_OPTIONS:MDEJAVU}
RUN_DEPENDS+= dejavu>0:${PORTSDIR}/x11-fonts/dejavu
.endif
@@ -122,8 +116,5 @@ post-install:
@${ECHO_MSG} "# See ${EXAMPLESDIR} for some demonstration code #"
@${ECHO_MSG} "############################################################################"
.endif
-.if ${PORT_OPTIONS:MPERL_MODULE}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/RRDs/RRDs.so
-.endif
.include <bsd.port.mk>
diff --git a/databases/rrdtool/distinfo b/databases/rrdtool/distinfo
index 203777f0844f..84fac4a8cd90 100644
--- a/databases/rrdtool/distinfo
+++ b/databases/rrdtool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rrdtool-1.4.8.tar.gz) = de95b9f5aa488b0683600aad5a07c316f8d98cbe8d00aa0a1c87e2b2ef89f3d6
-SIZE (rrdtool-1.4.8.tar.gz) = 1379482
+SHA256 (rrdtool-1.5.5.tar.gz) = 3a286d449c05d657e3fc3adcaa5cb4f0cfac8f465324b14f364a45d4ff8ca6f6
+SIZE (rrdtool-1.5.5.tar.gz) = 2187685
diff --git a/databases/rrdtool/files/patch-bindings-Makefile.in b/databases/rrdtool/files/patch-bindings-Makefile.in
index 5f4563ab8feb..9d4e5f6ad2cf 100644
--- a/databases/rrdtool/files/patch-bindings-Makefile.in
+++ b/databases/rrdtool/files/patch-bindings-Makefile.in
@@ -1,24 +1,21 @@
---- bindings/Makefile.in.orig 2010-03-23 01:30:03.000000000 +0800
-+++ bindings/Makefile.in 2010-04-26 03:43:31.000000000 +0800
-@@ -696,9 +696,9 @@
- all-local: @COMP_PERL@ @COMP_RUBY@ @COMP_PYTHON@
-
+--- bindings/Makefile.in.orig 2016-01-27 10:49:53 UTC
++++ bindings/Makefile.in
+@@ -711,15 +711,15 @@ all-local: @COMP_PERL@ @COMP_RUBY@ @COM
install-data-local:
-- $(AM_V_GEN)test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
-- $(AM_V_GEN)test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
-- $(AM_V_GEN)test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
-+ $(AM_V_GEN)test -f perl-piped/Makefile && cd perl-piped && $(MAKE) pure_install || true
-+ $(AM_V_GEN)test -f perl-shared/Makefile && cd perl-shared && $(MAKE) pure_install || true
-+ $(AM_V_GEN)test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) install || true
- $(AM_V_GEN)test -d python/build && cd python && env BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py install --skip-build --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
-
- # rules for building the ruby module
-@@ -709,7 +709,7 @@
-
- # rules for building the pyton module
- python: Makefile
-- cd python && env BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py build_ext --rpath=$(libdir) && env LIBDIR=../../src/.libs $(PYTHON) setup.py build
-+ cd python && env INCDIR=../../src BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py build_ext --rpath=$(libdir) && env LIBDIR=../../src/.libs $(PYTHON) setup.py build
-
- # rules for building the perl module
- perl_piped: perl-piped/Makefile
+ $(AM_V_GEN)test -f ${builddir}/perl-piped/Makefile \
+ && ( cd ${builddir}/perl-piped \
+- && $(MAKE) install ) \
++ && $(MAKE) pure-install ) \
+ || true
+ $(AM_V_GEN)test -f ${builddir}/perl-shared/Makefile \
+ && ( cd ${builddir}/perl-shared \
+- && $(MAKE) install ) \
++ && $(MAKE) pure-install ) \
+ || true
+ $(AM_V_GEN)test -f ${builddir}/ruby/Makefile \
+ && ( cd ${builddir}/ruby \
+- && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install ) \
++ && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) pure-install ) \
+ || true
+ $(AM_V_GEN)test -d ${builddir}/python/build \
+ && ( cd ${builddir}/python \
diff --git a/databases/rrdtool/files/patch-bindings_perl-shared_Makefile.PL b/databases/rrdtool/files/patch-bindings_perl-shared_Makefile.PL
deleted file mode 100644
index 1cd7bd9ff7fc..000000000000
--- a/databases/rrdtool/files/patch-bindings_perl-shared_Makefile.PL
+++ /dev/null
@@ -1,11 +0,0 @@
---- bindings/perl-shared/Makefile.PL.orig 2014-04-19 13:00:18.000000000 +0200
-+++ bindings/perl-shared/Makefile.PL 2014-04-19 13:13:26.000000000 +0200
-@@ -31,7 +31,7 @@
- /linux/ && do{ $R = "-Wl,--rpath -Wl,$rp"};
- /hpux/ && do{ $R = "+b$rp"};
- /solaris/ && do{ $R = "-R$rp"};
-- /bsd/ && do{ $R = "-R$rp"};
-+ /bsd/ && do{ $R = "-Wl,--rpath -Wl,$rp"};
- /aix/ && do{ $R = "-blibpath:$rp"};
- }
- }
diff --git a/databases/rrdtool/files/patch-configure b/databases/rrdtool/files/patch-configure
index baf59b07e1af..b8c70e3432c4 100644
--- a/databases/rrdtool/files/patch-configure
+++ b/databases/rrdtool/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2013-05-23 09:55:19.000000000 +0200
-+++ configure 2014-07-15 19:59:43.000000000 +0200
-@@ -12846,7 +12846,7 @@
+--- configure.orig 2015-11-10 16:59:23 UTC
++++ configure
+@@ -13172,7 +13172,7 @@ fi
if test "x$GCC" = "xyes"; then
diff --git a/databases/rrdtool/files/patch-doc-Makefile.in b/databases/rrdtool/files/patch-doc-Makefile.in
index 8485cde01277..9fc94f8f7fcf 100644
--- a/databases/rrdtool/files/patch-doc-Makefile.in
+++ b/databases/rrdtool/files/patch-doc-Makefile.in
@@ -1,9 +1,9 @@
---- doc/Makefile.in.orig 2010-04-26 03:40:16.000000000 +0800
-+++ doc/Makefile.in 2010-04-26 03:44:14.000000000 +0800
-@@ -344,9 +344,9 @@
+--- doc/Makefile.in.orig 2016-01-27 10:49:53 UTC
++++ doc/Makefile.in
+@@ -377,9 +377,9 @@ CLEANFILES = $(GENERATED_EXTRADIST) pod2
# what should go into the distribution
- EXTRA_DIST = $(POD) $(POD3) $(HTML) $(MAN) $(MAN3) $(TXT) rrdtool-dump.dtd rrdtool-xport.dtd rrdgraph_libdbi.pod rrdlua.pod
+ EXTRA_DIST = $(GENERATED_EXTRADIST) $(POD) $(POD3) rrdtool-dump.dtd rrdtool-xport.dtd rrdgraph_libdbi.pod rrdlua.pod
-idocdir = $(RRDDOCDIR)/txt
+idocdir = $(datadir)/doc/rrdtool/txt
idoc_DATA = $(POD) $(TXT)
diff --git a/databases/rrdtool/files/patch-examples-Makefile.in b/databases/rrdtool/files/patch-examples-Makefile.in
index f8e70fc686f5..864a9633dc20 100644
--- a/databases/rrdtool/files/patch-examples-Makefile.in
+++ b/databases/rrdtool/files/patch-examples-Makefile.in
@@ -1,11 +1,11 @@
---- examples/Makefile.in.orig 2010-03-23 01:30:04.000000000 +0800
-+++ examples/Makefile.in 2010-04-26 03:45:47.000000000 +0800
-@@ -369,7 +369,7 @@
+--- examples/Makefile.in.orig 2016-01-27 10:49:53 UTC
++++ examples/Makefile.in
+@@ -420,7 +420,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
SUBDIRS = rrdcached
- EXTRA_DIST = cgi-demo.cgi.in
+ EXTRA_DIST = cgi-demo.cgi.in stripes.py
-examplesdir = $(pkgdatadir)/examples
+examplesdir = $(datadir)/examples/rrdtool
examples_SCRIPTS = cgi-demo.cgi piped-demo.pl shared-demo.pl \
- stripes.pl bigtops.pl minmax.pl 4charts.pl perftest.pl
-
+ stripes.pl bigtops.pl minmax.pl 4charts.pl perftest.pl \
+ stripes.py
diff --git a/databases/rrdtool/files/patch-examples_rrdcached_Makefile.in b/databases/rrdtool/files/patch-examples_rrdcached_Makefile.in
new file mode 100644
index 000000000000..a14b3bbeb369
--- /dev/null
+++ b/databases/rrdtool/files/patch-examples_rrdcached_Makefile.in
@@ -0,0 +1,11 @@
+--- examples/rrdcached/Makefile.in.orig 2016-01-27 10:49:53 UTC
++++ examples/rrdcached/Makefile.in
+@@ -356,7 +356,7 @@ target_vendor = @target_vendor@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-examplesdir = $(pkgdatadir)/examples/rrdcached
++examplesdir = $(datadir)/examples/rrdtool/rrdcached
+ examples_SCRIPTS = rrdcached-size.pl
+ examples_DATA = RRDCached.pm
+ EXTRA_DIST = $(examples_DATA) $(examples_SCRIPTS)
diff --git a/databases/rrdtool/files/patch-src-rrd_open.c b/databases/rrdtool/files/patch-src-rrd_open.c
deleted file mode 100644
index 330547004f6c..000000000000
--- a/databases/rrdtool/files/patch-src-rrd_open.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/rrd_open.c.orig 2010-03-23 00:05:55.000000000 +0800
-+++ src/rrd_open.c 2010-04-26 03:46:23.000000000 +0800
-@@ -555,9 +555,6 @@
- int ret;
-
- #ifdef HAVE_MMAP
-- ret = msync(rrd_simple_file->file_start, rrd_file->file_len, MS_ASYNC);
-- if (ret != 0)
-- rrd_set_error("msync rrd_file: %s", rrd_strerror(errno));
- ret = munmap(rrd_simple_file->file_start, rrd_file->file_len);
- if (ret != 0)
- rrd_set_error("munmap rrd_file: %s", rrd_strerror(errno));
diff --git a/databases/rrdtool/files/patch-src__rrd_graph.c b/databases/rrdtool/files/patch-src__rrd_graph.c
deleted file mode 100644
index 5cccdcf53c73..000000000000
--- a/databases/rrdtool/files/patch-src__rrd_graph.c
+++ /dev/null
@@ -1,68 +0,0 @@
---- src/rrd_graph.c.orig 2013-05-23 09:55:07.000000000 +0200
-+++ src/rrd_graph.c 2014-07-20 22:11:58.000000000 +0200
-@@ -305,6 +305,52 @@
-
- #undef conv_if
-
-+
-+static int bad_format_imginfo(
-+ char *fmt)
-+{
-+ char *ptr;
-+ int n = 0;
-+
-+ ptr = fmt;
-+ while (*ptr != '\0')
-+ if (*ptr++ == '%') {
-+
-+ /* line cannot end with percent char */
-+ if (*ptr == '\0')
-+ return 1;
-+ /* '%%' is allowed */
-+ if (*ptr == '%')
-+ ptr++;
-+ /* '%s', '%S' are allowed */
-+ else if (*ptr == 's' || *ptr == 'S') {
-+ n = 1;
-+ ptr++;
-+ }
-+
-+ /* or else '% 4lu' and such are allowed */
-+ else {
-+ /* optional padding character */
-+ if (*ptr == ' ')
-+ ptr++;
-+ /* This should take care of 'm' */
-+ while (*ptr >= '0' && *ptr <= '9')
-+ ptr++;
-+ /* 'lu' must follow here */
-+ if (*ptr++ != 'l')
-+ return 1;
-+ if (*ptr == 'u')
-+ ptr++;
-+ else
-+ return 1;
-+ n++;
-+ }
-+ }
-+
-+ return (n != 3);
-+}
-+
-+
- int im_free(
- image_desc_t *im)
- {
-@@ -4022,6 +4068,12 @@
- char *path;
- char *filename;
-
-+ if (bad_format_imginfo(im.imginfo)) {
-+ rrd_info_free(im.grinfo);
-+ im_free(&im);
-+ rrd_set_error("bad format for imginfo");
-+ return NULL;
-+ }
- path = strdup(im.graphfile);
- filename = basename(path);
- info.u_str =
diff --git a/databases/rrdtool/files/patch-src__rrdupdate.c b/databases/rrdtool/files/patch-src__rrdupdate.c
deleted file mode 100644
index 083dadd43647..000000000000
--- a/databases/rrdtool/files/patch-src__rrdupdate.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/rrdupdate.c.orig 2014-08-12 20:19:23.000000000 -0400
-+++ src/rrdupdate.c 2014-08-12 20:19:50.000000000 -0400
-@@ -15,7 +15,12 @@
- #endif
-
- #include "rrd.h"
--#include "plbasename.h"
-+
-+#ifdef HAVE_LIBGEN_H
-+# include <libgen.h>
-+#else
-+# include "plbasename.h"
-+#endif
-
- int main(
- int argc,
diff --git a/databases/rrdtool/files/thirdparty-json.diff b/databases/rrdtool/files/thirdparty-json.diff
deleted file mode 100644
index 95159feb1add..000000000000
--- a/databases/rrdtool/files/thirdparty-json.diff
+++ /dev/null
@@ -1,112 +0,0 @@
---- src/rrd_tool.c.orig 2012-01-24 08:08:48.000000000 -0200
-+++ src/rrd_tool.c 2012-05-11 15:57:51.000000000 -0300
-@@ -57,7 +57,7 @@
- N_
- ("Valid commands: create, update, updatev, graph, graphv, dump, restore,\n"
- "\t\tlast, lastupdate, first, info, fetch, tune,\n"
-- "\t\tresize, xport, flushcached\n");
-+ "\t\tresize, xport, json, flushcached\n");
-
- const char *help_listremote =
- N_("Valid remote commands: quit, ls, cd, mkdir, pwd\n");
-@@ -210,6 +210,13 @@
- "\t\t[--enumds] [--json]\n" "\t\t[DEF:vname=rrd:ds-name:CF]\n"
- "\t\t[CDEF:vname=rpn-expression]\n"
- "\t\t[XPORT:vname:legend]\n");
-+ const char *help_json =
-+ N_("* json - generate JSON dump from one or several RRD\n\n"
-+ "\trrdtool json [-s|--start seconds] [-e|--end seconds]\n"
-+ "\t\t[-m|--maxrows rows]\n" "\t\t[--step seconds]\n"
-+ "\t\t[DEF:vname=rrd:ds-name:CF]\n"
-+ "\t\t[CDEF:vname=rpn-expression]\n"
-+ "\t\t[XPORT:vname:legend]\n");
- const char *help_quit =
- N_(" * quit - closing a session in remote mode\n\n"
- "\trrdtool quit\n");
-@@ -232,7 +239,7 @@
- enum { C_NONE, C_CREATE, C_DUMP, C_INFO, C_RESTORE, C_LAST,
- C_LASTUPDATE, C_FIRST, C_UPDATE, C_FETCH, C_GRAPH, C_GRAPHV,
- C_TUNE,
-- C_RESIZE, C_XPORT, C_QUIT, C_LS, C_CD, C_MKDIR, C_PWD,
-+ C_RESIZE, C_XPORT, C_JSON, C_QUIT, C_LS, C_CD, C_MKDIR, C_PWD,
- C_UPDATEV, C_FLUSHCACHED
- };
- int help_cmd = C_NONE;
-@@ -270,6 +277,8 @@
- help_cmd = C_RESIZE;
- else if (!strcmp(cmd, "xport"))
- help_cmd = C_XPORT;
-+ else if (!strcmp(cmd, "json"))
-+ help_cmd = C_JSON;
- else if (!strcmp(cmd, "quit"))
- help_cmd = C_QUIT;
- else if (!strcmp(cmd, "ls"))
-@@ -345,6 +354,9 @@
- case C_XPORT:
- puts(_(help_xport));
- break;
-+ case C_JSON:
-+ puts(_(help_json));
-+ break;
- case C_QUIT:
- puts(_(help_quit));
- break;
-@@ -844,6 +856,58 @@
- setlocale(LC_NUMERIC, old_locale);
- }
- free(vtag);
-+ } else if (strcmp("json", argv[1]) == 0) {
-+ int xxsize;
-+ unsigned long int j = 0;
-+ time_t start, end, ti;
-+ unsigned long step, col_cnt;
-+ rrd_value_t *data, *ptr;
-+ char **legend_v;
-+ int i;
-+
-+ if (rrd_xport
-+ (argc - 1, &argv[1], &xxsize, &start, &end, &step, &col_cnt,
-+ &legend_v, &data) != -1) {
-+ char *old_locale = setlocale(LC_NUMERIC, "C");
-+ printf("[\n");
-+ for (j = 0; j < col_cnt; j++) {
-+ char *entry = NULL;
-+ ptr = j + data;
-+ entry = legend_v[j];
-+
-+ printf("\t{\n\t\t\"%s\": {\n", entry);
-+ free(entry);
-+ printf("\t\t\t\"%s\": %lld,\n", META_START_TAG,
-+ (long long int) start + step);
-+ printf("\t\t\t\"%s\": %lu,\n", META_STEP_TAG, step);
-+ printf("\t\t\t\"%s\": %lld,\n", META_END_TAG, (long long int) end);
-+ printf("\t\t\t\"data_points\": [\n");
-+
-+ for (ti = start + step; ti <= end; ti += step) {
-+ rrd_value_t newval = DNAN;
-+ newval = *ptr;
-+ if (isnan(newval)) {
-+ printf("null");
-+ } else {
-+ printf("%0.5f", newval);
-+ };
-+ if (ti < end) {
-+ printf(", ");
-+ }
-+ ptr+=col_cnt;
-+ }
-+
-+ printf("\n\t\t\t]\n");
-+ printf("\t\t}\n");
-+
-+ printf("\t}%s\n", (j<col_cnt-1) ? "," : "");
-+ }
-+ free(legend_v);
-+
-+ free(data);
-+ printf("]\n");
-+ setlocale(LC_NUMERIC, old_locale);
-+ }
- #else
- rrd_set_error("the instance of rrdtool has been compiled without graphics");
- #endif
diff --git a/databases/rrdtool/pkg-plist b/databases/rrdtool/pkg-plist
index 1f866dc02a88..48fbd988791c 100644
--- a/databases/rrdtool/pkg-plist
+++ b/databases/rrdtool/pkg-plist
@@ -10,11 +10,11 @@ include/rrd_format.h
lib/librrd.a
lib/librrd.so
lib/librrd.so.4
-lib/librrd.so.4.2.1
+lib/librrd.so.4.3.5
lib/librrd_th.a
lib/librrd_th.so
lib/librrd_th.so.4
-lib/librrd_th.so.4.2.1
+lib/librrd_th.so.4.3.5
libdata/pkgconfig/librrd.pc
%%PORTDOCS%%man/man1/bin_dec_hex.1.gz
%%PORTDOCS%%man/man1/cdeftutorial.1.gz
@@ -45,16 +45,11 @@ libdata/pkgconfig/librrd.pc
%%PORTDOCS%%man/man1/rrdupdate.1.gz
%%PORTDOCS%%man/man1/rrdxport.1.gz
%%PORTDOCS%%man/man3/librrd.3.gz
-%%WITH_PERL%%%%PERL5_MAN3%%/RRDp.3.gz
-%%WITH_PERL%%%%PERL5_MAN3%%/RRDs.3.gz
-%%WITH_PERL%%%%SITE_ARCH%%/auto/RRDs/RRDs.so
-%%WITH_PERL%%%%SITE_ARCH%%/RRDs.pm
-%%WITH_PERL%%%%SITE_PERL%%/RRDp.pm
-%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/rrdtoolmodule.so
+%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/rrdtool.so
%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/py_rrdtool-0.2.2-py%%PYTHON_VER%%.egg-info
-%%WITH_RUBY%%%%RUBY_SITEARCHLIBDIR%%/RRD.so
-%%PORTEXAMPLES%%share/rrdtool/examples/rrdcached/RRDCached.pm
-%%PORTEXAMPLES%%share/rrdtool/examples/rrdcached/rrdcached-size.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rrdcached/RRDCached.pm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rrdcached/rrdcached-size.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stripes.py
%%PORTDOCS%%%%DOCSDIR%%/html/RRDp.html
%%PORTDOCS%%%%DOCSDIR%%/html/RRDs.html
%%PORTDOCS%%%%DOCSDIR%%/html/bin_dec_hex.html