aboutsummaryrefslogtreecommitdiff
path: root/databases/rubygem-activemodel4
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-09-14 02:06:58 +0000
committerSteve Wills <swills@FreeBSD.org>2014-09-14 02:06:58 +0000
commit28071e639803800705a6938642ba75b31f925b45 (patch)
tree80b3dcb025ec943583a478981072ebc0ef107aa8 /databases/rubygem-activemodel4
parentec6354100bcad612065a1c296b7176385d726ed5 (diff)
downloadports-28071e639803800705a6938642ba75b31f925b45.tar.gz
ports-28071e639803800705a6938642ba75b31f925b45.zip
www/rubygem-rails4: create port for rails4
This port required creating a number of new ports, old versions of existing ports and other adjustments, so do all that while here too. Rails is a web-application framework for the MVC pattern that includes both a template engine, controller framework, and object-relational mapping package. Everything needed to develop web-apps that can run on CGI, FastCGI, and mod_ruby Being a full-stack framework means that all layers are built to work seamlessly together. That way you Don't Repeat Yourself (DRY) and you can use a single language from top to bottom. Everything from templates to control flow to business logic is written in Ruby - The language of love for industry heavy-weights. WWW: http://www.rubyonrails.org Submitted by: xmj (based on)
Notes
Notes: svn path=/head/; revision=368156
Diffstat (limited to 'databases/rubygem-activemodel4')
-rw-r--r--databases/rubygem-activemodel4/Makefile22
-rw-r--r--databases/rubygem-activemodel4/distinfo2
-rw-r--r--databases/rubygem-activemodel4/pkg-descr6
3 files changed, 30 insertions, 0 deletions
diff --git a/databases/rubygem-activemodel4/Makefile b/databases/rubygem-activemodel4/Makefile
new file mode 100644
index 000000000000..a97d75e865b2
--- /dev/null
+++ b/databases/rubygem-activemodel4/Makefile
@@ -0,0 +1,22 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= activemodel
+PORTVERSION= 4.1.6
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 4
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Toolkit for building modeling frameworks
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-activesupport4>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport4 \
+ rubygem-builder32>=3.2.4:${PORTSDIR}/devel/rubygem-builder32
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-activemodel4/distinfo b/databases/rubygem-activemodel4/distinfo
new file mode 100644
index 000000000000..bf54662aeb98
--- /dev/null
+++ b/databases/rubygem-activemodel4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/activemodel-4.1.6.gem) = a60fd5b3ec60031047311df66aea58360ac7aece470966899ffa7425413bbc92
+SIZE (rubygem/activemodel-4.1.6.gem) = 44544
diff --git a/databases/rubygem-activemodel4/pkg-descr b/databases/rubygem-activemodel4/pkg-descr
new file mode 100644
index 000000000000..d8cf509d0e8b
--- /dev/null
+++ b/databases/rubygem-activemodel4/pkg-descr
@@ -0,0 +1,6 @@
+A toolkit for building modeling frameworks like Active Record and
+Active Resource. Rich support for attributes, callbacks,
+validations, observers, serialization, internationalization,
+and testing.
+
+WWW: http://www.rubyonrails.org