aboutsummaryrefslogtreecommitdiff
path: root/databases/rubygem-pg/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-08 21:43:08 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-08 21:43:08 +0000
commit16fff2cdf62c2326a790867fb7c714be408940db (patch)
tree447973b3d446c48c29eb63a253ad96ad595a4d9a /databases/rubygem-pg/Makefile
parentab72c1ef340d75969ed676bebd27726d8bfb77ac (diff)
downloadports-16fff2cdf62c2326a790867fb7c714be408940db.tar.gz
ports-16fff2cdf62c2326a790867fb7c714be408940db.zip
rubygem-pg provides the module "pg", a Ruby interface to the
PostgreSQL Relational Database Management System, which supersedes the old "postgres" module. WWW: http://rubyforge.org/projects/ruby-pg/ PR: ports/131270 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=227827
Diffstat (limited to 'databases/rubygem-pg/Makefile')
-rw-r--r--databases/rubygem-pg/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/databases/rubygem-pg/Makefile b/databases/rubygem-pg/Makefile
new file mode 100644
index 000000000000..576b1532df49
--- /dev/null
+++ b/databases/rubygem-pg/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: pg
+# Date created: 28 Jan 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pg
+PORTVERSION= 0.7.9.2008.10.13
+CATEGORIES= databases rubygems
+MASTER_SITES= RF
+MASTER_SITE_SUBDIR= ruby-pg
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Ruby interface to PostgreSQL library
+
+USE_PGSQL= yes
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+PG_CONFIG= ${LOCALBASE}/bin/pg_config
+CONFIGURE_ARGS= --with-pgsql-include-dir=`${PG_CONFIG} --includedir` \
+ --with-pgsql-lib-dir=`${PG_CONFIG} --libdir`
+
+.include <bsd.port.mk>