aboutsummaryrefslogtreecommitdiff
path: root/databases/rubygem-sqlite3-ruby
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-06-26 03:47:13 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-06-26 03:47:13 +0000
commit703bbb782630b13db9404cf2c4e9907b02370792 (patch)
tree050da9323d4879e7f6fcdfd9c1dd180a12e0f228 /databases/rubygem-sqlite3-ruby
parent14b084463461cfccecafc273b23661bace0955ab (diff)
downloadports-703bbb782630b13db9404cf2c4e9907b02370792.tar.gz
ports-703bbb782630b13db9404cf2c4e9907b02370792.zip
Add ruby-sqlite, (another) Ruby interface to the SQLite DB engine.
Notes
Notes: svn path=/head/; revision=83620
Diffstat (limited to 'databases/rubygem-sqlite3-ruby')
-rw-r--r--databases/rubygem-sqlite3-ruby/Makefile36
-rw-r--r--databases/rubygem-sqlite3-ruby/distinfo1
-rw-r--r--databases/rubygem-sqlite3-ruby/pkg-descr9
-rw-r--r--databases/rubygem-sqlite3-ruby/pkg-plist10
4 files changed, 56 insertions, 0 deletions
diff --git a/databases/rubygem-sqlite3-ruby/Makefile b/databases/rubygem-sqlite3-ruby/Makefile
new file mode 100644
index 000000000000..e15082239aa7
--- /dev/null
+++ b/databases/rubygem-sqlite3-ruby/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: sqlite-ruby
+# Date created: 26 June 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlite
+PORTVERSION= 1.0
+CATEGORIES= databases ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}-ruby
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Ruby interface to the SQLite DB engine
+
+LIB_DEPENDS= sqlite.2:${.CURDIR}/../sqlite
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/samples/* ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-sqlite3-ruby/distinfo b/databases/rubygem-sqlite3-ruby/distinfo
new file mode 100644
index 000000000000..2a94d58e50cd
--- /dev/null
+++ b/databases/rubygem-sqlite3-ruby/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/sqlite-ruby-1.0.tar.gz) = cc22e5ce8b3ddcb3de27eb4d7eaa23bc
diff --git a/databases/rubygem-sqlite3-ruby/pkg-descr b/databases/rubygem-sqlite3-ruby/pkg-descr
new file mode 100644
index 000000000000..433dc455feb5
--- /dev/null
+++ b/databases/rubygem-sqlite3-ruby/pkg-descr
@@ -0,0 +1,9 @@
+sqlite-ruby provides an interface for the SQLite DB engine. This
+differs from the DBD::SQLite module in that it is more complete, and
+from the ruby DBI version of SQLite in that it is SQLite specific, so
+you can do things that would otherwise be more difficult via DBI. If
+you want portability between backends, use DBI. If you want ease of
+use with SQLite, use this.
+
+Author: minam <jgb3@email.byu.edu>
+WWW: http://sqlite-ruby.sourceforge.net/
diff --git a/databases/rubygem-sqlite3-ruby/pkg-plist b/databases/rubygem-sqlite3-ruby/pkg-plist
new file mode 100644
index 000000000000..a569f9720d7f
--- /dev/null
+++ b/databases/rubygem-sqlite3-ruby/pkg-plist
@@ -0,0 +1,10 @@
+%%RUBY_SITEARCHLIBDIR%%/_sqlite.so
+%%RUBY_SITELIBDIR%%/sqlite.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/advanced.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/dbdef.sql
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/define_db.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/pragma.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/queries.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%