aboutsummaryrefslogtreecommitdiff
path: root/databases/rubygem-sqlite3
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-11-19 08:13:11 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-11-19 08:13:11 +0000
commitcd089e292bd7b074b2cff4cde534c13aa0e4007c (patch)
treeaeddd7ee4177f2d65977c8c4a7061bfdc2b46dd0 /databases/rubygem-sqlite3
parent26d0e50cd21ec00e3f703f7889bb78b63f693ad0 (diff)
downloadports-cd089e292bd7b074b2cff4cde534c13aa0e4007c.tar.gz
ports-cd089e292bd7b074b2cff4cde534c13aa0e4007c.zip
databases/rubygem-sqlite3: Update to 1.5.3
Diffstat (limited to 'databases/rubygem-sqlite3')
-rw-r--r--databases/rubygem-sqlite3/Makefile2
-rw-r--r--databases/rubygem-sqlite3/distinfo6
-rw-r--r--databases/rubygem-sqlite3/files/patch-ext-sqlite3-extconf.rb35
3 files changed, 26 insertions, 17 deletions
diff --git a/databases/rubygem-sqlite3/Makefile b/databases/rubygem-sqlite3/Makefile
index 52e8c10a945d..f5d93346f9e7 100644
--- a/databases/rubygem-sqlite3/Makefile
+++ b/databases/rubygem-sqlite3/Makefile
@@ -1,5 +1,5 @@
PORTNAME= sqlite3
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.3
CATEGORIES= databases rubygems
MASTER_SITES= RG
diff --git a/databases/rubygem-sqlite3/distinfo b/databases/rubygem-sqlite3/distinfo
index 256c9ade749f..7b22673dcb0d 100644
--- a/databases/rubygem-sqlite3/distinfo
+++ b/databases/rubygem-sqlite3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1664768028
-SHA256 (rubygem/sqlite3-1.5.2.gem) = 9b3153b5703b4619534135c16ff7c4e8ba1adbd8548ff61bb4a002dd632bcd5e
-SIZE (rubygem/sqlite3-1.5.2.gem) = 3134976
+TIMESTAMP = 1665648419
+SHA256 (rubygem/sqlite3-1.5.3.gem) = 66524f404db0b697620b601dea6381b139e9ce6f47e8eb628759c8d6ddcb25c5
+SIZE (rubygem/sqlite3-1.5.3.gem) = 3134976
diff --git a/databases/rubygem-sqlite3/files/patch-ext-sqlite3-extconf.rb b/databases/rubygem-sqlite3/files/patch-ext-sqlite3-extconf.rb
index c8b94b0e486a..ab031b907262 100644
--- a/databases/rubygem-sqlite3/files/patch-ext-sqlite3-extconf.rb
+++ b/databases/rubygem-sqlite3/files/patch-ext-sqlite3-extconf.rb
@@ -1,4 +1,4 @@
---- ext/sqlite3/extconf.rb.orig 2022-10-03 13:15:30 UTC
+--- ext/sqlite3/extconf.rb.orig 2022-10-13 10:19:00 UTC
+++ ext/sqlite3/extconf.rb
@@ -1,5 +1,4 @@
require "mkmf"
@@ -6,7 +6,7 @@
require "yaml"
module Sqlite3
-@@ -49,33 +48,6 @@ module Sqlite3
+@@ -49,42 +48,6 @@ module Sqlite3
end
def configure_packaged_libraries
@@ -27,20 +27,29 @@
- end
- recipe.activate
-
-- ENV["PKG_CONFIG_ALLOW_SYSTEM_CFLAGS"] = "t" # on macos, pkg-config will not return --cflags without this
-- pcfile = File.join(recipe.path, "lib", "pkgconfig", "sqlite3.pc")
-- if pkg_config(pcfile)
-- # see https://bugs.ruby-lang.org/issues/18490
-- libs = xpopen(["pkg-config", "--libs", "--static", pcfile], err: [:child, :out], &:read)
-- libs.split.each { |lib| append_ldflags(lib) } if $?.success?
-- else
-- abort("\nCould not configure the build properly. Please install either the `pkg-config` utility or the `pkg-config` rubygem.\n\n")
+- # on macos, pkg-config will not return --cflags without this
+- ENV["PKG_CONFIG_ALLOW_SYSTEM_CFLAGS"] = "t"
+-
+- lib_path = File.join(recipe.path, "lib")
+- pcfile = File.join(lib_path, "pkgconfig", "sqlite3.pc")
+- abort_pkg_config("pkg_config") unless pkg_config(pcfile)
+-
+- # see https://bugs.ruby-lang.org/issues/18490
+- flags = xpopen(["pkg-config", "--libs", "--static", pcfile], err: [:child, :out], &:read)
+- abort_pkg_config("xpopen") unless $?.success?
+- flags = flags.split
+-
+- # see https://github.com/flavorjones/mini_portile/issues/118
+- "-L#{lib_path}".tap do |lib_path_flag|
+- flags.prepend(lib_path_flag) unless flags.include?(lib_path_flag)
- end
+-
+- flags.each { |flag| append_ldflags(flag) }
- end
end
def configure_extension
-@@ -116,11 +88,6 @@ module Sqlite3
+@@ -125,11 +88,6 @@ module Sqlite3
end
def minimal_recipe
@@ -52,7 +61,7 @@
end
def package_root_dir
-@@ -128,12 +95,9 @@ module Sqlite3
+@@ -137,12 +95,9 @@ module Sqlite3
end
def sqlite3_config
@@ -65,7 +74,7 @@
end
def abort_could_not_find(missing)
-@@ -141,11 +105,9 @@ module Sqlite3
+@@ -154,11 +109,9 @@ module Sqlite3
end
def cross_build?