aboutsummaryrefslogtreecommitdiff
path: root/databases/slony1v2
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-04-07 21:58:56 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-04-07 21:58:56 +0000
commit56915055beb9fd3d00ec665904fb830c49ba1e40 (patch)
tree6ebad9f0113c0e103b322c2059f64f959355881c /databases/slony1v2
parente695731b4a7c5226b7c4ddb2427414daacbca9c5 (diff)
downloadports-56915055beb9fd3d00ec665904fb830c49ba1e40.tar.gz
ports-56915055beb9fd3d00ec665904fb830c49ba1e40.zip
Notes
Diffstat (limited to 'databases/slony1v2')
-rw-r--r--databases/slony1v2/Makefile33
1 files changed, 9 insertions, 24 deletions
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index b56bfe2010af..6d1681619334 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -24,25 +24,21 @@ SUB_FILES= pkg-message slon-mkservice.sh
SUB_LIST+= NAME=slon
OPTIONS_DEFINE= DOCS PERLTOOLS
+OPTIONS_SUB= yes
PERLTOOLS_DESC= Install perl configuration tools
CONFLICTS?= slony1-1*
CONFIGURE_ENV+= FLEX=${LOCALBASE}/bin/flex
-.include <bsd.port.options.mk>
+PERLTOOLS_DESC= Install perl configuration tools
+PERLTOOLS_USES= perl5
+PERLTOOLS_CONFIGURE_ENV= PERL=${PERL}
+PERLTOOLS_CONFIGURE_ON= --with-perltools=${LOCALBASE}/sbin
+PERLTOOLS_BUILD_DEPENDS= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
+PERLTOOLS_RUN_DEPENDS= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
-.if ${PORT_OPTIONS:MPERLTOOLS}
-USES+= perl5
-CONFIGURE_ARGS+=--with-perltools=${LOCALBASE}/sbin
-RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
-BUILD_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
-PLIST_SUB+= PERLTOOLS=""
-SUB_LIST+= PERLTOOLS=""
-.else
-PLIST_SUB+= PERLTOOLS="@comment "
-SUB_LIST+= PERLTOOLS="@comment "
-.endif
+.include <bsd.port.options.mk>
# let configure find postgres stuff in non-standard places
CONFIGURE_ARGS+=--with-pgconfigdir=${LOCALBASE}/bin \
@@ -53,17 +49,6 @@ CONFIGURE_ARGS+=--with-pgconfigdir=${LOCALBASE}/bin \
--with-pgpkglibdir=${LOCALBASE}/lib/postgresql \
--with-pgsharedir=${LOCALBASE}/share/postgresql
-# Setting/finding PostgreSQL version we want.
-.if exists(${LOCALBASE}/bin/postmaster)
-PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | \
- ${SED} -En 's/.*PostgreSQL[^0-9]*([0-9]+)\.([0-9]+)\..*/\1\2/p'
-.elif exists(${LOCALBASE}/bin/pg_config)
-PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | \
- ${SED} -En 's/PostgreSQL[^0-9]*([0-9]*)\.([0-9]+)\..*/\1\2/p'
-.else
-PGSQL_VER= ${DEFAULT_PGSQL_VER}
-.endif
-
PORTDOCS= *
DOCS= COPYRIGHT INSTALL README README.Unicode RELEASE \
@@ -71,7 +56,7 @@ DOCS= COPYRIGHT INSTALL README README.Unicode RELEASE \
post-patch:
@for _file in ${WRKSRC}/doc/adminguide/man7/*.7; do \
- mv "$${_file}" $$(echo $${_file} | sed -e 's/ [ ]*/_/g'); \
+ ${MV} "$${_file}" $$(echo $${_file} | ${SED} -e 's/ [ ]*/_/g'); \
done
@for _file in ${WRKSRC}/doc/adminguide/man7/*.7; do \
${REINPLACE_CMD} -e '/^.TH/s/ [ ]*/ /g' $${_file}; \