aboutsummaryrefslogtreecommitdiff
path: root/databases/soci
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-14 06:52:09 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-14 06:52:09 +0000
commit9c098e1413f86f9ecb1d1429f42096a99fad48e2 (patch)
tree9943b243e0ae3ddf417445b540804a93e95aca03 /databases/soci
parent26da23bf37c767ddaa089cd273eb3d997274f34d (diff)
downloadports-9c098e1413f86f9ecb1d1429f42096a99fad48e2.tar.gz
ports-9c098e1413f86f9ecb1d1429f42096a99fad48e2.zip
Disable dependency on firebird for tier-2 archs. There is work underway
to fix firebird on those archs but it is not complete. This unbreaks several dozen ports on tier-2. PR: 216943 Submitted by: linimon Reviewed by: mat (only this file)
Notes
Notes: svn path=/head/; revision=440865
Diffstat (limited to 'databases/soci')
-rw-r--r--databases/soci/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/databases/soci/Makefile b/databases/soci/Makefile
index 30c84cfd3b64..041d15e60977 100644
--- a/databases/soci/Makefile
+++ b/databases/soci/Makefile
@@ -25,6 +25,15 @@ BOOST_DESC= Enable support for additional types using Boost
OPTIONS_DEFAULT=MYSQL PGSQL SQLITE ODBC BOOST FIREBIRD
OPTIONS_SUB= yes
+# firebird is currently only available on x86.
+OPTIONS_EXCLUDE_aarch64= FIREBIRD
+OPTIONS_EXCLUDE_armv6= FIREBIRD
+OPTIONS_EXCLUDE_mips= FIREBIRD
+OPTIONS_EXCLUDE_mips64= FIREBIRD
+OPTIONS_EXCLUDE_powerpc= FIREBIRD
+OPTIONS_EXCLUDE_powerpc64= FIREBIRD
+OPTIONS_EXCLUDE_sparc64= FIREBIRD
+
MYSQL_USE= MYSQL=yes
MYSQL_CMAKE_ON= -DWITH_MYSQL:BOOL=ON
MYSQL_CMAKE_OFF= -DWITH_MYSQL:BOOL=OFF