aboutsummaryrefslogtreecommitdiff
path: root/databases/spatialite
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-11-30 14:55:34 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-11-30 14:55:34 +0000
commit64be4e831df9334d5a0cdf1b73f2908e1c3ea406 (patch)
treef95a191c24aecb2cd8a83927e31fded5e2303023 /databases/spatialite
parent1eabed7529d90de9f2b01b9e06c69aed911d5a94 (diff)
downloadports-64be4e831df9334d5a0cdf1b73f2908e1c3ea406.tar.gz
ports-64be4e831df9334d5a0cdf1b73f2908e1c3ea406.zip
databases/spatialite: enable libxml2
- Enable libxml2 - USES pathfix pkgconfig PR: ports/184099 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=335294
Diffstat (limited to 'databases/spatialite')
-rw-r--r--databases/spatialite/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/databases/spatialite/Makefile b/databases/spatialite/Makefile
index 7068f0dfcf3e..45243b3e4965 100644
--- a/databases/spatialite/Makefile
+++ b/databases/spatialite/Makefile
@@ -3,6 +3,7 @@
PORTNAME= spatialite
PORTVERSION= 4.1.1
+PORTREVISION= 1
CATEGORIES= databases geography
MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
DISTNAME= lib${PORTNAME}-${PORTVERSION}
@@ -16,13 +17,13 @@ LIB_DEPENDS= libgeos_c.so:${PORTSDIR}/graphics/geos \
WRKSRC= ${WRKDIR}/lib${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
+USES= gmake iconv pathfix pkgconfig
USE_SQLITE= yes
-USES= gmake iconv
-USE_GCC= yes
+USE_GNOME= libxml2
-CPPFLAGS+= -I${WRKSRC}/src/headers -I${LOCALBASE}/include
+CFLAGS+= -I${WRKSRC}/src/headers -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
-CONFIGURE_ARGS+=CFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS+=--enable-libxml2=yes CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
NO_STAGE= yes
@@ -30,13 +31,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|-ldl| |' ${WRKSRC}/src/Makefile.am
@${REINPLACE_CMD} -e 's|-ldl| |' ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e 's|-ldl| |' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|$$(prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.in
-.include <bsd.port.pre.mk>
+BROKEN_powerpc= Does not compile on powerpc: invokes i386 assembler
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc: invokes i386 assembler
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>