aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite-ext-miscfuncs
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-05-16 03:11:14 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-05-16 03:11:14 +0000
commitd3716a5a6d941b05529980b59f94fda980a5d491 (patch)
treece66c44f5a288ca1e23ce6e146006ffdaa607ba7 /databases/sqlite-ext-miscfuncs
parent3b51bf0323e0e00e939a17ecb667c06ba81a6b38 (diff)
downloadports-d3716a5a6d941b05529980b59f94fda980a5d491.tar.gz
ports-d3716a5a6d941b05529980b59f94fda980a5d491.zip
Support STAGEDIR.
Notes
Notes: svn path=/head/; revision=354192
Diffstat (limited to 'databases/sqlite-ext-miscfuncs')
-rw-r--r--databases/sqlite-ext-miscfuncs/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/databases/sqlite-ext-miscfuncs/Makefile b/databases/sqlite-ext-miscfuncs/Makefile
index 4daae2d0c149..5fd4ae1d67c4 100644
--- a/databases/sqlite-ext-miscfuncs/Makefile
+++ b/databases/sqlite-ext-miscfuncs/Makefile
@@ -35,19 +35,17 @@ PORTDOCS= README
CFLAGS+= -I${PREFIX}/include -fPIC -lm -shared
-NO_STAGE= yes
do-build:
@cd ${WRKSRC} && ${CC} ${CFLAGS} ${SRCFILE} -o ${LIBFILE}
do-install:
- @${INSTALL} -d ${PREFIX}/libexec/${DIST_SUBDIR}
- @${INSTALL_PROGRAM} ${WRKSRC}/${LIBFILE} ${INST_DIR}
+ @${INSTALL} -d ${STAGEDIR}${PREFIX}/libexec/${DIST_SUBDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${LIBFILE} ${STAGEDIR}${INST_DIR}
post-install:
.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}
- @${CP} ${WRKDIR}/${PORTDOCS} ${DOCSDIR}
+ @${INSTALL} -d ${STAGEDIR}${DOCSDIR}
+ @${CP} ${WRKDIR}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>