aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite-ext-pcre
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-12-21 09:00:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-12-21 09:00:38 +0000
commite4e666ef51077cfe75da132ee94eae523421ad02 (patch)
tree5ce2805262a277760537799f843320f24ec2a695 /databases/sqlite-ext-pcre
parent3028b125ee9535a5d1fac9467a3269ad72ef9437 (diff)
downloadports-e4e666ef51077cfe75da132ee94eae523421ad02.tar.gz
ports-e4e666ef51077cfe75da132ee94eae523421ad02.zip
- Pet portlint
- Add LICENSE - Cosmetic fixes - Unsilence installation commands Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=456896
Diffstat (limited to 'databases/sqlite-ext-pcre')
-rw-r--r--databases/sqlite-ext-pcre/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/databases/sqlite-ext-pcre/Makefile b/databases/sqlite-ext-pcre/Makefile
index fcf0edf212d4..64b77e315567 100644
--- a/databases/sqlite-ext-pcre/Makefile
+++ b/databases/sqlite-ext-pcre/Makefile
@@ -4,34 +4,34 @@ PORTNAME= sqlite-ext-pcre
PORTVERSION= 20100208
PORTREVISION= 1
CATEGORIES= databases
+DIST_SUBDIR= sqlite-ext
MAINTAINER= vivek@khera.org
COMMENT= Regexp function for SQLite based on PCRE library
-LIB_DEPENDS+= libpcre.so:devel/pcre
+LICENSE= PD
-DIST_SUBDIR= sqlite-ext
+LIB_DEPENDS= libpcre.so:devel/pcre
+
+USE_GITHUB= yes
+GH_ACCOUNT= ralight
+GH_PROJECT= sqlite3-pcre
+GH_TAGNAME= c98da41
+USES= gmake pkgconfig sqlite
LIBFILE= pcre.so
INST_DIR= ${PREFIX}/libexec/${DIST_SUBDIR}
USE_LDCONFIG= ${INST_DIR}
-SUB_LIST+= LIBFILE=${LIBFILE}
+SUB_LIST= LIBFILE=${LIBFILE}
PLIST_FILES= libexec/${DIST_SUBDIR}/${LIBFILE}
-USES= gmake pkgconfig sqlite
-
-USE_GITHUB= yes
-GH_ACCOUNT= ralight
-GH_PROJECT= sqlite3-pcre
-GH_TAGNAME= c98da41
-
do-build:
@cd ${WRKSRC} && ${GMAKE}
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/libexec/${DIST_SUBDIR}
- @${INSTALL_PROGRAM} ${WRKSRC}/${LIBFILE} ${STAGEDIR}${PREFIX}/libexec/${DIST_SUBDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${LIBFILE} ${STAGEDIR}${PREFIX}/libexec/${DIST_SUBDIR}
.include <bsd.port.mk>