aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite-ext-regexp
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-05-06 15:02:46 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-05-06 15:02:46 +0000
commit78dd6ad23c6ae52c9bfb3cf7523ce2d8538a442c (patch)
treecb5ba769ae3c38ab2177a47074beb99f6b9094e1 /databases/sqlite-ext-regexp
parentcf5405d2efcda58d1e1cc6ec2b51ea5b792c0cab (diff)
downloadports-78dd6ad23c6ae52c9bfb3cf7523ce2d8538a442c.tar.gz
ports-78dd6ad23c6ae52c9bfb3cf7523ce2d8538a442c.zip
New port: databases/sqlite-ext-regexp
Regular-expression matcher for posix extended regular expressions against UTF8 text. Functions: regexp WWW: https://www.sqlite.org/ PR: 203218 Submitted by: Yuri <yuri@rawbw.com>
Notes
Notes: svn path=/head/; revision=414709
Diffstat (limited to 'databases/sqlite-ext-regexp')
-rw-r--r--databases/sqlite-ext-regexp/Makefile40
-rw-r--r--databases/sqlite-ext-regexp/distinfo2
-rw-r--r--databases/sqlite-ext-regexp/pkg-descr6
-rw-r--r--databases/sqlite-ext-regexp/pkg-message11
4 files changed, 59 insertions, 0 deletions
diff --git a/databases/sqlite-ext-regexp/Makefile b/databases/sqlite-ext-regexp/Makefile
new file mode 100644
index 000000000000..598ad6862481
--- /dev/null
+++ b/databases/sqlite-ext-regexp/Makefile
@@ -0,0 +1,40 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= sqlite-ext-regexp
+PORTVERSION= 3.8.11.1
+CATEGORIES= databases
+MASTER_SITES= https://www.sqlite.org/2015/ http://www2.sqlite.org/2015/ http://www3.sqlite.org/2015/
+DISTNAME= sqlite-src-${PORTVERSION:S|8.|8|:S|.|0|g}
+DIST_SUBDIR= sqlite-ext
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Regular-expression matcher using NFA engine for SQLite
+
+LICENSE= public
+LICENSE_NAME= Public Domain
+LICENSE_TEXT= Description of the license can be obtained from the following URL: http://www.sqlite.org/copyright.html
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USES= sqlite:3 zip
+NO_WRKSUBDIR= yes
+
+SRCFILE= ${DISTNAME}/ext/misc/regexp.c
+LIBFILE= libregexp.so
+INST_DIR= ${PREFIX}/libexec/${DIST_SUBDIR}
+USE_LDCONFIG= ${INST_DIR}
+
+EXTRACT_AFTER_ARGS= ${SRCFILE}
+
+PLIST_FILES= libexec/${DIST_SUBDIR}/${LIBFILE}
+
+CFLAGS+= -I${PREFIX}/include -fPIC -shared
+
+do-build:
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} ${SRCFILE} -o ${LIBFILE}
+
+do-install:
+ ${INSTALL} -d ${STAGEDIR}${PREFIX}/libexec/${DIST_SUBDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${LIBFILE} ${STAGEDIR}${INST_DIR}
+
+.include <bsd.port.mk>
diff --git a/databases/sqlite-ext-regexp/distinfo b/databases/sqlite-ext-regexp/distinfo
new file mode 100644
index 000000000000..004d1245c4b9
--- /dev/null
+++ b/databases/sqlite-ext-regexp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sqlite-ext/sqlite-src-3081101.zip) = 261ad454663f66fda6101b278bb7b3931cf01884deefbf4ea6b152f83a624662
+SIZE (sqlite-ext/sqlite-src-3081101.zip) = 9057103
diff --git a/databases/sqlite-ext-regexp/pkg-descr b/databases/sqlite-ext-regexp/pkg-descr
new file mode 100644
index 000000000000..614a8481304b
--- /dev/null
+++ b/databases/sqlite-ext-regexp/pkg-descr
@@ -0,0 +1,6 @@
+Regular-expression matcher for posix extended regular expressions
+against UTF8 text.
+
+Functions: regexp
+
+WWW: https://www.sqlite.org/
diff --git a/databases/sqlite-ext-regexp/pkg-message b/databases/sqlite-ext-regexp/pkg-message
new file mode 100644
index 000000000000..d55184d7fb78
--- /dev/null
+++ b/databases/sqlite-ext-regexp/pkg-message
@@ -0,0 +1,11 @@
+*********************************************************************
+Loading extensions is by default prohibited as a security measure;
+see "Security Considerations" in
+http://www.sqlite.org/cvstrac/wiki?p=LoadableExtensions.
+
+If the sqlite3 program and library are built this way, you cannot
+use these functions from the program, you must write your own program
+using the sqlite3 API, and call sqlite3_enable_load_extension as
+described above, or else rebuilt the sqlite3 program to allow
+loadable extensions.
+*********************************************************************