aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite-ext-spellfix
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-05-06 14:59:36 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-05-06 14:59:36 +0000
commitcf5405d2efcda58d1e1cc6ec2b51ea5b792c0cab (patch)
tree0ee96d66003c3c2697609028fcfb944c7220af0a /databases/sqlite-ext-spellfix
parentf83159f188ed7d4e1b0ed7375af1898a91b93115 (diff)
downloadports-cf5405d2efcda58d1e1cc6ec2b51ea5b792c0cab.tar.gz
ports-cf5405d2efcda58d1e1cc6ec2b51ea5b792c0cab.zip
New port: databases/sqlite-ext-spellfix
This module implements the spellfix1 VIRTUAL TABLE that can be used to search a large vocabulary for close matches using Levenshtein distance. Virtual table: spellfix1 Functions: editdist, editdist3, spellfix1_translit, spellfix1_phonehash, spellfix1_scriptcode WWW: http://www.sqlite.org/spellfix1.html PR: 203217 Submitted by: Yuri <yuri@rawbw.com>
Notes
Notes: svn path=/head/; revision=414708
Diffstat (limited to 'databases/sqlite-ext-spellfix')
-rw-r--r--databases/sqlite-ext-spellfix/Makefile40
-rw-r--r--databases/sqlite-ext-spellfix/distinfo2
-rw-r--r--databases/sqlite-ext-spellfix/pkg-descr13
-rw-r--r--databases/sqlite-ext-spellfix/pkg-message11
4 files changed, 66 insertions, 0 deletions
diff --git a/databases/sqlite-ext-spellfix/Makefile b/databases/sqlite-ext-spellfix/Makefile
new file mode 100644
index 000000000000..8419586376c9
--- /dev/null
+++ b/databases/sqlite-ext-spellfix/Makefile
@@ -0,0 +1,40 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= sqlite-ext-spellfix
+PORTVERSION= 3.8.11.1
+CATEGORIES= databases
+MASTER_SITES= https://www.sqlite.org/2015/ http://www2.sqlite.org/2015/ http://www3.sqlite.org/2015/
+DISTNAME= sqlite-src-${PORTVERSION:S|8.|8|:S|.|0|g}
+DIST_SUBDIR= sqlite-ext
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Search large vocabulary for close matches for SQLite
+
+LICENSE= public
+LICENSE_NAME= Public Domain
+LICENSE_TEXT= Description of the license can be obtained from the following URL: http://www.sqlite.org/copyright.html
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USES= sqlite:3 zip
+NO_WRKSUBDIR= yes
+
+SRCFILE= ${DISTNAME}/ext/misc/spellfix.c
+LIBFILE= libspellfix.so
+INST_DIR= ${PREFIX}/libexec/${DIST_SUBDIR}
+USE_LDCONFIG= ${INST_DIR}
+
+EXTRACT_AFTER_ARGS= ${SRCFILE}
+
+PLIST_FILES= libexec/${DIST_SUBDIR}/${LIBFILE}
+
+CFLAGS+= -I${PREFIX}/include -fPIC -shared
+
+do-build:
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} ${SRCFILE} -o ${LIBFILE}
+
+do-install:
+ ${INSTALL} -d ${STAGEDIR}${PREFIX}/libexec/${DIST_SUBDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${LIBFILE} ${STAGEDIR}${INST_DIR}
+
+.include <bsd.port.mk>
diff --git a/databases/sqlite-ext-spellfix/distinfo b/databases/sqlite-ext-spellfix/distinfo
new file mode 100644
index 000000000000..004d1245c4b9
--- /dev/null
+++ b/databases/sqlite-ext-spellfix/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sqlite-ext/sqlite-src-3081101.zip) = 261ad454663f66fda6101b278bb7b3931cf01884deefbf4ea6b152f83a624662
+SIZE (sqlite-ext/sqlite-src-3081101.zip) = 9057103
diff --git a/databases/sqlite-ext-spellfix/pkg-descr b/databases/sqlite-ext-spellfix/pkg-descr
new file mode 100644
index 000000000000..48f9f9e8f187
--- /dev/null
+++ b/databases/sqlite-ext-spellfix/pkg-descr
@@ -0,0 +1,13 @@
+This module implements the spellfix1 VIRTUAL TABLE that can be used
+to search a large vocabulary for close matches using Levenshtein distance.
+
+Virtual table:
+
+ spellfix1
+
+Functions:
+
+ editdist, editdist3, spellfix1_translit, spellfix1_phonehash,
+ spellfix1_scriptcode
+
+WWW: http://www.sqlite.org/spellfix1.html
diff --git a/databases/sqlite-ext-spellfix/pkg-message b/databases/sqlite-ext-spellfix/pkg-message
new file mode 100644
index 000000000000..d55184d7fb78
--- /dev/null
+++ b/databases/sqlite-ext-spellfix/pkg-message
@@ -0,0 +1,11 @@
+*********************************************************************
+Loading extensions is by default prohibited as a security measure;
+see "Security Considerations" in
+http://www.sqlite.org/cvstrac/wiki?p=LoadableExtensions.
+
+If the sqlite3 program and library are built this way, you cannot
+use these functions from the program, you must write your own program
+using the sqlite3 API, and call sqlite3_enable_load_extension as
+described above, or else rebuilt the sqlite3 program to allow
+loadable extensions.
+*********************************************************************