aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite2
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-09-25 09:32:09 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-09-25 09:32:09 +0000
commit4cfe5a185aa7bbe17f24b26e389291a84056241e (patch)
tree9f14dfdd9d8767634f1a0e47acda62a0e81af6f6 /databases/sqlite2
parent9275b0a73a782df594e2be7ca8162342de10f860 (diff)
downloadports-4cfe5a185aa7bbe17f24b26e389291a84056241e.tar.gz
ports-4cfe5a185aa7bbe17f24b26e389291a84056241e.zip
- Convert to USES+=tcl
- Fix package provide
Notes
Notes: svn path=/head/; revision=328258
Diffstat (limited to 'databases/sqlite2')
-rw-r--r--databases/sqlite2/Makefile9
-rw-r--r--databases/sqlite2/files/pkgIndex.tcl2
2 files changed, 5 insertions, 6 deletions
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index ec5cb29b1a63..4ac24d504c03 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= http://www.sqlite.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= An SQL database engine in a C library
-USES= pkgconfig
-USE_GMAKE= YES
+USES= gmake pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES
@@ -30,11 +29,11 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTCL}
-USE_TCL= 84+
+USES+= tcl
.else
.if ${PORT_OPTIONS:MDOCS}
-USE_TCL_BUILD= 84+
-. endif
+USES+= tcl:build
+.endif
.endif
.include <bsd.port.pre.mk>
diff --git a/databases/sqlite2/files/pkgIndex.tcl b/databases/sqlite2/files/pkgIndex.tcl
index d96e27a1bc55..cf17c6ef1f1b 100644
--- a/databases/sqlite2/files/pkgIndex.tcl
+++ b/databases/sqlite2/files/pkgIndex.tcl
@@ -1 +1 @@
-package ifneeded sqlite 0.0 [list load [file join $dir libtclsqlite.so] sqlite]
+package ifneeded sqlite 2.0 [list load [file join $dir libtclsqlite.so] sqlite]