aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite2
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2015-03-26 23:02:48 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2015-03-26 23:02:48 +0000
commit86aaf8b926e35061ed611d7c2bbe917895d3568d (patch)
tree97526edd4c680ca8863d5d628fad88fd1982df3a /databases/sqlite2
parentff9e0a2850ab132ce72c3b9993f6b3e4d6ffcc19 (diff)
downloadports-86aaf8b926e35061ed611d7c2bbe917895d3568d.tar.gz
ports-86aaf8b926e35061ed611d7c2bbe917895d3568d.zip
Fix compiler warnings, i.e., "-lpthread: 'linker' input unused".
Notes
Notes: svn path=/head/; revision=382352
Diffstat (limited to 'databases/sqlite2')
-rw-r--r--databases/sqlite2/Makefile4
-rw-r--r--databases/sqlite2/files/patch-Makefile.in13
2 files changed, 14 insertions, 3 deletions
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index eab7db77763e..ce6b084e5190 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -65,7 +65,9 @@ post-patch:
@${ECHO} "" > ${WRKSRC}/freebsd.hints
.endif
.if ${PORT_OPTIONS:MTHREADS}
- @${ECHO} "config_TARGET_CFLAGS=\"-DTHREADSAFE=1 -lpthread\"" \
+ @${ECHO} "config_TARGET_CFLAGS=\"-DTHREADSAFE=1\"" \
+ >> ${WRKSRC}/freebsd.hints
+ @${ECHO} "config_TARGET_LIBS=\"-lpthread\"" \
>> ${WRKSRC}/freebsd.hints
.endif
diff --git a/databases/sqlite2/files/patch-Makefile.in b/databases/sqlite2/files/patch-Makefile.in
index ad1b8ff07b42..59f1598e25d3 100644
--- a/databases/sqlite2/files/patch-Makefile.in
+++ b/databases/sqlite2/files/patch-Makefile.in
@@ -1,5 +1,14 @@
---- Makefile.in.orig Sat Mar 27 08:16:32 2004
-+++ Makefile.in Sun Nov 21 04:32:00 2004
+--- Makefile.in.orig 2005-04-23 18:43:23.000000000 -0400
++++ Makefile.in 2015-03-26 18:36:07.358178000 -0400
+@@ -38,7 +38,7 @@
+
+ # libtool compile/link/install
+ LTCOMPILE = $(LIBTOOL) --mode=compile $(TCC)
+-LTLINK = $(LIBTOOL) --mode=link $(TCC)
++LTLINK = $(LIBTOOL) --mode=link $(TCC) @TARGET_LIBS@
+ LTINSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ # Compiler options needed for programs that use the TCL library.
@@ -471,8 +471,12 @@
$(LTINSTALL) sqlite $(DESTDIR)$(exec_prefix)/bin
$(INSTALL) -d $(DESTDIR)$(prefix)/include