aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite2
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-10-21 15:21:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-10-21 15:21:13 +0000
commita0bcd2cf684ff6bc2faf242e6678282f20a3ee44 (patch)
treea5029ff30555b3a7ee0621f4dd5aacb832fde1d8 /databases/sqlite2
parentb7fb6d6f05e67910c9ecd4b0e0e1e0a130f8f54f (diff)
downloadports-a0bcd2cf684ff6bc2faf242e6678282f20a3ee44.tar.gz
ports-a0bcd2cf684ff6bc2faf242e6678282f20a3ee44.zip
Use USES=pathfix where applicable.
PR: 213195 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D8093
Notes
Notes: svn path=/head/; revision=424427
Diffstat (limited to 'databases/sqlite2')
-rw-r--r--databases/sqlite2/Makefile2
-rw-r--r--databases/sqlite2/files/patch-Makefile.in22
2 files changed, 10 insertions, 14 deletions
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index 8933b8ca0ab6..6fd3199807de 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= SQL database engine in a C library
GNU_CONFIGURE= yes
-USES= gmake libtool pkgconfig readline
+USES= gmake libtool pathfix pkgconfig readline
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-hints=freebsd.hints
diff --git a/databases/sqlite2/files/patch-Makefile.in b/databases/sqlite2/files/patch-Makefile.in
index 59f1598e25d3..64cb2b04c652 100644
--- a/databases/sqlite2/files/patch-Makefile.in
+++ b/databases/sqlite2/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2005-04-23 18:43:23.000000000 -0400
-+++ Makefile.in 2015-03-26 18:36:07.358178000 -0400
-@@ -38,7 +38,7 @@
+--- Makefile.in.orig 2005-04-23 22:43:23 UTC
++++ Makefile.in
+@@ -38,7 +38,7 @@ RELEASE = @ALLOWRELEASE@
# libtool compile/link/install
LTCOMPILE = $(LIBTOOL) --mode=compile $(TCC)
@@ -9,18 +9,14 @@
LTINSTALL = $(LIBTOOL) --mode=install $(INSTALL)
# Compiler options needed for programs that use the TCL library.
-@@ -471,8 +471,12 @@
- $(LTINSTALL) sqlite $(DESTDIR)$(exec_prefix)/bin
- $(INSTALL) -d $(DESTDIR)$(prefix)/include
- $(INSTALL) -m 0644 sqlite.h $(DESTDIR)$(prefix)/include
-- $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib/pkgconfig;
-- $(INSTALL) -m 0644 sqlite.pc $(DESTDIR)$(exec_prefix)/lib/pkgconfig;
-+ $(INSTALL) -d $(DESTDIR)/$(exec_prefix)/libdata/pkgconfig
-+ $(INSTALL) -m 0644 sqlite.pc $(DESTDIR)/$(exec_prefix)/libdata/pkgconfig
-+
+@@ -474,6 +474,10 @@ install: sqlite libsqlite.la sqlite.h
+ $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib/pkgconfig;
+ $(INSTALL) -m 0644 sqlite.pc $(DESTDIR)$(exec_prefix)/lib/pkgconfig;
+
+install-tcl: libtclsqlite.la
+ $(INSTALL) -d $(DESTDIR)$(prefix)/lib/sqlite
+ $(LTINSTALL) libtclsqlite.la $(DESTDIR)$(prefix)/lib/sqlite
-
++
clean:
rm -f *.lo *.la *.o sqlite@TARGET_EXEEXT@ libsqlite.la sqlite.h opcodes.*
+ rm -rf .libs .deps