aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlite3
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2020-07-11 20:23:00 +0000
committerBernard Spil <brnrd@FreeBSD.org>2020-07-11 20:23:00 +0000
commit837a0c94356a96b44dfe009959f2ef5625603167 (patch)
treec570047a25be3996504609be3cdff45bbb34a012 /databases/sqlite3
parent05c50ace80745ad875698269cd56e5a33e8cf48f (diff)
downloadports-837a0c94356a96b44dfe009959f2ef5625603167.tar.gz
ports-837a0c94356a96b44dfe009959f2ef5625603167.zip
databases/sqlite3: change options logic
PR: 222021 Submitted by: Pavel Volkov <pavelivolkov gmail com> Approved by: maintainer (pavelivolkov gmail com)
Notes
Notes: svn path=/head/; revision=542047
Diffstat (limited to 'databases/sqlite3')
-rw-r--r--databases/sqlite3/Makefile29
1 files changed, 11 insertions, 18 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index fc0857b13604..fde1d50366e9 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sqlite3
DISTVERSION= 3.32.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= https://www.sqlite.org/2020/ http://www2.sqlite.org/2020/ http://www3.sqlite.org/2020/
@@ -13,7 +14,7 @@ COMMENT= SQL database engine in a C library
LICENSE= PD
-USES= libtool ncurses pathfix
+USES= libtool pathfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -27,8 +28,8 @@ OPTIONS_DEFINE= FTS4 URI URI_AUTHORITY METADATA \
LIKENOTBLOB STSHELL FTS3_TOKEN UNKNOWN_SQL SORT_REF \
NORMALIZE DQS TRUSTED_SCHEMA
OPTIONS_SINGLE= RAMT
-OPTIONS_RADIO= STAT
-OPTIONS_GROUP= OPT_EXT OPT_FUNC UNICODE RTREEG RL
+OPTIONS_RADIO= STAT RL
+OPTIONS_GROUP= OPT_EXT OPT_FUNC UNICODE RTREEG
OPTIONS_GROUP_OPT_EXT= JSON1 SESSION
OPTIONS_GROUP_OPT_FUNC= OFFSET SER1 SOUNDEX
@@ -131,17 +132,11 @@ RTREE_INT_DESC= Store 32-bit sig int (no float) coordinates
GEOPOLY_DESC= Uses the GeoJSON notation (RFC-7946)
GEOPOLY_IMPLIES= RTREE
-OPTIONS_GROUP_RL= READLINES READLINEP EDITLINE
-RL_DESC= Which command line editing library to use:
-READLINES_DESC= the libreadline from system
-READLINEP_DESC= the GNU libreadline from ports
-EDITLINE_DESC= the BSD libedit from ports
-READLINES_PREVENTS= READLINEP EDITLINE
-READLINEP_PREVENTS= READLINES EDITLINE
-EDITLINE_PREVENTS= READLINES READLINEP
+OPTIONS_RADIO_RL= READLINES READLINEP EDITLINE
+RL_DESC= Command line editing library (may be off)
OPTIONS_DEFAULT= FTS4 URI METADATA SECURE_DELETE UNLOCK_NOTIFY THREADS \
- EXTENSION TS1 UNICODE61 RTREE DBSTAT STSHELL READLINES \
+ EXTENSION TS1 UNICODE61 RTREE DBSTAT STSHELL LIBEDIT \
FTS3_TOKEN FTS5 DQS JSON1
# SECURE_DELETE, UNLOCK_NOTIFY, DBSTAT (since 41.0) used by www/firefox et al.
# RTREE used by graphics/mapnik, databases/spatialite
@@ -206,12 +201,10 @@ ICU_LIBS= `${LOCALBASE}/bin/icu-config --ldflags`
UNICODE61_CPPFLAGS= ""
UNICODE61_CPPFLAGS_OFF= -DSQLITE_DISABLE_FTS3_UNICODE=1
-READLINES_CONFIGURE_ON= --enable-readline
-READLINES_USES= readline
-READLINEP_CONFIGURE_ON= --enable-readline
-READLINEP_USES= readline:port
-EDITLINE_CONFIGURE_ENABLE= editline
-EDITLINE_USES= libedit
+LIBEDIT_CONFIGURE_ENABLE= editline
+LIBEDIT_USES= libedit ncurses
+READLINE_CONFIGURE_ENABLE= readline
+READLINE_USES= readline ncurses
JSON1_CONFIGURE_ENABLE= json1