aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlitebrowser
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-07-30 19:36:56 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-07-30 19:36:56 +0000
commit03c65b8904ea553408384fbe10042106c1709266 (patch)
tree7ffd6e8a471c08e85ae0911d4f9ceacabd00758c /databases/sqlitebrowser
parenta18983bdf7caebdabf7914b6ddb0a0f0edcf4567 (diff)
downloadports-03c65b8904ea553408384fbe10042106c1709266.tar.gz
ports-03c65b8904ea553408384fbe10042106c1709266.zip
databases/sqlitebrowser: Update to 3.12.0
- Update to 3.12.0 - Remove patches fixed upstream - Patch .desktop location Changelog: - https://github.com/sqlitebrowser/sqlitebrowser/releases/tag/v3.12.0 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D25844
Notes
Notes: svn path=/head/; revision=543821
Diffstat (limited to 'databases/sqlitebrowser')
-rw-r--r--databases/sqlitebrowser/Makefile9
-rw-r--r--databases/sqlitebrowser/distinfo6
-rw-r--r--databases/sqlitebrowser/files/patch-cmake_FindQScintilla.cmake27
-rw-r--r--databases/sqlitebrowser/files/patch-src_grammar_Sqlite3Lexer.hpp10
4 files changed, 7 insertions, 45 deletions
diff --git a/databases/sqlitebrowser/Makefile b/databases/sqlitebrowser/Makefile
index 0eff6e23191b..032cd2255b5d 100644
--- a/databases/sqlitebrowser/Makefile
+++ b/databases/sqlitebrowser/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= sqlitebrowser
-PORTVERSION= 3.11.2
-PORTREVISION= 2
+PORTVERSION= 3.12.0
DISTVERSIONPREFIX= v
CATEGORIES= databases
@@ -27,8 +26,8 @@ INSTALLS_ICONS= yes
post-patch:
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
- ${WRKSRC}/src/PreferencesDialog.cpp
- @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
- ${WRKSRC}/src/Application.cpp
+ ${WRKSRC}/src/PreferencesDialog.cpp ${WRKSRC}/src/Application.cpp
+ @${REINPLACE_CMD} -e 's|metainfo|appdata|' \
+ ${WRKSRC}/src/src.pro ${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/databases/sqlitebrowser/distinfo b/databases/sqlitebrowser/distinfo
index fdeaa87113a9..6bd8e5973f8c 100644
--- a/databases/sqlitebrowser/distinfo
+++ b/databases/sqlitebrowser/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1556652171
-SHA256 (sqlitebrowser-sqlitebrowser-v3.11.2_GH0.tar.gz) = 298acb28878aa712277a1c35c185b07a5a1671cc3e2c6a21b323477b91d486fc
-SIZE (sqlitebrowser-sqlitebrowser-v3.11.2_GH0.tar.gz) = 2530497
+TIMESTAMP = 1595919997
+SHA256 (sqlitebrowser-sqlitebrowser-v3.12.0_GH0.tar.gz) = 3f1a1453ed0f4b5b72b0468bf8ee56887eb23d71c2518a449f4eb179471d73d1
+SIZE (sqlitebrowser-sqlitebrowser-v3.12.0_GH0.tar.gz) = 4017370
diff --git a/databases/sqlitebrowser/files/patch-cmake_FindQScintilla.cmake b/databases/sqlitebrowser/files/patch-cmake_FindQScintilla.cmake
deleted file mode 100644
index 7698da71c802..000000000000
--- a/databases/sqlitebrowser/files/patch-cmake_FindQScintilla.cmake
+++ /dev/null
@@ -1,27 +0,0 @@
-The find module sets QSCINTILLA_INCLUDE_DIR to the directory containing
-qsciscintilla.h, which in our case is already in the subdirectory Qsci/,
-so (also) try another path for the version file. Accept only the Qt5
-versions of the library.
-
---- cmake/FindQScintilla.cmake.orig 2017-09-20 13:59:51 UTC
-+++ cmake/FindQScintilla.cmake
-@@ -53,6 +53,10 @@ set ( QSCINTILLA_INCLUDE_DIRS ${QSCINTIL
-
- # version
- set ( _VERSION_FILE ${QSCINTILLA_INCLUDE_DIR}/Qsci/qsciglobal.h )
-+if ( NOT EXISTS ${_VERSION_FILE} )
-+ set ( _VERSION_FILE ${QSCINTILLA_INCLUDE_DIR}/qsciglobal.h )
-+endif()
-+
- if ( EXISTS ${_VERSION_FILE} )
- file ( STRINGS ${_VERSION_FILE} _VERSION_LINE REGEX "define[ ]+QSCINTILLA_VERSION_STR" )
- if ( _VERSION_LINE )
-@@ -80,7 +84,7 @@ endif ()
-
-
- find_library ( QSCINTILLA_LIBRARY
-- NAMES qscintilla qscintilla2 libqscintilla2
-+ NAMES qscintilla2_qt5 libqscintilla2_qt5
- HINTS ${QT_LIBRARY_DIR}
- )
-
diff --git a/databases/sqlitebrowser/files/patch-src_grammar_Sqlite3Lexer.hpp b/databases/sqlitebrowser/files/patch-src_grammar_Sqlite3Lexer.hpp
deleted file mode 100644
index 2fd72c890c09..000000000000
--- a/databases/sqlitebrowser/files/patch-src_grammar_Sqlite3Lexer.hpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/grammar/Sqlite3Lexer.hpp.orig 2018-12-19 22:04:37 UTC
-+++ src/grammar/Sqlite3Lexer.hpp
-@@ -7,6 +7,7 @@
- #include <antlr/InputBuffer.hpp>
- #include <antlr/BitSet.hpp>
- #include "sqlite3TokenTypes.hpp"
-+#include <strings.h>
- #include <antlr/CharScanner.hpp>
- class CUSTOM_API Sqlite3Lexer : public ANTLR_USE_NAMESPACE(antlr)CharScanner, public sqlite3TokenTypes
- {