aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlitebrowser
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-12-23 17:07:47 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-12-23 17:07:47 +0000
commit5856cd080b106272b34f98c8f3d082cd5ad9522b (patch)
tree1d81c5ac4e5e3efc63326f0a0208bf8f6c86542c /databases/sqlitebrowser
parentc8bd572bbd25728c54cb5f55dca1b58a24092888 (diff)
downloadports-5856cd080b106272b34f98c8f3d082cd5ad9522b.tar.gz
ports-5856cd080b106272b34f98c8f3d082cd5ad9522b.zip
This port needs USES=compiler:c++11-lang and #include <strings.h> in
src/grammar/Sqlite3Lexer.hpp to build on GCC-based architectures. While here, add USES=gnome. PR: 234206 Submitted by: Piotr Kubaj Approved by: maintainer
Notes
Notes: svn path=/head/; revision=488226
Diffstat (limited to 'databases/sqlitebrowser')
-rw-r--r--databases/sqlitebrowser/Makefile2
-rw-r--r--databases/sqlitebrowser/files/patch-src_grammar_Sqlite3Lexer.hpp10
2 files changed, 11 insertions, 1 deletions
diff --git a/databases/sqlitebrowser/Makefile b/databases/sqlitebrowser/Makefile
index 99ac5cd28f98..c07e2ff682de 100644
--- a/databases/sqlitebrowser/Makefile
+++ b/databases/sqlitebrowser/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/lib/libantlr.a:devel/antlr
LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
-USES= cmake desktop-file-utils qt:5 sqlite
+USES= compiler:c++11-lang cmake desktop-file-utils gnome qt:5 sqlite
CMAKE_ARGS+= -DQT_INCLUDE_DIR=${QT_INCDIR} -DQT_LIBRARY_DIR=${QT_LIBDIR}
USE_QT= core gui network printsupport testlib widgets \
buildtools_build linguisttools_build qmake_build
diff --git a/databases/sqlitebrowser/files/patch-src_grammar_Sqlite3Lexer.hpp b/databases/sqlitebrowser/files/patch-src_grammar_Sqlite3Lexer.hpp
new file mode 100644
index 000000000000..2fd72c890c09
--- /dev/null
+++ b/databases/sqlitebrowser/files/patch-src_grammar_Sqlite3Lexer.hpp
@@ -0,0 +1,10 @@
+--- src/grammar/Sqlite3Lexer.hpp.orig 2018-12-19 22:04:37 UTC
++++ src/grammar/Sqlite3Lexer.hpp
+@@ -7,6 +7,7 @@
+ #include <antlr/InputBuffer.hpp>
+ #include <antlr/BitSet.hpp>
+ #include "sqlite3TokenTypes.hpp"
++#include <strings.h>
+ #include <antlr/CharScanner.hpp>
+ class CUSTOM_API Sqlite3Lexer : public ANTLR_USE_NAMESPACE(antlr)CharScanner, public sqlite3TokenTypes
+ {