aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlitebrowser
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-02-06 13:29:25 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-02-06 13:29:25 +0000
commitce6563685eed5858eabd873a01830d0e360fc5ff (patch)
tree21f36514d13fe48b16c9cad0a8f7d27740febc85 /databases/sqlitebrowser
parente753120e08d4055141a23a37f6cdc6289ab4ec4c (diff)
downloadports-ce6563685eed5858eabd873a01830d0e360fc5ff.tar.gz
ports-ce6563685eed5858eabd873a01830d0e360fc5ff.zip
Update to 3.5.0.
PR: 197253 Submitted by: coder@tuxfamily.org (maintainer)
Notes
Notes: svn path=/head/; revision=378535
Diffstat (limited to 'databases/sqlitebrowser')
-rw-r--r--databases/sqlitebrowser/Makefile18
-rw-r--r--databases/sqlitebrowser/distinfo4
-rw-r--r--databases/sqlitebrowser/files/patch-src-Application.cpp28
-rw-r--r--databases/sqlitebrowser/files/patch-src-PreferencesDialog.cpp17
-rw-r--r--databases/sqlitebrowser/pkg-plist4
5 files changed, 66 insertions, 5 deletions
diff --git a/databases/sqlitebrowser/Makefile b/databases/sqlitebrowser/Makefile
index 6f02d9916bd7..afa099de0339 100644
--- a/databases/sqlitebrowser/Makefile
+++ b/databases/sqlitebrowser/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sqlitebrowser
-PORTVERSION= 3.4.0
+PORTVERSION= 3.5.0
CATEGORIES= databases
MAINTAINER= coder@tuxfamily.org
@@ -13,9 +13,9 @@ LICENSE_COMB= dual
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-${GH_COMMIT}
-USE_GITHUB=
+USE_GITHUB= yes
GH_ACCOUNT= sqlitebrowser
-GH_COMMIT= 0358faa
+GH_COMMIT= 634c51b
GH_TAGNAME= ${GH_COMMIT}
USES= cmake desktop-file-utils
@@ -23,4 +23,16 @@ USE_QT4= gui qmake_build linguist_build moc_build uic_build rcc_build
USE_SQLITE= yes
INSTALLS_ICONS= yes
+
+post-patch:
+ @${ECHO} ${DATADIR}
+ @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
+ ${WRKSRC}/src/PreferencesDialog.cpp
+ @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
+ ${WRKSRC}/src/Application.cpp
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${LOCALBASE}/share/${PORTNAME}/translations
+ (cd ${WRKSRC}/translations && ${COPYTREE_SHARE} . ${STAGEDIR}${LOCALBASE}/share/${PORTNAME}/translations)
+
.include <bsd.port.mk>
diff --git a/databases/sqlitebrowser/distinfo b/databases/sqlitebrowser/distinfo
index 1ae0845094da..081a8811d095 100644
--- a/databases/sqlitebrowser/distinfo
+++ b/databases/sqlitebrowser/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sqlitebrowser-3.4.0.tar.gz) = 9d2493c1b4ef15643b42899a2a6069fed75dae50073e3056adabb3b164904b8a
-SIZE (sqlitebrowser-3.4.0.tar.gz) = 841234
+SHA256 (sqlitebrowser-3.5.0.tar.gz) = 251175ecb3c9f7ac2db4b23216c370eceda502b82438cb9afa114fe89a0e8275
+SIZE (sqlitebrowser-3.5.0.tar.gz) = 872486
diff --git a/databases/sqlitebrowser/files/patch-src-Application.cpp b/databases/sqlitebrowser/files/patch-src-Application.cpp
new file mode 100644
index 000000000000..80d657873d5c
--- /dev/null
+++ b/databases/sqlitebrowser/files/patch-src-Application.cpp
@@ -0,0 +1,28 @@
+--- src/Application.cpp.orig 2015-01-30 19:48:06.000000000 +0100
++++ src/Application.cpp 2015-02-01 15:40:02.790619098 +0100
+@@ -30,8 +30,15 @@
+
+ // First of all try to load the application translation file.
+ m_translatorApp = new QTranslator(this);
++
++#ifdef Q_OS_FREEBSD
++ QString trans_dir = "%%DATADIR%%/translations";
++ ok = m_translatorApp->load("sqlb_" + name,
++ trans_dir);
++#else
+ ok = m_translatorApp->load("sqlb_" + name,
+ QCoreApplication::applicationDirPath() + "/translations");
++#endif
+
+ if (ok == true) {
+ PreferencesDialog::setSettingsValue("General", "language", name);
+@@ -47,7 +54,9 @@
+ ok = m_translatorQt->load("qt_" + name,
+ QLibraryInfo::location(QLibraryInfo::TranslationsPath));
+ if (ok == false)
++ {
+ ok = m_translatorQt->load("qt_" + name, "translations");
++ }
+ if (ok == true)
+ installTranslator(m_translatorQt);
+ }
diff --git a/databases/sqlitebrowser/files/patch-src-PreferencesDialog.cpp b/databases/sqlitebrowser/files/patch-src-PreferencesDialog.cpp
new file mode 100644
index 000000000000..c88f834ada60
--- /dev/null
+++ b/databases/sqlitebrowser/files/patch-src-PreferencesDialog.cpp
@@ -0,0 +1,17 @@
+--- src/PreferencesDialog.cpp.orig 2015-02-01 15:27:53.407669984 +0100
++++ src/PreferencesDialog.cpp 2015-02-01 15:30:51.885904399 +0100
+@@ -266,9 +266,13 @@
+ void PreferencesDialog::fillLanguageBox()
+ {
+ // Use the path relative to the main executable
++#ifdef Q_OS_FREEBSD
++ QDir translationsDir("%%DATADIR%%/translations",
++ "sqlb_*.qm");
++#else
+ QDir translationsDir(QCoreApplication::applicationDirPath() + "/translations",
+ "sqlb_*.qm");
+-
++#endif
+ // Add default language
+ ui->languageComboBox->addItem("English (United States)", "en_US");
+
diff --git a/databases/sqlitebrowser/pkg-plist b/databases/sqlitebrowser/pkg-plist
index ca96fa6a2f53..67f4ea11a802 100644
--- a/databases/sqlitebrowser/pkg-plist
+++ b/databases/sqlitebrowser/pkg-plist
@@ -1,3 +1,7 @@
%%QT_BINDIR%%/sqlitebrowser
share/applications/sqlitebrowser.desktop
share/icons/hicolor/256x256/apps/sqlitebrowser.png
+%%DATADIR%%/translations/sqlb_de.qm
+%%DATADIR%%/translations/sqlb_fr.qm
+%%DATADIR%%/translations/sqlb_ru.qm
+%%DATADIR%%/translations/sqlb_zh.qm