aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlitebrowser
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-08-12 00:10:35 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-08-12 00:10:35 +0000
commite86c459a92c3383ff251de576e34de7833a63dc2 (patch)
treecb786fa8a47592c8a255146036405e9ad10a2842 /databases/sqlitebrowser
parent279e35637e7a271b56910fe1f9b256b2259c42db (diff)
downloadports-e86c459a92c3383ff251de576e34de7833a63dc2.tar.gz
ports-e86c459a92c3383ff251de576e34de7833a63dc2.zip
databases/sqlitebrowser: modernize, fix dependencies
- Replace USE_QT4=linguist_build with USE_QT4=linguisttools_build. - Add missed corelib and network components into USE_QT4. - Regenerate patches. - Bump PORTREVISION PR: 201648 Submitted by: s3erios@gmail.com Approved by: maintainer timeout (coder@tuxfamily.org ; 25 days)
Notes
Notes: svn path=/head/; revision=393992
Diffstat (limited to 'databases/sqlitebrowser')
-rw-r--r--databases/sqlitebrowser/Makefile4
-rw-r--r--databases/sqlitebrowser/files/patch-src-Application.cpp8
-rw-r--r--databases/sqlitebrowser/files/patch-src-PreferencesDialog.cpp6
3 files changed, 10 insertions, 8 deletions
diff --git a/databases/sqlitebrowser/Makefile b/databases/sqlitebrowser/Makefile
index 6aba7fd1516c..f3ca417a85fc 100644
--- a/databases/sqlitebrowser/Makefile
+++ b/databases/sqlitebrowser/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sqlitebrowser
PORTVERSION= 3.6.0
+PORTREVISION= 1
CATEGORIES= databases
MAINTAINER= coder@tuxfamily.org
@@ -16,7 +17,8 @@ GH_ACCOUNT= sqlitebrowser
GH_TAGNAME= e703344
USES= cmake desktop-file-utils
-USE_QT4= gui qmake_build linguist_build moc_build uic_build rcc_build
+USE_QT4= corelib network gui qmake_build linguisttools_build \
+ moc_build uic_build rcc_build
USE_SQLITE= yes
INSTALLS_ICONS= yes
diff --git a/databases/sqlitebrowser/files/patch-src-Application.cpp b/databases/sqlitebrowser/files/patch-src-Application.cpp
index 80d657873d5c..12467e13e512 100644
--- a/databases/sqlitebrowser/files/patch-src-Application.cpp
+++ b/databases/sqlitebrowser/files/patch-src-Application.cpp
@@ -1,6 +1,6 @@
---- src/Application.cpp.orig 2015-01-30 19:48:06.000000000 +0100
-+++ src/Application.cpp 2015-02-01 15:40:02.790619098 +0100
-@@ -30,8 +30,15 @@
+--- src/Application.cpp.orig 2015-04-27 09:31:47 UTC
++++ src/Application.cpp
+@@ -30,8 +30,15 @@ Application::Application(int& argc, char
// First of all try to load the application translation file.
m_translatorApp = new QTranslator(this);
@@ -16,7 +16,7 @@
if (ok == true) {
PreferencesDialog::setSettingsValue("General", "language", name);
-@@ -47,7 +54,9 @@
+@@ -47,7 +54,9 @@ Application::Application(int& argc, char
ok = m_translatorQt->load("qt_" + name,
QLibraryInfo::location(QLibraryInfo::TranslationsPath));
if (ok == false)
diff --git a/databases/sqlitebrowser/files/patch-src-PreferencesDialog.cpp b/databases/sqlitebrowser/files/patch-src-PreferencesDialog.cpp
index 14f2e9074f67..ae8841d1d786 100644
--- a/databases/sqlitebrowser/files/patch-src-PreferencesDialog.cpp
+++ b/databases/sqlitebrowser/files/patch-src-PreferencesDialog.cpp
@@ -1,6 +1,6 @@
---- src/PreferencesDialog.cpp.orig 2015-05-09 08:19:49.920343024 +0200
-+++ src/PreferencesDialog.cpp 2015-05-09 08:20:57.913337598 +0200
-@@ -356,8 +356,15 @@
+--- src/PreferencesDialog.cpp.orig 2015-04-27 09:31:47 UTC
++++ src/PreferencesDialog.cpp
+@@ -356,8 +356,15 @@ void PreferencesDialog::removeExtension(
void PreferencesDialog::fillLanguageBox()
{