aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlitestudio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-08-19 20:14:00 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-08-19 20:14:00 +0000
commit89f87c49a96c2f3133cbf2bb0c8b08cc388ff53a (patch)
tree220cca815d3c5e4146cbc008f90cf013c7fed51a /databases/sqlitestudio
parentb0f39bfa5892ee92fe25bdc517e245192648d309 (diff)
downloadports-89f87c49a96c2f3133cbf2bb0c8b08cc388ff53a.tar.gz
ports-89f87c49a96c2f3133cbf2bb0c8b08cc388ff53a.zip
databases/sqlitestudio: Add the .desktop file and the icon.
Caveat: the icon isn't displayed in xfce's Applications menu, see https://bugzilla.xfce.org/show_bug.cgi?id=15855 Requested by: John L. Males <jlmales@gmail.com> (user; reported/requested via e-mail)
Notes
Notes: svn path=/head/; revision=509308
Diffstat (limited to 'databases/sqlitestudio')
-rw-r--r--databases/sqlitestudio/Makefile18
-rw-r--r--databases/sqlitestudio/pkg-plist1
2 files changed, 17 insertions, 2 deletions
diff --git a/databases/sqlitestudio/Makefile b/databases/sqlitestudio/Makefile
index 329d39728e02..a754bbc53bff 100644
--- a/databases/sqlitestudio/Makefile
+++ b/databases/sqlitestudio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sqlitestudio
DISTVERSION= 3.2.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= databases
MASTER_SITES= http://sqlitestudio.pl/files/sqlitestudio3/complete/tar/
@@ -31,7 +31,7 @@ PLUGIN_PRINTING_USE= QT=printsupport
WRKSRC= ${WRKDIR}/SQLiteStudio3
-USES= compiler:c++11-lib gmake ncurses qmake qt:5 readline sqlite
+USES= compiler:c++11-lib gl gmake ncurses qmake qt:5 readline sqlite
USE_CXXSTD= c++11
USE_QT= core concurrent gui network script sql sql-sqlite3_run svg widgets xml \
uitools buildtools_build linguisttools_build
@@ -39,6 +39,13 @@ USE_GL= gl
CXXFLAGS+= -I${WRKSRC}/coreSQLiteStudio
+DESKTOP_ENTRIES= "SQLite database manager" \
+ "Advanced SQLite database manager" \
+ "SQLiteStudio" \
+ "SQLiteStudio" \
+ "Database;Viewer;DataVisualization;Development;Qt;" \
+ ""
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/|${LOCALBASE}/|' \
${WRKSRC}/dirs.pri
@@ -56,15 +63,22 @@ post-configure:
cd ${WRKDIR}/Plugins/$$plugin && \
${SETENV} ${QMAKE_ENV} ${_QMAKE} ${QMAKE_ARGS} ${QMAKE_SOURCE_PATH}; \
done;
+
post-build:
@for plugin in ${PLUGIN_DIRS}; do \
cd ${WRKDIR}/Plugins/$$plugin && \
${DO_MAKE_BUILD} ${ALL_TARGET}; \
done;
+
post-install:
@for plugin in ${PLUGIN_DIRS}; do \
cd ${WRKDIR}/Plugins/$$plugin && \
${SETENV} ${MAKE_ENV} ${FAKEROOT} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; \
done;
+ # install icons for the .desktop file to work
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
+ ${INSTALL_DATA} \
+ ${WRKSRC}/guiSQLiteStudio/img/sqlitestudio.svg \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/SQLiteStudio.svg
.include <bsd.port.mk>
diff --git a/databases/sqlitestudio/pkg-plist b/databases/sqlitestudio/pkg-plist
index ccf7b0167286..8591cf137fd5 100644
--- a/databases/sqlitestudio/pkg-plist
+++ b/databases/sqlitestudio/pkg-plist
@@ -21,3 +21,4 @@ lib/libguiSQLiteStudio.so.1.0.0
%%PLUGIN_SQL_EXPORT%%lib/sqlitestudio/libSqlExport.so
%%PLUGIN_SQL_ENTERPRISE_FORMATTER%%lib/sqlitestudio/libSqlEnterpriseFormatter.so
%%PLUGIN_XML_EXPORT%%lib/sqlitestudio/libXmlExport.so
+share/icons/hicolor/scalable/apps/SQLiteStudio.svg