aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlitestudio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-26 19:00:19 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-26 19:00:19 +0000
commitbb3119435520ea653a6c1448c6ec5eee2de0c801 (patch)
treee88e590d21d71b5a5bbaee73ea2355b9baa04fa7 /databases/sqlitestudio
parente011e2dcbbfd3ac7ce2fa3ec1a62be65d0b505cf (diff)
downloadports-bb3119435520ea653a6c1448c6ec5eee2de0c801.tar.gz
ports-bb3119435520ea653a6c1448c6ec5eee2de0c801.zip
databases/sqlitestudio: Update 3.1.1 -> 3.2.0
Changelog: https://sqlitestudio.pl/index.rvt?act=changelog Port changes: * Use DISTVERSION * Update LICENSE_FILE * Add options group * Simplify option handling such that the plugins list is in only one place * New plugin was added: MultiEditorImage * Remove USE_LDCONFIG, not needed
Notes
Notes: svn path=/head/; revision=475394
Diffstat (limited to 'databases/sqlitestudio')
-rw-r--r--databases/sqlitestudio/Makefile56
-rw-r--r--databases/sqlitestudio/distinfo6
-rw-r--r--databases/sqlitestudio/files/patch-coreSQLiteStudio_common_utils.cpp10
-rw-r--r--databases/sqlitestudio/files/patch-coreSQLiteStudio_db_db.h25
-rw-r--r--databases/sqlitestudio/files/patch-coreSQLiteStudio_services_functionmanager.h10
-rw-r--r--databases/sqlitestudio/files/patch-sqlitestudiocli_cli__config.h10
-rw-r--r--databases/sqlitestudio/pkg-plist3
7 files changed, 21 insertions, 99 deletions
diff --git a/databases/sqlitestudio/Makefile b/databases/sqlitestudio/Makefile
index cd4ec0adefa5..6796f5631d95 100644
--- a/databases/sqlitestudio/Makefile
+++ b/databases/sqlitestudio/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= sqlitestudio
-PORTVERSION= 3.1.1
-PORTREVISION= 5
+DISTVERSION= 3.2.0
CATEGORIES= databases
MASTER_SITES= http://sqlitestudio.pl/files/sqlitestudio3/complete/tar/
@@ -11,30 +10,23 @@ MAINTAINER= yuri@FreeBSD.org
COMMENT= SQLite database GUI manager
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/guiSQLiteStudio/license.txt
+LICENSE_FILE= ${WRKSRC}/coreSQLiteStudio/licenses/sqlitestudio_license.txt
-OPTIONS_DEFINE= PLUGIN_CSV_IMPORT PLUGIN_CSV_EXPORT PLUGIN_DB_SQLITE_CIPHER PLUGIN_HTML_EXPORT
-OPTIONS_DEFINE+= PLUGIN_JSON_EXPORT PLUGIN_PDF_EXPORT PLUGIN_PRINTING PLUGIN_REGEXP_IMPORT
-OPTIONS_DEFINE+= PLUGIN_SQL_FORMATTER_SIMPLE PLUGIN_SQL_EXPORT PLUGIN_SQL_ENTERPRISE_FORMATTER
-OPTIONS_DEFINE+= PLUGIN_XML_EXPORT
-PLUGIN_CSV_IMPORT_DESC= Install CsvImport plugin
-PLUGIN_CSV_EXPORT_DESC= Install CsvExport plugin
-PLUGIN_DB_SQLITE_CIPHER_DESC= Install DbSqliteCipher plugin
-PLUGIN_HTML_EXPORT_DESC= Install HtmlExport plugin
-PLUGIN_JSON_EXPORT_DESC= Install JsonExport plugin
-PLUGIN_PDF_EXPORT_DESC= Install PdfExport plugin
-PLUGIN_PRINTING_DESC= Install Printing plugin
-PLUGIN_REGEXP_IMPORT_DESC= Install RegExp plugin
-PLUGIN_SQL_FORMATTER_SIMPLE_DESC= Install SqlFormatterSimple plugin
-PLUGIN_SQL_EXPORT_DESC= Install SqlExport plugin
-PLUGIN_SQL_ENTERPRISE_FORMATTER_DESC= Install SqlEnterpriseFormatter plugin
-PLUGIN_XML_EXPORT_DESC= Install XmlExport plugin
-
-OPTIONS_DEFAULT= PLUGIN_CSV_IMPORT PLUGIN_CSV_EXPORT PLUGIN_HTML_EXPORT
-OPTIONS_DEFAULT+= PLUGIN_JSON_EXPORT PLUGIN_PDF_EXPORT PLUGIN_PRINTING PLUGIN_REGEXP_IMPORT
-OPTIONS_DEFAULT+= PLUGIN_SQL_FORMATTER_SIMPLE PLUGIN_SQL_EXPORT PLUGIN_SQL_ENTERPRISE_FORMATTER
-OPTIONS_DEFAULT+= PLUGIN_XML_EXPORT
+OPTIONS_GROUP= PLUGINS
+OPTIONS_DEFAULT= ${OPTIONS_GROUP_PLUGINS}
OPTIONS_SUB= yes
+PLUGINS_DESC= Install plugins:
+
+ALL_PLUGINS= CsvImport CsvExport DbSqliteCipher HtmlExport JsonExport MultiEditorImage PdfExport Printing \
+ RegExpImport SqlFormatterSimple SqlExport SqlEnterpriseFormatter XmlExport
+.for p in ${ALL_PLUGINS}
+OPTIONS_GROUP_PLUGINS+= PLUGIN${p:C/([A-Z])/_\1/g:tu}
+PLUGIN${p:C/([A-Z])/_\1/g:tu}_DESC= ${p} plugin
+PLUGIN${p:C/([A-Z])/_\1/g:tu}_VARS= PLUGIN_DIRS+=${p}
+.endfor
+
+PLUGIN_DB_SQLITE_CIPHER_USES= ssl
+PLUGIN_PRINTING_USE= QT=printsupport
WRKSRC= ${WRKDIR}/SQLiteStudio3
@@ -43,7 +35,6 @@ USE_CXXSTD= c++11
USE_QT= core concurrent gui network script sql sql-sqlite3_run svg widgets xml \
uitools buildtools_build linguisttools_build
USE_GL= gl
-USE_LDCONFIG= yes
CXXFLAGS+= -I${WRKSRC}/coreSQLiteStudio
@@ -56,21 +47,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|^include(.*|include($$$$PWD/../../SQLiteStudio3/plugins.pri)|' \
${WRKDIR}/Plugins/DbSqliteCipher/DbSqliteCipher.pro
-PLUGIN_DIRS=
-PLUGIN_CSV_IMPORT_VARS= PLUGIN_DIRS+=CsvImport
-PLUGIN_CSV_EXPORT_VARS= PLUGIN_DIRS+=CsvExport
-PLUGIN_DB_SQLITE_CIPHER_USES= ssl
-PLUGIN_DB_SQLITE_CIPHER_VARS= PLUGIN_DIRS+=DbSqliteCipher
-PLUGIN_HTML_EXPORT_VARS= PLUGIN_DIRS+=HtmlExport
-PLUGIN_JSON_EXPORT_VARS= PLUGIN_DIRS+=JsonExport
-PLUGIN_PDF_EXPORT_VARS= PLUGIN_DIRS+=PdfExport
-PLUGIN_PRINTING_VARS= PLUGIN_DIRS+=Printing USE_QT+=printsupport
-PLUGIN_REGEXP_IMPORT_VARS= PLUGIN_DIRS+=RegExpImport
-PLUGIN_SQL_ENTERPRISE_FORMATTER_VARS= PLUGIN_DIRS+=SqlEnterpriseFormatter
-PLUGIN_SQL_EXPORT_VARS= PLUGIN_DIRS+=SqlExport
-PLUGIN_SQL_FORMATTER_SIMPLE_VARS= PLUGIN_DIRS+=SqlFormatterSimple
-PLUGIN_XML_EXPORT_VARS= PLUGIN_DIRS+=XmlExport
-
post-configure:
# Fix for a suspected bug in qmake: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=210418
@${REINPLACE_CMD} -E 's|SUBLIBS) -L[^ ]+|SUBLIBS) |' ${WRKSRC}/sqlitestudio/Makefile
diff --git a/databases/sqlitestudio/distinfo b/databases/sqlitestudio/distinfo
index 4dab40fee8bd..980a0c3d9de6 100644
--- a/databases/sqlitestudio/distinfo
+++ b/databases/sqlitestudio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1481570258
-SHA256 (sqlitestudio-3.1.1.tar.gz) = f757a82466e97137addd70dd5323a1a7ba7cad7841dc138812a2da2799f92c6c
-SIZE (sqlitestudio-3.1.1.tar.gz) = 8610037
+TIMESTAMP = 1532583392
+SHA256 (sqlitestudio-3.2.0.tar.gz) = 73822e13e668383a41e643c2c0ec79449251b64c4b1f374e1afbba6c1fbe381d
+SIZE (sqlitestudio-3.2.0.tar.gz) = 9404865
diff --git a/databases/sqlitestudio/files/patch-coreSQLiteStudio_common_utils.cpp b/databases/sqlitestudio/files/patch-coreSQLiteStudio_common_utils.cpp
deleted file mode 100644
index de400a9e215d..000000000000
--- a/databases/sqlitestudio/files/patch-coreSQLiteStudio_common_utils.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- coreSQLiteStudio/common/utils.cpp.orig 2016-01-21 10:31:10 UTC
-+++ coreSQLiteStudio/common/utils.cpp
-@@ -2,6 +2,7 @@
- #include "common/global.h"
- #include "dbobjecttype.h"
- #include "rsa/RSA.h"
-+#include <QDataStream>
- #include <QTextCodec>
- #include <QString>
- #include <QSet>
diff --git a/databases/sqlitestudio/files/patch-coreSQLiteStudio_db_db.h b/databases/sqlitestudio/files/patch-coreSQLiteStudio_db_db.h
deleted file mode 100644
index d517cb0fcf86..000000000000
--- a/databases/sqlitestudio/files/patch-coreSQLiteStudio_db_db.h
+++ /dev/null
@@ -1,25 +0,0 @@
---- coreSQLiteStudio/db/db.h.orig 2016-11-04 15:27:43 UTC
-+++ coreSQLiteStudio/db/db.h
-@@ -1,6 +1,7 @@
- #ifndef DB_H
- #define DB_H
-
-+#include <QVariant> // upstream didn't fix the broken build for many months
- #include "returncode.h"
- #include "dialect.h"
- #include "services/functionmanager.h"
-@@ -10,13 +11,13 @@
- #include "interruptable.h"
- #include "dbobjecttype.h"
- #include <QObject>
--#include <QVariant>
- #include <QList>
- #include <QHash>
- #include <QReadWriteLock>
- #include <QRunnable>
- #include <QStringList>
- #include <QSet>
-+#include <QDataStream>
-
- /** @file */
-
diff --git a/databases/sqlitestudio/files/patch-coreSQLiteStudio_services_functionmanager.h b/databases/sqlitestudio/files/patch-coreSQLiteStudio_services_functionmanager.h
deleted file mode 100644
index 3a8ba57a4cb9..000000000000
--- a/databases/sqlitestudio/files/patch-coreSQLiteStudio_services_functionmanager.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- coreSQLiteStudio/services/functionmanager.h.orig 2017-11-23 00:59:57 UTC
-+++ coreSQLiteStudio/services/functionmanager.h
-@@ -3,6 +3,7 @@
-
- #include "coreSQLiteStudio_global.h"
- #include "common/global.h"
-+#include <QVariant> // upstream didn't fix the broken build for many months
- #include <QList>
- #include <QSharedPointer>
- #include <QObject>
diff --git a/databases/sqlitestudio/files/patch-sqlitestudiocli_cli__config.h b/databases/sqlitestudio/files/patch-sqlitestudiocli_cli__config.h
deleted file mode 100644
index 15f461e5ff4f..000000000000
--- a/databases/sqlitestudio/files/patch-sqlitestudiocli_cli__config.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- sqlitestudiocli/cli_config.h.orig 2016-01-21 10:44:03 UTC
-+++ sqlitestudiocli/cli_config.h
-@@ -2,6 +2,7 @@
- #define CLI_CONFIG_H
-
- #include "config_builder.h"
-+#include <QDataStream>
-
- namespace CliResultsDisplay
- {
diff --git a/databases/sqlitestudio/pkg-plist b/databases/sqlitestudio/pkg-plist
index 5fbfbc4ffc15..ccf7b0167286 100644
--- a/databases/sqlitestudio/pkg-plist
+++ b/databases/sqlitestudio/pkg-plist
@@ -13,9 +13,10 @@ lib/libguiSQLiteStudio.so.1.0.0
%%PLUGIN_DB_SQLITE_CIPHER%%lib/sqlitestudio/libDbSqliteCipher.so
%%PLUGIN_HTML_EXPORT%%lib/sqlitestudio/libHtmlExport.so
%%PLUGIN_JSON_EXPORT%%lib/sqlitestudio/libJsonExport.so
+%%PLUGIN_MULTI_EDITOR_IMAGE%%lib/sqlitestudio/libMultiEditorImage.so
%%PLUGIN_PDF_EXPORT%%lib/sqlitestudio/libPdfExport.so
%%PLUGIN_PRINTING%%lib/sqlitestudio/libPrinting.so
-%%PLUGIN_REGEXP_IMPORT%%lib/sqlitestudio/libRegExpImport.so
+%%PLUGIN_REG_EXP_IMPORT%%lib/sqlitestudio/libRegExpImport.so
%%PLUGIN_SQL_FORMATTER_SIMPLE%%lib/sqlitestudio/libSqlFormatterSimple.so
%%PLUGIN_SQL_EXPORT%%lib/sqlitestudio/libSqlExport.so
%%PLUGIN_SQL_ENTERPRISE_FORMATTER%%lib/sqlitestudio/libSqlEnterpriseFormatter.so