aboutsummaryrefslogtreecommitdiff
path: root/databases/tablelog
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-15 19:22:58 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-15 19:22:58 +0000
commit61c43ad466bd4729142c097f5333941b9f262ba7 (patch)
treeed16d2b3f91c88b1f4510dea1a275d3793a02dc4 /databases/tablelog
parent4dbd9f401a603eaa8afb293f1f9cbd05a87e7b9d (diff)
downloadports-61c43ad466bd4729142c097f5333941b9f262ba7.tar.gz
ports-61c43ad466bd4729142c097f5333941b9f262ba7.zip
Notes
Diffstat (limited to 'databases/tablelog')
-rw-r--r--databases/tablelog/Makefile38
-rw-r--r--databases/tablelog/distinfo3
-rw-r--r--databases/tablelog/pkg-descr7
-rw-r--r--databases/tablelog/pkg-plist5
4 files changed, 53 insertions, 0 deletions
diff --git a/databases/tablelog/Makefile b/databases/tablelog/Makefile
new file mode 100644
index 000000000000..18ae85cc13ff
--- /dev/null
+++ b/databases/tablelog/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: tablelog
+# Date created: 11 July 2007
+# Whom: Robert Gogolok <gogo@cs.uni-sb.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tablelog
+PORTVERSION= 0.4.4
+CATEGORIES= databases
+MASTER_SITES= http://pgfoundry.org/frs/download.php/1387/
+
+MAINTAINER= gogo@cs.uni-sb.de
+COMMENT= Logs changes on a table in PostgreSQL
+
+WRKSRC= ${WRKDIR}/table_log-${DISTVERSION}
+
+USE_GMAKE= yes
+USE_PGSQL= yes
+
+IGNORE_WITH_PGSQL= 73
+
+MAKE_ARGS= USE_PGXS=1
+
+PORTDOCS= README.table_log table_log.sql
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/postgresql/
+ @${INSTALL_PROGRAM} ${WRKSRC}/table_log.so ${PREFIX}/lib/postgresql/
+ @${MKDIR} ${PREFIX}/share/postgresql/contrib/
+ @${INSTALL_DATA} ${WRKSRC}/table_log_init.sql \
+ ${PREFIX}/share/postgresql/contrib/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/tablelog/distinfo b/databases/tablelog/distinfo
new file mode 100644
index 000000000000..ba73f7e81ace
--- /dev/null
+++ b/databases/tablelog/distinfo
@@ -0,0 +1,3 @@
+MD5 (tablelog-0.4.4.tar.gz) = 5eefddc340c150c98625086ae5779ba3
+SHA256 (tablelog-0.4.4.tar.gz) = 58c84388daf7ef0b692be981821f2586d9553901005b613581e0fcdb7ed51ffd
+SIZE (tablelog-0.4.4.tar.gz) = 14197
diff --git a/databases/tablelog/pkg-descr b/databases/tablelog/pkg-descr
new file mode 100644
index 000000000000..829a1b0a2a01
--- /dev/null
+++ b/databases/tablelog/pkg-descr
@@ -0,0 +1,7 @@
+Tablelog is a contributed PostgreSQL module that uses a trigger to log
+any INSERTs, UPDATEs and DELETEs on a specific table into another table.
+The second part of tablelog is able to restore the state of the original
+table or of a specific row for any time in the past.
+
+WWW: http://tablelog.projects.postgresql.org/
+Author: Andreas Scherbaum <ads-pgfoundry @nospam@ wars-nicht.de>
diff --git a/databases/tablelog/pkg-plist b/databases/tablelog/pkg-plist
new file mode 100644
index 000000000000..4b31153ed577
--- /dev/null
+++ b/databases/tablelog/pkg-plist
@@ -0,0 +1,5 @@
+lib/postgresql/table_log.so
+share/postgresql/contrib/table_log_init.sql
+@dirrmtry lib/postgresql
+@dirrmtry share/postgresql/contrib
+@dirrmtry share/postgresql