aboutsummaryrefslogtreecommitdiff
path: root/databases/tarantool-c
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-06-25 20:51:43 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-06-25 20:51:43 +0000
commitb1db263c43915eb8ed6d7e08b7cdbfb1ca7425f3 (patch)
tree3cf2dbe513587a66eb9154489915316cd24a3588 /databases/tarantool-c
parente4b9232b2f4cdb584398e5c793b7263e34e77b19 (diff)
downloadports-b1db263c43915eb8ed6d7e08b7cdbfb1ca7425f3.tar.gz
ports-b1db263c43915eb8ed6d7e08b7cdbfb1ca7425f3.zip
Update r504086: use an unconditional patch which could be merged upstream
Tested by: linimon
Notes
Notes: svn path=/head/; revision=505107
Diffstat (limited to 'databases/tarantool-c')
-rw-r--r--databases/tarantool-c/Makefile8
-rw-r--r--databases/tarantool-c/files/extra-patch-tnt_CMakeLists.txt14
-rw-r--r--databases/tarantool-c/files/patch-tnt_CMakeLists.txt15
3 files changed, 16 insertions, 21 deletions
diff --git a/databases/tarantool-c/Makefile b/databases/tarantool-c/Makefile
index eae4d49f5660..ff93107613f7 100644
--- a/databases/tarantool-c/Makefile
+++ b/databases/tarantool-c/Makefile
@@ -25,10 +25,4 @@ post-patch:
@${GREP} -lr 'msgpuck/msgpuck.h' ${WRKSRC}/ | ${XARGS} ${REINPLACE_CMD} -e 's|msgpuck/msgpuck.h|msgpuck.h|'
@${REINPLACE_CMD} -e 's|libmsgpuck.a|libmsgpuck.so|' ${WRKSRC}/cmake/FindMsgPuck.cmake
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-tnt_CMakeLists.txt
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/tarantool-c/files/extra-patch-tnt_CMakeLists.txt b/databases/tarantool-c/files/extra-patch-tnt_CMakeLists.txt
deleted file mode 100644
index 79f7dd66c15c..000000000000
--- a/databases/tarantool-c/files/extra-patch-tnt_CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- tnt/CMakeLists.txt.orig 2019-02-21 14:33:51 UTC
-+++ tnt/CMakeLists.txt
-@@ -49,8 +49,9 @@ set (TNT_SOURCES
- # Builds
- #----------------------------------------------------------------------------#
-
--set_source_files_properties(${PROJECT_SOURCE_DIR}/third_party/uri.c PROPERTIES
-- COMPILE_FLAGS "-Wno-implicit-fallthrough")
-+# -Wno-implicit-fallthrough only has meaning for llvm
-+#set_source_files_properties(${PROJECT_SOURCE_DIR}/third_party/uri.c PROPERTIES
-+# COMPILE_FLAGS "-Wno-implicit-fallthrough")
-
- ## Static library
- project(tnt)
diff --git a/databases/tarantool-c/files/patch-tnt_CMakeLists.txt b/databases/tarantool-c/files/patch-tnt_CMakeLists.txt
new file mode 100644
index 000000000000..62fe4f8eb936
--- /dev/null
+++ b/databases/tarantool-c/files/patch-tnt_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- tnt/CMakeLists.txt.orig 2019-06-14 13:13:47 UTC
++++ tnt/CMakeLists.txt
+@@ -49,8 +49,10 @@ set (TNT_SOURCES
+ # Builds
+ #----------------------------------------------------------------------------#
+
+-set_source_files_properties(${PROJECT_SOURCE_DIR}/third_party/uri.c PROPERTIES
+- COMPILE_FLAGS "-Wno-implicit-fallthrough")
++if(CMAKE_COMPILER_IS_CLANG AND NOT CMAKE_COMPILER_IS_GNUCC)
++ set_source_files_properties(${PROJECT_SOURCE_DIR}/third_party/uri.c PROPERTIES
++ COMPILE_FLAGS "-Wno-implicit-fallthrough")
++endif()
+
+ ## Static library
+ project(tnt)