aboutsummaryrefslogtreecommitdiff
path: root/databases/tarantool
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-01 13:34:54 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-01 13:34:54 +0000
commit2075c77ea2337152254cb362812d546e3b399e73 (patch)
treee6f4fbeb4644f46a2d65b7c641ef7c0b02804c65 /databases/tarantool
parentf3dbcc0a9f1742328ca59b8197d81e435098f33b (diff)
downloadports-2075c77ea2337152254cb362812d546e3b399e73.tar.gz
ports-2075c77ea2337152254cb362812d546e3b399e73.zip
Update to 1.9.0
- Add LICENSE_FILE - Use CMAKE_BOOL and CMAKE_ON - Clean up Makefile - Update pkg-descr - Update WWW - Take maintainership Changes: https://github.com/tarantool/tarantool/releases https://github.com/tarantool/tarantool/commits/1.9
Notes
Notes: svn path=/head/; revision=463309
Diffstat (limited to 'databases/tarantool')
-rw-r--r--databases/tarantool/Makefile69
-rw-r--r--databases/tarantool/distinfo16
-rw-r--r--databases/tarantool/files/pkg-message.in26
-rw-r--r--databases/tarantool/pkg-descr29
-rw-r--r--databases/tarantool/pkg-plist80
5 files changed, 148 insertions, 72 deletions
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
index 0219a9a08501..cce751a6b212 100644
--- a/databases/tarantool/Makefile
+++ b/databases/tarantool/Makefile
@@ -2,59 +2,62 @@
# $FreeBSD$
PORTNAME= tarantool
-PORTVERSION= 1.7.4.260
-PORTREVISION= 2
+PORTVERSION= 1.9.0
CATEGORIES= databases
-MASTER_SITES= http://download.tarantool.org/tarantool/1.7/src/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= NoSQL database running in a Lua application server
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
NOT_FOR_ARCHS= armv6 powerpc64 sparc64
NOT_FOR_ARCHS_REASON= fails to build: Unsupported architecture
-MAKE_JOBS_UNSAFE=yes
-USES= cmake:noninja compiler:c++11-lang gettext gmake perl5 readline
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libicui18n.so:devel/icu \
+ libmsgpuck.so:devel/msgpuck \
+ libyaml.so:textproc/libyaml \
+ libzstd.so:archivers/zstd
+
+CMAKE_ARGS= -DCMAKE_INSTALL_FULL_SYSCONFDIR=${ETCDIR} \
+ -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
+ -DCMAKE_INSTALL_MANDIR=${PREFIX}/man
+CMAKE_OFF= ENABLE_BUNDLED_LIBYAML ENABLE_BUNDLED_MSGPUCK ENABLE_BUNDLED_ZSTD
+CMAKE_ON= ENABLE_DIST
+MAKE_JOBS_UNSAFE= yes
+USES= cmake:noninja compiler:c++11-lang gettext-runtime gmake perl5 readline ssl
+USE_PERL5= build
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
+
+PLIST_SUB= TT_DATADIR=${TT_DATADIR} \
+ TT_LOGDIR=${TT_LOGDIR}
SUB_FILES= pkg-message
-TT_DATADIR?= /var/db/tarantool
-TT_RUNDIR?= /var/run/tarantool
-TT_LOGDIR?= /var/log/tarantool
-
-CMAKE_ARGS= -DCMAKE_INSTALL_FULL_SYSCONFDIR=${ETCDIR} \
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var \
- -DCMAKE_INSTALL_MANDIR=${MANPREFIX}/man \
- -DENABLE_DIST=ON
+GH_TUPLE= rtsisyk:luafun:04c99f9:luafun/third_party/luafun \
+ tarantool:luajit:b8587fa:luajit/third_party/luajit \
+ tarantool:luarocks:6e6fe62:luarocks/third_party/luarocks \
+ tarantool:small:22d1bad:small/src/lib/small \
+ tarantool:test-run:ff5fb4f:test_run/test-run
+USE_GITHUB= yes
USERS= tarantool
GROUPS= tarantool
-SUB_LIST+= PORTNAME=${PORTNAME} \
- TT_USER=${USERS} \
- TT_DATADIR=${TT_DATADIR} \
- TT_LOGDIR=${TT_LOGDIR} \
- TT_RUNDIR=${TT_RUNDIR}
-
-PLIST_SUB+= TT_USER=${USERS} \
- TT_GROUP=${GROUPS} \
- TT_LOGDIR=${TT_LOGDIR} \
- TT_DATADIR=${TT_DATADIR} \
- TT_RUNDIR=${TT_RUNDIR}
+TT_DATADIR?= /var/db/tarantool
+TT_LOGDIR?= /var/log/tarantool
+TT_RUNDIR?= /var/run/tarantool
OPTIONS_DEFINE= DEBUG
-.include <bsd.port.options.mk>
+DEBUG_CMAKE_BOOL= ENABLE_BACKTRACE
+
+post-patch:
+ @${ECHO_CMD} ${PORTVERSION}-0 > ${WRKSRC}/VERSION
+ @${GREP} -lr 'msgpuck/msgpuck.h' ${WRKSRC}/ | ${XARGS} ${REINPLACE_CMD} -e 's|msgpuck/msgpuck.h|msgpuck.h|'
-.if ${PORT_OPTIONS:MDEBUG}
-CMAKE_BUILD_TYPE= RelWithDebugInfo
-CMAKE_ARGS+= -DENABLE_BACKTRACE=ON
-.else
-CMAKE_BUILD_TYPE= Rel
-CMAKE_ARGS+= -DENABLE_BACKTRACE=OFF
-.endif
+post-install:
+ @${RMDIR} ${STAGEDIR}${PREFIX}/lib/tarantool/
.include <bsd.port.mk>
diff --git a/databases/tarantool/distinfo b/databases/tarantool/distinfo
index d96e202c0086..72a34c971419 100644
--- a/databases/tarantool/distinfo
+++ b/databases/tarantool/distinfo
@@ -1,3 +1,13 @@
-TIMESTAMP = 1499692037
-SHA256 (tarantool-1.7.4.260.tar.gz) = d7247d1ba3589068187f6f18f1630da29892fd0a73e68ce52a3e4d44752a9af0
-SIZE (tarantool-1.7.4.260.tar.gz) = 6423923
+TIMESTAMP = 1519670258
+SHA256 (tarantool-tarantool-1.9.0_GH0.tar.gz) = 7f9942d9e8d7a5132cf233263039e229d5046ca3a15e44fad233bc93caa2d725
+SIZE (tarantool-tarantool-1.9.0_GH0.tar.gz) = 2356661
+SHA256 (rtsisyk-luafun-04c99f9_GH0.tar.gz) = 4f135f25a2d31116723162ec8ad54f7d4e0e1258557bb1665557532ac64dc625
+SIZE (rtsisyk-luafun-04c99f9_GH0.tar.gz) = 67326
+SHA256 (tarantool-luajit-b8587fa_GH0.tar.gz) = 620a023a5ee6a52fc5f9fb3ece568b5ff58246a807c9ba4e31a8157451e9cff2
+SIZE (tarantool-luajit-b8587fa_GH0.tar.gz) = 1027765
+SHA256 (tarantool-luarocks-6e6fe62_GH0.tar.gz) = 69091525588e4b1f19341aecd1628eaace7919eed57c7177bb8ffdba9bf27c56
+SIZE (tarantool-luarocks-6e6fe62_GH0.tar.gz) = 4027514
+SHA256 (tarantool-small-22d1bad_GH0.tar.gz) = 760e2e25e0688915f4902921c070f8c5ddba0ad85f86204c2bbc35ad9b0544eb
+SIZE (tarantool-small-22d1bad_GH0.tar.gz) = 108894
+SHA256 (tarantool-test-run-ff5fb4f_GH0.tar.gz) = 78f8ac985b07138a9a35b05240cdb33a8f99948b81c1e44d0459923e87c42202
+SIZE (tarantool-test-run-ff5fb4f_GH0.tar.gz) = 55148
diff --git a/databases/tarantool/files/pkg-message.in b/databases/tarantool/files/pkg-message.in
index 724e169d99dc..fbbe7f26f2f1 100644
--- a/databases/tarantool/files/pkg-message.in
+++ b/databases/tarantool/files/pkg-message.in
@@ -1,14 +1,12 @@
-#########################################################
-#
-#
-# After install you'll need:
-#
-# Configuration at /etc/rc.conf:
-#
-# * Enable tarantool on startup:
-# tarantool_enable="YES"
-# * Path to storage link files of instances:
-# tarantool_instances="%%ETCDIR%%/instances.enabled"
-#
-#
-#########################################################
+========================================================================
+
+ After install, you'll need:
+
+ Configuration at /etc/rc.conf:
+
+ * Enable tarantool on startup:
+ tarantool_enable="yes"
+ * Path to storage link files of instances:
+ tarantool_instances="%%ETCDIR%%/instances.enabled"
+
+========================================================================
diff --git a/databases/tarantool/pkg-descr b/databases/tarantool/pkg-descr
index e183e661eee6..48e70528ed29 100644
--- a/databases/tarantool/pkg-descr
+++ b/databases/tarantool/pkg-descr
@@ -1,19 +1,18 @@
-Tarantool is an efficient NoSQL database and a Lua application server.
+Tarantool is an in-memory database and application server.
-Key features of the Lua application server:
-* 100% compatible drop-in replacement for Lua 5.1, based on LuaJIT 2.0.
-Simply use #!/usr/bin/tarantool instead of #!/usr/bin/lua in your script.
-* full support for Lua modules and a rich set of own modules, including
-cooperative multitasking, non-blocking I/O, access to external databases,
-etc.
+Key features of the application server:
+- 100% compatible drop-in replacement for Lua 5.1, based on LuaJIT 2.1. Simply
+ use #!/usr/bin/tarantool instead of #!/usr/bin/lua in your script.
+- full support for Lua modules and a rich set of own modules, including
+ cooperative multitasking, non-blocking I/O, access to external databases, etc
Key features of the database:
-* MsgPack data format and MsgPack based client-server protocol
-* two data engines: 100% in-memory with optional persistence and a 2-level
-disk-based B-tree, to use with large data sets
-* multiple index types: HASH, TREE, BITSET
-* asynchronous master-master replication
-* authentication and access control
-* the database is just a C extension to the app server and can be turned off
+- MsgPack data format and MsgPack based client-server protocol
+- two data engines: 100% in-memory with optional persistence and a 2-level
+ disk-based B-tree, to use with large data sets
+- multiple index types: HASH, TREE, RTREE, BITSET
+- asynchronous master-master replication
+- authentication and access control
+- the database is just a C extension to the app server and can be turned off
-WWW: http://tarantool.org/
+WWW: https://tarantool.org/
diff --git a/databases/tarantool/pkg-plist b/databases/tarantool/pkg-plist
index a5c5c402fa18..928c6d90b229 100644
--- a/databases/tarantool/pkg-plist
+++ b/databases/tarantool/pkg-plist
@@ -1,7 +1,7 @@
bin/tarantool
bin/tarantoolctl
-%%ETCDIR%%/default/tarantool
-%%ETCDIR%%/instances.available/example.lua
+etc/tarantool/default/tarantool
+etc/tarantool/instances.available/example.lua
include/tarantool/lauxlib.h
include/tarantool/lua.h
include/tarantool/lua.hpp
@@ -11,8 +11,74 @@ include/tarantool/lualib.h
include/tarantool/module.h
man/man1/tarantool.1.gz
man/man1/tarantoolctl.1.gz
-@dir %%DATADIR%%
-@dir %%ETCDIR%%/instances.available
-@dir lib/tarantool
-@dir(%%TT_USER%%,%%TT_GROUP%%,) %%TT_DATADIR%%
-@dir(%%TT_USER%%,%%TT_GROUP%%,) %%TT_LOGDIR%%
+%%DATADIR%%/luarocks/add.lua
+%%DATADIR%%/luarocks/admin_remove.lua
+%%DATADIR%%/luarocks/build.lua
+%%DATADIR%%/luarocks/build/builtin.lua
+%%DATADIR%%/luarocks/build/cmake.lua
+%%DATADIR%%/luarocks/build/command.lua
+%%DATADIR%%/luarocks/build/make.lua
+%%DATADIR%%/luarocks/cache.lua
+%%DATADIR%%/luarocks/cfg.lua
+%%DATADIR%%/luarocks/command_line.lua
+%%DATADIR%%/luarocks/config_cmd.lua
+%%DATADIR%%/luarocks/deps.lua
+%%DATADIR%%/luarocks/dir.lua
+%%DATADIR%%/luarocks/doc.lua
+%%DATADIR%%/luarocks/download.lua
+%%DATADIR%%/luarocks/fetch.lua
+%%DATADIR%%/luarocks/fetch/cvs.lua
+%%DATADIR%%/luarocks/fetch/git.lua
+%%DATADIR%%/luarocks/fetch/git_file.lua
+%%DATADIR%%/luarocks/fetch/git_http.lua
+%%DATADIR%%/luarocks/fetch/git_https.lua
+%%DATADIR%%/luarocks/fetch/git_ssh.lua
+%%DATADIR%%/luarocks/fetch/hg.lua
+%%DATADIR%%/luarocks/fetch/hg_http.lua
+%%DATADIR%%/luarocks/fetch/hg_https.lua
+%%DATADIR%%/luarocks/fetch/hg_ssh.lua
+%%DATADIR%%/luarocks/fetch/sscm.lua
+%%DATADIR%%/luarocks/fetch/svn.lua
+%%DATADIR%%/luarocks/fs.lua
+%%DATADIR%%/luarocks/fs/lua.lua
+%%DATADIR%%/luarocks/fs/tools.lua
+%%DATADIR%%/luarocks/fs/unix.lua
+%%DATADIR%%/luarocks/fs/unix/tools.lua
+%%DATADIR%%/luarocks/fs/win32.lua
+%%DATADIR%%/luarocks/fs/win32/tools.lua
+%%DATADIR%%/luarocks/help.lua
+%%DATADIR%%/luarocks/index.lua
+%%DATADIR%%/luarocks/install.lua
+%%DATADIR%%/luarocks/lint.lua
+%%DATADIR%%/luarocks/list.lua
+%%DATADIR%%/luarocks/loader.lua
+%%DATADIR%%/luarocks/make.lua
+%%DATADIR%%/luarocks/make_manifest.lua
+%%DATADIR%%/luarocks/manif.lua
+%%DATADIR%%/luarocks/manif_core.lua
+%%DATADIR%%/luarocks/new_version.lua
+%%DATADIR%%/luarocks/pack.lua
+%%DATADIR%%/luarocks/path.lua
+%%DATADIR%%/luarocks/path_cmd.lua
+%%DATADIR%%/luarocks/persist.lua
+%%DATADIR%%/luarocks/purge.lua
+%%DATADIR%%/luarocks/refresh_cache.lua
+%%DATADIR%%/luarocks/remove.lua
+%%DATADIR%%/luarocks/repos.lua
+%%DATADIR%%/luarocks/require.lua
+%%DATADIR%%/luarocks/search.lua
+%%DATADIR%%/luarocks/show.lua
+%%DATADIR%%/luarocks/site_config.lua
+%%DATADIR%%/luarocks/tools/patch.lua
+%%DATADIR%%/luarocks/tools/tar.lua
+%%DATADIR%%/luarocks/tools/zip.lua
+%%DATADIR%%/luarocks/type_check.lua
+%%DATADIR%%/luarocks/unpack.lua
+%%DATADIR%%/luarocks/upload.lua
+%%DATADIR%%/luarocks/upload/api.lua
+%%DATADIR%%/luarocks/upload/multipart.lua
+%%DATADIR%%/luarocks/util.lua
+%%DATADIR%%/luarocks/validate.lua
+%%DATADIR%%/luarocks/write_rockspec.lua
+@dir(tarantool,tarantool,) %%TT_DATADIR%%
+@dir(tarantool,tarantool,) %%TT_LOGDIR%%