aboutsummaryrefslogtreecommitdiff
path: root/databases/tcl-lmdb
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-04-13 10:49:44 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-04-13 10:49:44 +0000
commit3a6f80ddb3abe15c2fa450b94404965f6f45e82c (patch)
tree3676f12a4dfe0349c326cbea675c6b3cbaa492c5 /databases/tcl-lmdb
parentdc061bccb0899d6d7dbe83da4ed6da8ed978b3dd (diff)
downloadports-3a6f80ddb3abe15c2fa450b94404965f6f45e82c.tar.gz
ports-3a6f80ddb3abe15c2fa450b94404965f6f45e82c.zip
databases/tcl-lmdb: new port
This is the Lightning Memory-Mapped Database (LMDB) extension for Tcl using the Tcl Extension Architecture (TEA). WWW: https://sites.google.com/site/ray2501/tcl-lmdb
Notes
Notes: svn path=/head/; revision=413199
Diffstat (limited to 'databases/tcl-lmdb')
-rw-r--r--databases/tcl-lmdb/Makefile36
-rw-r--r--databases/tcl-lmdb/distinfo2
-rw-r--r--databases/tcl-lmdb/pkg-descr4
3 files changed, 42 insertions, 0 deletions
diff --git a/databases/tcl-lmdb/Makefile b/databases/tcl-lmdb/Makefile
new file mode 100644
index 000000000000..a96d50f52ea2
--- /dev/null
+++ b/databases/tcl-lmdb/Makefile
@@ -0,0 +1,36 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= tcl-lmdb
+PORTVERSION= 0.3.3
+CATEGORIES= databases
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Tcl interface to the Lightning Memory-Mapped Database
+
+LICENSE= BSD2CLAUSE
+
+LIB_DEPENDS= liblmdb.so:databases/lmdb
+
+USE_GITHUB= yes
+GH_ACCOUNT= ray2501
+
+USES= gmake tcl
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} --with-system-lmdb
+CONFIGURE_ENV+= CPPFLAGS="${CFLAGS}"
+
+TEST_TARGET= test
+
+TCLPKG= lmdb${PORTVERSION}
+PLIST_FILES= lib/${TCLPKG}/lib${TCLPKG}.so \
+ lib/${TCLPKG}/pkgIndex.tcl \
+ man/mann/lmdb.n.gz
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${TCLPKG}/lib${TCLPKG}.so
+
+.include <bsd.port.mk>
+
diff --git a/databases/tcl-lmdb/distinfo b/databases/tcl-lmdb/distinfo
new file mode 100644
index 000000000000..f4e86519c5a6
--- /dev/null
+++ b/databases/tcl-lmdb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ray2501-tcl-lmdb-0.3.3_GH0.tar.gz) = 5ac1af45303a3af7d820b30c8af95146a9732d09b32277085b04ca097aa32c3d
+SIZE (ray2501-tcl-lmdb-0.3.3_GH0.tar.gz) = 276080
diff --git a/databases/tcl-lmdb/pkg-descr b/databases/tcl-lmdb/pkg-descr
new file mode 100644
index 000000000000..85f2235e2d8b
--- /dev/null
+++ b/databases/tcl-lmdb/pkg-descr
@@ -0,0 +1,4 @@
+This is the Lightning Memory-Mapped Database (LMDB) extension for Tcl using the
+Tcl Extension Architecture (TEA).
+
+WWW: https://sites.google.com/site/ray2501/tcl-lmdb