aboutsummaryrefslogtreecommitdiff
path: root/databases/tdb
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2015-11-30 00:17:41 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2015-11-30 00:17:41 +0000
commit2885f1117af2a138c3412ea9cb6af14fbb10f07a (patch)
treeb403b5721493dc1a148d7671ab9a4c7be26be74c /databases/tdb
parent82cfb486dcace15703c07118ce15de0df97de7c6 (diff)
downloadports-2885f1117af2a138c3412ea9cb6af14fbb10f07a.tar.gz
ports-2885f1117af2a138c3412ea9cb6af14fbb10f07a.zip
Update Samba supplimentary libs
Notes
Notes: svn path=/head/; revision=402636
Diffstat (limited to 'databases/tdb')
-rw-r--r--databases/tdb/Makefile4
-rw-r--r--databases/tdb/distinfo4
-rw-r--r--databases/tdb/files/patch-lib_replace_replace.c68
3 files changed, 4 insertions, 72 deletions
diff --git a/databases/tdb/Makefile b/databases/tdb/Makefile
index a919973e9fdc..3c071cdd1d3f 100644
--- a/databases/tdb/Makefile
+++ b/databases/tdb/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= tdb
-PORTVERSION= 1.3.7
-PORTREVISION= 1
+PORTVERSION= 1.3.8
+PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= SAMBA
diff --git a/databases/tdb/distinfo b/databases/tdb/distinfo
index 64b451776514..7914af7638f6 100644
--- a/databases/tdb/distinfo
+++ b/databases/tdb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tdb-1.3.7.tar.gz) = a64d95ca0cc06a28fed24c6e952aed7660cae04983108735d6bc30b925136412
-SIZE (tdb-1.3.7.tar.gz) = 493847
+SHA256 (tdb-1.3.8.tar.gz) = 0605ac0427eac9c23bf61ebfd8206a07d5ece198498eab1769cd0cfb6e7de6b1
+SIZE (tdb-1.3.8.tar.gz) = 494106
diff --git a/databases/tdb/files/patch-lib_replace_replace.c b/databases/tdb/files/patch-lib_replace_replace.c
deleted file mode 100644
index ec08fd5e8169..000000000000
--- a/databases/tdb/files/patch-lib_replace_replace.c
+++ /dev/null
@@ -1,68 +0,0 @@
-From 035dd6447a06409c2df5ed559218f52479621abd Mon Sep 17 00:00:00 2001
-From: Volker Lendecke <vl@samba.org>
-Date: Tue, 18 Aug 2015 20:57:27 +0200
-Subject: [PATCH] replace: Fix bug 11455
-
-Don't call rep_strtoull recursively
-
-Signed-off-by: Volker Lendecke <vl@samba.org>
-Bug: https://bugzilla.samba.org/show_bug.cgi?id=11455
-
-https://lists.samba.org/archive/samba-technical/2015-July/108587.html
-https://lists.samba.org/archive/samba-technical/2015-July/108588.html
-
---- ./lib/replace/replace.c.orig 2015-09-18 23:51:08 UTC
-+++ ./lib/replace/replace.c 2015-09-18 23:51:08 UTC
-@@ -518,8 +518,10 @@
- }
- #else
- #ifdef HAVE_BSD_STRTOLL
-+#undef strtoll
- long long int rep_strtoll(const char *str, char **endptr, int base)
- {
-+ int errno0 = errno;
- long long int nb = strtoll(str, endptr, base);
- /* With glibc EINVAL is only returned if base is not ok */
- if (errno == EINVAL) {
-@@ -528,7 +530,7 @@
- * able to make the convertion.
- * Let's reset errno.
- */
-- errno = 0;
-+ errno = errno0;
- }
- }
- return nb;
-@@ -551,26 +553,24 @@
- #endif
- }
- #else
--#ifdef HAVE_BSD_STRTOLL
--#ifdef HAVE_STRTOUQ
-+#ifdef HAVE_BSD_STRTOLL /* yes, it's not HAVE_BSD_STRTOULL */
-+#undef strtoull
- unsigned long long int rep_strtoull(const char *str, char **endptr, int base)
- {
-- unsigned long long int nb = strtouq(str, endptr, base);
-- /* In linux EINVAL is only returned if base is not ok */
-+ int errno0 = errno;
-+ unsigned long long int nb = strtoull(str, endptr, base);
-+ /* With glibc EINVAL is only returned if base is not ok */
- if (errno == EINVAL) {
- if (base == 0 || (base >1 && base <37)) {
- /* Base was ok so it's because we were not
- * able to make the convertion.
- * Let's reset errno.
- */
-- errno = 0;
-+ errno = errno0;
- }
- }
- return nb;
- }
--#else
--#error "You need the strtouq function"
--#endif /* HAVE_STRTOUQ */
- #endif /* HAVE_BSD_STRTOLL */
- #endif /* HAVE_STRTOULL */
-