aboutsummaryrefslogtreecommitdiff
path: root/databases/tdb
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2010-10-26 13:07:59 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2010-10-26 13:07:59 +0000
commiteed9126195ac95409e796f8c4e6b7f33e6077dc7 (patch)
treeb9f73aba2817e38e63f3b9ff2f957077c47509d1 /databases/tdb
parent20ee097976d7eb64320f25e75a74c6321a1d0ef8 (diff)
downloadports-eed9126195ac95409e796f8c4e6b7f33e6077dc7.tar.gz
ports-eed9126195ac95409e796f8c4e6b7f33e6077dc7.zip
Bumped port version to the 1.2.2. Fixed installation of the manpages.
Notes
Notes: svn path=/head/; revision=263615
Diffstat (limited to 'databases/tdb')
-rw-r--r--databases/tdb/Makefile17
-rw-r--r--databases/tdb/distinfo6
-rw-r--r--databases/tdb/files/tdbbackup.8115
-rw-r--r--databases/tdb/files/tdbdump.843
-rw-r--r--databases/tdb/files/tdbtool.8150
5 files changed, 325 insertions, 6 deletions
diff --git a/databases/tdb/Makefile b/databases/tdb/Makefile
index 4b7dabc29735..f8c2d1cad205 100644
--- a/databases/tdb/Makefile
+++ b/databases/tdb/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tdb
-PORTVERSION= 1.2.1
+PORTVERSION= 1.2.2
PORTREVISION= 0
CATEGORIES= databases
MASTER_SITES= ftp://ftp.samba.org/pub/%SUBDIR%/ \
@@ -17,7 +17,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= timur@FreeBSD.org
COMMENT= Trivial Database
-CONFLICTS= *samba-3.*
+CONFLICTS= *samba3[0-4]*
USE_PYTHON= yes
USE_GMAKE= yes
@@ -26,7 +26,7 @@ GNU_CONFIGURE= yes
USE_GNOME= pkgconfig
USE_AUTOTOOLS= autoconf:268 autoheader:268
-IPATHS= -I${WRKSRC}/libreplace
+IPATHS= -I${WRKSRC}/lib/replace
AUTOHEADER_ARGS= ${IPATHS}
AUTOCONF_ARGS= ${IPATHS}
@@ -34,6 +34,12 @@ PKGCONFIGDIR?= ${PREFIX}/libdata/pkgconfig
PKGCONFIGDIR_REL?= ${PKGCONFIGDIR:S|^${PREFIX}/||}
PYTHON_SITELIBDIR_REL?= ${PYTHONPREFIX_SITELIBDIR:S|^${PREFIX}/||}
+CONFIGURE_ENV+= XSLTPROC="/usr/bin/true"
+
+MAN8= tdbbackup.8 \
+ tdbdump.8 \
+ tdbtool.8
+
PLIST_FILES= bin/tdbbackup \
bin/tdbdump \
bin/tdbtool \
@@ -44,6 +50,11 @@ PLIST_FILES= bin/tdbbackup \
${PKGCONFIGDIR_REL}/tdb.pc \
${PYTHON_SITELIBDIR_REL}/tdb.so
+pre-install:
+.for man in ${MAN8}
+ @${CP} ${FILESDIR}/${man} ${WRKSRC}/manpages
+.endfor
+
post-install:
@${LN} -sf libtdb.so.1 ${PREFIX}/lib/libtdb.so
diff --git a/databases/tdb/distinfo b/databases/tdb/distinfo
index 6ea486958c8f..6a8d397215d8 100644
--- a/databases/tdb/distinfo
+++ b/databases/tdb/distinfo
@@ -1,3 +1,3 @@
-MD5 (tdb-1.2.1.tar.gz) = 73ea81282a82e5c959d9c082af2d0215
-SHA256 (tdb-1.2.1.tar.gz) = ef423b934c5ddfeddaa3d3b1567072b0d6f7243bbae5fd363a1b090b0573cdfa
-SIZE (tdb-1.2.1.tar.gz) = 268142
+MD5 (tdb-1.2.2.tar.gz) = d93f31e1585971f12cbd259323c54432
+SHA256 (tdb-1.2.2.tar.gz) = faee3dbb5c0af896c98f5edf3ab68b2ed9bc4992376666f2cd502873a1b2f892
+SIZE (tdb-1.2.2.tar.gz) = 372672
diff --git a/databases/tdb/files/tdbbackup.8 b/databases/tdb/files/tdbbackup.8
new file mode 100644
index 000000000000..fc554c80de1d
--- /dev/null
+++ b/databases/tdb/files/tdbbackup.8
@@ -0,0 +1,115 @@
+'\" t
+.\" Title: tdbbackup
+.\" Author: [see the "AUTHOR" section]
+.\" Generator: DocBook XSL Stylesheets v1.75.2 <http://docbook.sf.net/>
+.\" Date: 10/26/2010
+.\" Manual: System Administration tools
+.\" Source: Samba 3.6
+.\" Language: English
+.\"
+.TH "TDBBACKUP" "8" "10/26/2010" "Samba 3\&.6" "System Administration tools"
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+tdbbackup \- tool for backing up and for validating the integrity of samba \&.tdb files
+.SH "SYNOPSIS"
+.HP \w'\fBtdbbackup\fR\ 'u
+\fBtdbbackup\fR [\-s\ suffix] [\-v] [\-h]
+.SH "DESCRIPTION"
+.PP
+This tool is part of the
+\fBsamba\fR(1)
+suite\&.
+.PP
+\fBtdbbackup\fR
+is a tool that may be used to backup samba \&.tdb files\&. This tool may also be used to verify the integrity of the \&.tdb files prior to samba startup or during normal operation\&. If it finds file damage and it finds a prior backup the backup file will be restored\&.
+.SH "OPTIONS"
+.PP
+\-h
+.RS 4
+Get help information\&.
+.RE
+.PP
+\-s suffix
+.RS 4
+The
+\fB\-s\fR
+option allows the adminisistrator to specify a file backup extension\&. This way it is possible to keep a history of tdb backup files by using a new suffix for each backup\&.
+.RE
+.PP
+\-v
+.RS 4
+The
+\fB\-v\fR
+will check the database for damages (currupt data) which if detected causes the backup to be restored\&.
+.RE
+.SH "COMMANDS"
+.PP
+\fIGENERAL INFORMATION\fR
+.PP
+The
+\fBtdbbackup\fR
+utility can safely be run at any time\&. It was designed so that it can be used at any time to validate the integrity of tdb files, even during Samba operation\&. Typical usage for the command will be:
+.PP
+tdbbackup [\-s suffix] *\&.tdb
+.PP
+Before restarting samba the following command may be run to validate \&.tdb files:
+.PP
+tdbbackup \-v [\-s suffix] *\&.tdb
+.PP
+Samba \&.tdb files are stored in various locations, be sure to run backup all \&.tdb file on the system\&. Important files includes:
+.sp
+.RS 4
+.ie n \{\
+\h'-04'\(bu\h'+03'\c
+.\}
+.el \{\
+.sp -1
+.IP \(bu 2.3
+.\}
+
+\fBsecrets\&.tdb\fR
+\- usual location is in the /usr/local/samba/private directory, or on some systems in /etc/samba\&.
+.RE
+.sp
+.RS 4
+.ie n \{\
+\h'-04'\(bu\h'+03'\c
+.\}
+.el \{\
+.sp -1
+.IP \(bu 2.3
+.\}
+
+\fBpassdb\&.tdb\fR
+\- usual location is in the /usr/local/samba/private directory, or on some systems in /etc/samba\&.
+.RE
+.sp
+.RS 4
+.ie n \{\
+\h'-04'\(bu\h'+03'\c
+.\}
+.el \{\
+.sp -1
+.IP \(bu 2.3
+.\}
+
+\fB*\&.tdb\fR
+located in the /usr/local/samba/var directory or on some systems in the /var/cache or /var/lib/samba directories\&.
+.RE
+.SH "VERSION"
+.PP
+This man page is correct for version 3 of the Samba suite\&.
+.SH "AUTHOR"
+.PP
+The original Samba software and related utilities were created by Andrew Tridgell\&. Samba is now developed by the Samba Team as an Open Source project similar to the way the Linux kernel is developed\&.
+.PP
+The tdbbackup man page was written by John H Terpstra\&.
diff --git a/databases/tdb/files/tdbdump.8 b/databases/tdb/files/tdbdump.8
new file mode 100644
index 000000000000..59c11edb5308
--- /dev/null
+++ b/databases/tdb/files/tdbdump.8
@@ -0,0 +1,43 @@
+'\" t
+.\" Title: tdbdump
+.\" Author: [see the "AUTHOR" section]
+.\" Generator: DocBook XSL Stylesheets v1.75.2 <http://docbook.sf.net/>
+.\" Date: 10/26/2010
+.\" Manual: System Administration tools
+.\" Source: Samba 3.6
+.\" Language: English
+.\"
+.TH "TDBDUMP" "8" "10/26/2010" "Samba 3\&.6" "System Administration tools"
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+tdbdump \- tool for printing the contents of a TDB file
+.SH "SYNOPSIS"
+.HP \w'\fBtdbdump\fR\ 'u
+\fBtdbdump\fR {filename}
+.SH "DESCRIPTION"
+.PP
+This tool is part of the
+\fBsamba\fR(1)
+suite\&.
+.PP
+\fBtdbdump\fR
+is a very simple utility that \'dumps\' the contents of a TDB (Trivial DataBase) file to standard output in a human\-readable format\&.
+.PP
+This tool can be used when debugging problems with TDB files\&. It is intended for those who are somewhat familiar with Samba internals\&.
+.SH "VERSION"
+.PP
+This man page is correct for version 3 of the Samba suite\&.
+.SH "AUTHOR"
+.PP
+The original Samba software and related utilities were created by Andrew Tridgell\&. Samba is now developed by the Samba Team as an Open Source project similar to the way the Linux kernel is developed\&.
+.PP
+The tdbdump man page was written by Jelmer Vernooij\&.
diff --git a/databases/tdb/files/tdbtool.8 b/databases/tdb/files/tdbtool.8
new file mode 100644
index 000000000000..91944321a5ca
--- /dev/null
+++ b/databases/tdb/files/tdbtool.8
@@ -0,0 +1,150 @@
+'\" t
+.\" Title: tdbtool
+.\" Author: [see the "AUTHOR" section]
+.\" Generator: DocBook XSL Stylesheets v1.75.2 <http://docbook.sf.net/>
+.\" Date: 10/26/2010
+.\" Manual: System Administration tools
+.\" Source: Samba 3.6
+.\" Language: English
+.\"
+.TH "TDBTOOL" "8" "10/26/2010" "Samba 3\&.6" "System Administration tools"
+.\" -----------------------------------------------------------------
+.\" * set default formatting
+.\" -----------------------------------------------------------------
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.\" -----------------------------------------------------------------
+.\" * MAIN CONTENT STARTS HERE *
+.\" -----------------------------------------------------------------
+.SH "NAME"
+tdbtool \- manipulate the contents TDB files
+.SH "SYNOPSIS"
+.HP \w'\fBtdbtool\fR\ 'u
+\fBtdbtool\fR
+.HP \w'\fBtdbtool\fR\ 'u
+\fBtdbtool\fR \fITDBFILE\fR [\fICOMMANDS\fR...]
+.SH "DESCRIPTION"
+.PP
+This tool is part of the
+\fBsamba\fR(1)
+suite\&.
+.PP
+\fBtdbtool\fR
+a tool for displaying and altering the contents of Samba TDB (Trivial DataBase) files\&. Each of the commands listed below can be entered interactively or provided on the command line\&.
+.SH "COMMANDS"
+.PP
+\fBcreate\fR \fITDBFILE\fR
+.RS 4
+Create a new database named
+\fITDBFILE\fR\&.
+.RE
+.PP
+\fBopen\fR \fITDBFILE\fR
+.RS 4
+Open an existing database named
+\fITDBFILE\fR\&.
+.RE
+.PP
+\fBerase\fR
+.RS 4
+Erase the current database\&.
+.RE
+.PP
+\fBdump\fR
+.RS 4
+Dump the current database as strings\&.
+.RE
+.PP
+\fBcdump\fR
+.RS 4
+Dump the current database as connection records\&.
+.RE
+.PP
+\fBkeys\fR
+.RS 4
+Dump the current database keys as strings\&.
+.RE
+.PP
+\fBhexkeys\fR
+.RS 4
+Dump the current database keys as hex values\&.
+.RE
+.PP
+\fBinfo\fR
+.RS 4
+Print summary information about the current database\&.
+.RE
+.PP
+\fBinsert\fR \fIKEY\fR \fIDATA\fR
+.RS 4
+Insert a record into the current database\&.
+.RE
+.PP
+\fBmove\fR \fIKEY\fR \fITDBFILE\fR
+.RS 4
+Move a record from the current database into
+\fITDBFILE\fR\&.
+.RE
+.PP
+\fBstore\fR \fIKEY\fR \fIDATA\fR
+.RS 4
+Store (replace) a record in the current database\&.
+.RE
+.PP
+\fBshow\fR \fIKEY\fR
+.RS 4
+Show a record by key\&.
+.RE
+.PP
+\fBdelete\fR \fIKEY\fR
+.RS 4
+Delete a record by key\&.
+.RE
+.PP
+\fBlist\fR
+.RS 4
+Print the current database hash table and free list\&.
+.RE
+.PP
+\fBfree\fR
+.RS 4
+Print the current database and free list\&.
+.RE
+.PP
+\fB!\fR \fICOMMAND\fR
+.RS 4
+Execute the given system command\&.
+.RE
+.PP
+\fBfirst\fR
+.RS 4
+Print the first record in the current database\&.
+.RE
+.PP
+\fBnext\fR
+.RS 4
+Print the next record in the current database\&.
+.RE
+.PP
+\fBcheck\fR
+.RS 4
+Check the integrity of the current database\&.
+.RE
+.PP
+\fBquit\fR
+.RS 4
+Exit
+\fBtdbtool\fR\&.
+.RE
+.SH "CAVEATS"
+.PP
+The contents of the Samba TDB files are private to the implementation and should not be altered with
+\fBtdbtool\fR\&.
+.SH "VERSION"
+.PP
+This man page is correct for version 3\&.0\&.25 of the Samba suite\&.
+.SH "AUTHOR"
+.PP
+The original Samba software and related utilities were created by Andrew Tridgell\&. Samba is now developed by the Samba Team as an Open Source project similar to the way the Linux kernel is developed\&.