aboutsummaryrefslogtreecommitdiff
path: root/databases/tokyotyrant
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-06 20:43:32 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-06 20:43:32 +0000
commit7c54a9e2256a230e815e5e20533011095fbbb063 (patch)
tree42131ce67f3841a4c655736e086ef0f207c0ef61 /databases/tokyotyrant
parentb761bbdfb8ebbdf94bb836b40e1c67ba047df65e (diff)
downloadports-7c54a9e2256a230e815e5e20533011095fbbb063.tar.gz
ports-7c54a9e2256a230e815e5e20533011095fbbb063.zip
Clean up Makefile
- Use USES=localbase - Use = instead of += for options helper - Silence patch message
Notes
Notes: svn path=/head/; revision=564251
Diffstat (limited to 'databases/tokyotyrant')
-rw-r--r--databases/tokyotyrant/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/databases/tokyotyrant/Makefile b/databases/tokyotyrant/Makefile
index 429a5786b54d..2e69aaac9ec5 100644
--- a/databases/tokyotyrant/Makefile
+++ b/databases/tokyotyrant/Makefile
@@ -5,7 +5,7 @@ PORTNAME= tokyotyrant
PORTVERSION= 1.1.41
PORTREVISION= 2
CATEGORIES= databases
-MASTER_SITES= https://dbmx.net/${PORTNAME}/
+MASTER_SITES= https://dbmx.net/tokyotyrant/
MAINTAINER= ports@FreeBSD.org
COMMENT= Network interface of Tokyo Cabinet
@@ -13,24 +13,21 @@ COMMENT= Network interface of Tokyo Cabinet
BUILD_DEPENDS= tokyocabinet>=1.4.20:databases/tokyocabinet
LIB_DEPENDS= libtokyocabinet.so:databases/tokyocabinet
+USES= gmake localbase pathfix
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= gmake pathfix
USE_RC_SUBR= ttserver
OPTIONS_DEFINE= LUA
+OPTIONS_DEFAULT=LUA # should be removed before committing
-LDFLAGS+= -L${LOCALBASE}/lib
-CFLAGS+= -I${LOCALBASE}/include
-
+LUA_CFLAGS= -I${LUA_INCDIR}
LUA_CONFIGURE_ENABLE= lua
-LUA_LDFLAGS+= -L${LUA_LIBDIR}
-LUA_CFLAGS+= -I${LUA_INCDIR}
-LUA_CPPFLAGS+= -I${LUA_INCDIR}
LUA_USES= lua
post-patch:
- ${REINPLACE_CMD} -e 's|llua|llua-${LUA_VER}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|llua|llua-${LUA_VER}|g' ${WRKSRC}/configure
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*