aboutsummaryrefslogtreecommitdiff
path: root/databases/twemproxy
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2014-05-12 17:55:07 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2014-05-12 17:55:07 +0000
commitd2391216d9f503c27c6cca3728ed540c51a50089 (patch)
tree766268da7f789b23db18908530cfc6ec9f65b01f /databases/twemproxy
parent732b8be525c98a52d2516a8840dac1886c283dc7 (diff)
downloadports-d2391216d9f503c27c6cca3728ed540c51a50089.tar.gz
ports-d2391216d9f503c27c6cca3728ed540c51a50089.zip
twemproxy, aka nutcracker is a fast and lightweight proxy for memcached and
redis protocol. It was primarily built to reduce the connection count on the backend caching serve WWW: https://github.com/twitter/twemproxy
Notes
Notes: svn path=/head/; revision=353882
Diffstat (limited to 'databases/twemproxy')
-rw-r--r--databases/twemproxy/Makefile26
-rw-r--r--databases/twemproxy/distinfo2
-rw-r--r--databases/twemproxy/pkg-descr5
3 files changed, 33 insertions, 0 deletions
diff --git a/databases/twemproxy/Makefile b/databases/twemproxy/Makefile
new file mode 100644
index 000000000000..3d2e30380295
--- /dev/null
+++ b/databases/twemproxy/Makefile
@@ -0,0 +1,26 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= twemproxy
+PORTVERSION= 0.3.0
+CATEGORIES= databases
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= nutcracker-${PORTVERSION}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Fast, light-weight proxy for memcached and redis
+
+LICENSE= APACHE20
+
+PLIST_FILES= sbin/nutcracker \
+ man/man8/nutcracker.8.gz \
+ etc/nutcracker.yml.sample
+
+HAS_CONFIGURE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/nutcracker ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/man/nutcracker.8 ${STAGEDIR}${MANPREFIX}/man/man8/
+ ${INSTALL_DATA} ${WRKSRC}/conf/nutcracker.yml ${STAGEDIR}${PREFIX}/etc/nutcracker.yml.sample
+
+.include <bsd.port.mk>
diff --git a/databases/twemproxy/distinfo b/databases/twemproxy/distinfo
new file mode 100644
index 000000000000..fc06cb0db6f6
--- /dev/null
+++ b/databases/twemproxy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nutcracker-0.3.0.tar.gz) = e9993d6827b2e93ee2b865e827acbf9efadbbfc81ccd9103a85948ee2580942a
+SIZE (nutcracker-0.3.0.tar.gz) = 1825106
diff --git a/databases/twemproxy/pkg-descr b/databases/twemproxy/pkg-descr
new file mode 100644
index 000000000000..4c309b9a78a9
--- /dev/null
+++ b/databases/twemproxy/pkg-descr
@@ -0,0 +1,5 @@
+twemproxy, aka nutcracker is a fast and lightweight proxy for memcached and
+redis protocol. It was primarily built to reduce the connection count on the
+backend caching serve
+
+WWW: https://github.com/twitter/twemproxy