aboutsummaryrefslogtreecommitdiff
path: root/databases/unixODBC
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-04-27 09:03:47 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-04-27 09:03:47 +0000
commitef028271f78d49cf2d9ead89b4358121a72c418b (patch)
tree257b908aaedd5bc1719a9bd199fe3aab3c97be4d /databases/unixODBC
parentc496b34b2a85ad2e3ac7c111d6f0f7b6184db67d (diff)
downloadports-ef028271f78d49cf2d9ead89b4358121a72c418b.tar.gz
ports-ef028271f78d49cf2d9ead89b4358121a72c418b.zip
databases/unixODBC: Update to 2.3.6
Notes
Notes: svn path=/head/; revision=468409
Diffstat (limited to 'databases/unixODBC')
-rw-r--r--databases/unixODBC/Makefile2
-rw-r--r--databases/unixODBC/distinfo6
-rw-r--r--databases/unixODBC/files/patch-exe_Makefile.am27
-rw-r--r--databases/unixODBC/files/patch-exe_Makefile.in29
-rw-r--r--databases/unixODBC/pkg-plist3
5 files changed, 63 insertions, 4 deletions
diff --git a/databases/unixODBC/Makefile b/databases/unixODBC/Makefile
index af9abdc9bac1..b7c2ddee9533 100644
--- a/databases/unixODBC/Makefile
+++ b/databases/unixODBC/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= unixODBC
-PORTVERSION= 2.3.5
+PORTVERSION= 2.3.6
CATEGORIES= databases
MASTER_SITES= ftp://ftp.unixodbc.org/pub/unixODBC/
diff --git a/databases/unixODBC/distinfo b/databases/unixODBC/distinfo
index 8fbf5f0e3373..18ee0f4a1d47 100644
--- a/databases/unixODBC/distinfo
+++ b/databases/unixODBC/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1518243635
-SHA256 (unixODBC-2.3.5.tar.gz) = 760972e05cc6361aee49d676fb7da8244e0f3a225cd4d3449a951378551b495b
-SIZE (unixODBC-2.3.5.tar.gz) = 1633390
+TIMESTAMP = 1524817314
+SHA256 (unixODBC-2.3.6.tar.gz) = 88b637f647c052ecc3861a3baa275c3b503b193b6a49ff8c28b2568656d14d69
+SIZE (unixODBC-2.3.6.tar.gz) = 1661914
diff --git a/databases/unixODBC/files/patch-exe_Makefile.am b/databases/unixODBC/files/patch-exe_Makefile.am
new file mode 100644
index 000000000000..70ab60080ea7
--- /dev/null
+++ b/databases/unixODBC/files/patch-exe_Makefile.am
@@ -0,0 +1,27 @@
+From 92b4c96de9addb7c194b31070fa18cd9f3dbed36 Mon Sep 17 00:00:00 2001
+From: lurcher <nick@lurcher.org>
+Date: Mon, 26 Mar 2018 10:45:26 +0100
+Subject: [PATCH] Fix sed problem
+
+---
+ exe/Makefile.am | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/exe/Makefile.am b/exe/Makefile.am
+index 61b7493..31a142e 100644
+--- exe/Makefile.am.orig
++++ exe/Makefile.am
+@@ -60,8 +60,10 @@ dltest_DEPENDENCIES = $(LTDLDEPS)
+ dltest_LDADD = $(LIBLTDL)
+
+ all-am:
+- @sed -i -e "s![@]ODBC_ULEN[@]!`$(CURDIR)/odbc_config$(EXEEXT) --ulen`!" \
+- -e "s![@]ODBC_CFLAGS[@]!`$(CURDIR)/odbc_config$(EXEEXT) --cflags | sed 's/ -I.*//'`!" \
+- $(top_builddir)/DriverManager/odbc.pc
+-
++ @sed "s![@]ODBC_ULEN[@]!`$(CURDIR)/odbc_config$(EXEEXT) --ulen`!" \
++ $(top_builddir)/DriverManager/odbc.pc > $(CURDIR)/odbc.pc.tmp
++ @mv $(CURDIR)/odbc.pc.tmp $(top_builddir)/DriverManager/odbc.pc
++ @sed "s![@]ODBC_CFLAGS[@]!`$(CURDIR)/odbc_config$(EXEEXT) --cflags | sed 's/ -I.*//'`!" \
++ $(top_builddir)/DriverManager/odbc.pc > $(CURDIR)/odbc.pc.tmp
++ @mv $(CURDIR)/odbc.pc.tmp $(top_builddir)/DriverManager/odbc.pc
diff --git a/databases/unixODBC/files/patch-exe_Makefile.in b/databases/unixODBC/files/patch-exe_Makefile.in
new file mode 100644
index 000000000000..0e9b8059954d
--- /dev/null
+++ b/databases/unixODBC/files/patch-exe_Makefile.in
@@ -0,0 +1,29 @@
+From 92b4c96de9addb7c194b31070fa18cd9f3dbed36 Mon Sep 17 00:00:00 2001
+From: lurcher <nick@lurcher.org>
+Date: Mon, 26 Mar 2018 10:45:26 +0100
+Subject: [PATCH] Fix sed problem
+
+---
+ exe/Makefile.am | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/exe/Makefile.am b/exe/Makefile.am
+index 61b7493..31a142e 100644
+--- exe/Makefile.in.orig 2018-03-19 11:18:18.000000000 +0100
++++ exe/Makefile.in 2018-04-27 10:38:57.114794000 +0200
+@@ -749,9 +758,12 @@ uninstall-am: uninstall-binPROGRAMS
+
+
+ all-am:
+- @sed -i -e "s![@]ODBC_ULEN[@]!`$(CURDIR)/odbc_config$(EXEEXT) --ulen`!" \
+- -e "s![@]ODBC_CFLAGS[@]!`$(CURDIR)/odbc_config$(EXEEXT) --cflags | sed 's/ -I.*//'`!" \
+- $(top_builddir)/DriverManager/odbc.pc
++ @sed "s![@]ODBC_ULEN[@]!`$(.CURDIR)/odbc_config$(EXEEXT) --ulen`!" \
++ $(top_builddir)/DriverManager/odbc.pc > $(.CURDIR)/odbc.pc.tmp
++ @mv $(.CURDIR)/odbc.pc.tmp $(top_builddir)/DriverManager/odbc.pc
++ @sed "s![@]ODBC_CFLAGS[@]!`$(.CURDIR)/odbc_config$(EXEEXT) --cflags | sed 's/ -I.*//'`!" \
++ $(top_builddir)/DriverManager/odbc.pc > $(.CURDIR)/odbc.pc.tmp
++ @mv $(.CURDIR)/odbc.pc.tmp $(top_builddir)/DriverManager/odbc.pc
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/databases/unixODBC/pkg-plist b/databases/unixODBC/pkg-plist
index 526d6e7480b1..10f1f8b0427f 100644
--- a/databases/unixODBC/pkg-plist
+++ b/databases/unixODBC/pkg-plist
@@ -32,6 +32,9 @@ lib/libodbcinst.la
lib/libodbcinst.so
lib/libodbcinst.so.2
lib/libodbcinst.so.2.0.0
+libdata/pkgconfig/odbc.pc
+libdata/pkgconfig/odbccr.pc
+libdata/pkgconfig/odbcinst.pc
man/man1/dltest.1.gz
man/man1/isql.1.gz
man/man1/iusql.1.gz