aboutsummaryrefslogtreecommitdiff
path: root/databases/vsqlite
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-29 20:37:27 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-29 20:37:27 +0000
commit5c4174835fc6edfc444e44c42ef9b3bca427ab31 (patch)
tree93c401f09d4dde0121849162f5ed36fc965b308b /databases/vsqlite
parent3654545f5fcae702cbaadb17af491eaefe34c438 (diff)
downloadports-5c4174835fc6edfc444e44c42ef9b3bca427ab31.tar.gz
ports-5c4174835fc6edfc444e44c42ef9b3bca427ab31.zip
Add vsqlite, a well designed and portable SQLite3 Wrapper for C++.
Notes
Notes: svn path=/head/; revision=338041
Diffstat (limited to 'databases/vsqlite')
-rw-r--r--databases/vsqlite/Makefile33
-rw-r--r--databases/vsqlite/distinfo2
-rw-r--r--databases/vsqlite/pkg-descr3
-rw-r--r--databases/vsqlite/pkg-plist15
4 files changed, 53 insertions, 0 deletions
diff --git a/databases/vsqlite/Makefile b/databases/vsqlite/Makefile
new file mode 100644
index 000000000000..98094542e452
--- /dev/null
+++ b/databases/vsqlite/Makefile
@@ -0,0 +1,33 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= vsqlite
+PORTVERSION= 0.3.12
+CATEGORIES= databases
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Well designed and portable SQLite3 Wrapper for C++
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libboost_random.so:${PORTSDIR}/devel/boost-libs
+
+USE_GITHUB= yes
+GH_ACCOUNT= vinzenz
+GH_PROJECT= vsqlite--
+GH_TAGNAME= 3fa8d32
+GH_COMMIT= 3fa8d32
+
+USE_AUTOTOOLS= libtool autoconf automake
+USE_SQLITE= 3
+USE_LDCONFIG= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+pre-configure:
+ @cd ${WRKSRC} && ${SH} autogen.sh
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libvsqlitepp.so.3
+
+.include <bsd.port.mk>
diff --git a/databases/vsqlite/distinfo b/databases/vsqlite/distinfo
new file mode 100644
index 000000000000..833a7067e918
--- /dev/null
+++ b/databases/vsqlite/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vsqlite-0.3.12.tar.gz) = 722d0a077c690e2e21e880602690c35b5c1eb2a491911ec44a28b92106ea8459
+SIZE (vsqlite-0.3.12.tar.gz) = 23733
diff --git a/databases/vsqlite/pkg-descr b/databases/vsqlite/pkg-descr
new file mode 100644
index 000000000000..e56db6237487
--- /dev/null
+++ b/databases/vsqlite/pkg-descr
@@ -0,0 +1,3 @@
+Well designed and portable SQLite3 Wrapper for C++
+
+WWW: https://github.com/vinzenz/vsqlite--
diff --git a/databases/vsqlite/pkg-plist b/databases/vsqlite/pkg-plist
new file mode 100644
index 000000000000..cb55edb0f13f
--- /dev/null
+++ b/databases/vsqlite/pkg-plist
@@ -0,0 +1,15 @@
+include/sqlite/command.hpp
+include/sqlite/connection.hpp
+include/sqlite/database_exception.hpp
+include/sqlite/execute.hpp
+include/sqlite/ext/variant.hpp
+include/sqlite/query.hpp
+include/sqlite/result.hpp
+include/sqlite/transaction.hpp
+include/sqlite/view.hpp
+lib/libvsqlitepp.a
+lib/libvsqlitepp.la
+lib/libvsqlitepp.so
+lib/libvsqlitepp.so.3
+@dirrmtry include/sqlite/ext
+@dirrmtry include/sqlite