aboutsummaryrefslogtreecommitdiff
path: root/databases/xtrabackup
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-06-19 12:41:54 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-06-19 12:41:54 +0000
commit824a60375f32776a102731c7e6c3f4177fa24827 (patch)
tree06f30ce895fec5946b2f5df9936d126f00d0162e /databases/xtrabackup
parent287c266f6b27c79f02b8ceea53be07c18fdae5b1 (diff)
downloadports-824a60375f32776a102731c7e6c3f4177fa24827.tar.gz
ports-824a60375f32776a102731c7e6c3f4177fa24827.zip
Add compiler:c++11-lang to USES to unbreak build on powerpc64:
ld: final link failed: Bad value While here, pacify portlint by also alpha sorting USES. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=504544
Diffstat (limited to 'databases/xtrabackup')
-rw-r--r--databases/xtrabackup/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/databases/xtrabackup/Makefile b/databases/xtrabackup/Makefile
index 8d673ec8275e..acec3bfff5dc 100644
--- a/databases/xtrabackup/Makefile
+++ b/databases/xtrabackup/Makefile
@@ -18,7 +18,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_armv6= fails to compile: cannot combine with previous 'type-name' declaration specifier
BROKEN_armv7= fails to compile: cannot combine with previous 'type-name' declaration specifier
BROKEN_mips64= fails to compile: 'fpsetmask' was not declared in this scope
-BROKEN_powerpc64= fails to link: ld: final link failed: Bad value
# quilt is required by build.sh
BUILD_DEPENDS= bash:shells/bash \
@@ -30,7 +29,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
RUN_DEPENDS= qpress:archivers/qpress
# autotool is in use for 5.1 builds
-USES= alias autoreconf:build bison cpe gettext cmake:noninja libtool perl5 shebangfix
+USES= alias autoreconf:build bison cmake:noninja compiler:c++11-lang \
+ cpe gettext libtool perl5 shebangfix
CPE_VENDOR= percona
SHEBANG_FILES= storage/innobase/xtrabackup/xbcloud_osenv.sh
CMAKE_ARGS= -DWITH_BOOST=${WRKDIR}/boost_1_59_0