aboutsummaryrefslogtreecommitdiff
path: root/databases/xtrabackup
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-18 07:30:24 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-18 07:30:24 +0000
commitc576f8b4cbe8bc3f8f5458df112689c37257ae41 (patch)
treed48d6597ea7c7db859311db9b35ca22726d16341 /databases/xtrabackup
parent196028163692b2de15d75a05eec9dcc201e2f126 (diff)
downloadports-c576f8b4cbe8bc3f8f5458df112689c37257ae41.tar.gz
ports-c576f8b4cbe8bc3f8f5458df112689c37257ae41.zip
- Make both cmake and autotools build dependencies only
- Merge MASTER_SITES and MASTER_SITE_SUBDIR
Notes
Notes: svn path=/head/; revision=368423
Diffstat (limited to 'databases/xtrabackup')
-rw-r--r--databases/xtrabackup/Makefile21
1 files changed, 4 insertions, 17 deletions
diff --git a/databases/xtrabackup/Makefile b/databases/xtrabackup/Makefile
index 73da5f81aede..7cb6154a0a21 100644
--- a/databases/xtrabackup/Makefile
+++ b/databases/xtrabackup/Makefile
@@ -5,7 +5,7 @@ PORTNAME= xtrabackup
PORTVERSION= 2.1.7
PORTREVISION= 1
CATEGORIES= databases
-MASTER_SITES= http://www.percona.com/downloads/%SUBDIR%/
+MASTER_SITES= http://www.percona.com/downloads/XtraBackup/XtraBackup-${PORTVERSION}/source/
DISTNAME= percona-${PORTNAME}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
DISTFILES= percona-xtrabackup-${PORTVERSION}.tar.gz
EXTRACT_ONLY= percona-xtrabackup-${PORTVERSION}.tar.gz
@@ -15,8 +15,9 @@ COMMENT= OpenSource version of InnoDB backup with support of Percona extensions
LICENSE= GPLv2
-# quilt is requiered by build.sh
+# quilt is required by build.sh
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ cmake:${PORTSDIR}/devel/cmake \
quilt:${PORTSDIR}/devel/quilt \
bison:${PORTSDIR}/devel/bison
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
@@ -25,11 +26,7 @@ RUN_DEPENDS= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
qpress:${PORTSDIR}/archivers/qpress
# autotool is in use for 5.1 builds
-USE_AUTOTOOLS= automake autoheader autoconf aclocal libtoolize
-# MySQL 5.5 using CMAKE
-USES= cmake iconv gettext gmake libtool perl5
-
-MASTER_SITE_SUBDIR= XtraBackup/XtraBackup-${PORTVERSION}/source/
+USES= autoreconf:build gettext gmake iconv libtool perl5
PLIST_FILES= bin/xtrabackup bin/xtrabackup_55 bin/xtrabackup_56 bin/xbstream \
bin/innobackupex bin/xbcrypt
@@ -53,14 +50,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/xbcrypt ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/innobackupex ${STAGEDIR}${PREFIX}/bin
-# autoconf is running by build.sh
-do-configure:
-run-autotools-aclocal:
-run-autotools-automake:
-run-autotools-autoconf:
-run-autotools-autoheader:
-run-autotools-libtoolize:
-patch-autotools-libtool:
- @${TRUE}
-
.include <bsd.port.mk>