aboutsummaryrefslogtreecommitdiff
path: root/databases/xtrabackup
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-10-07 14:56:33 +0000
committerSteve Wills <swills@FreeBSD.org>2019-10-07 14:56:33 +0000
commitfdabb087d4c743d8fbb426635a192e2b8f1c71cd (patch)
tree5030b5cf63a6871e1001e1730a76d596eb096a5e /databases/xtrabackup
parent837afe479ac91155b683e36b97e5d028b841ad9e (diff)
downloadports-fdabb087d4c743d8fbb426635a192e2b8f1c71cd.tar.gz
ports-fdabb087d4c743d8fbb426635a192e2b8f1c71cd.zip
Notes
Diffstat (limited to 'databases/xtrabackup')
-rw-r--r--databases/xtrabackup/Makefile7
-rw-r--r--databases/xtrabackup/distinfo6
-rw-r--r--databases/xtrabackup/files/patch-cmake-install_layout.cmake2
-rw-r--r--databases/xtrabackup/files/patch-plugin_keyring_common_system__keys__container.cc11
-rw-r--r--databases/xtrabackup/files/patch-storage_innobase_row_row0sel.cc11
-rw-r--r--databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_CMakeLists.txt31
-rw-r--r--databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_backup__copy.cc46
-rw-r--r--databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_xtrabackup.cc13
8 files changed, 7 insertions, 120 deletions
diff --git a/databases/xtrabackup/Makefile b/databases/xtrabackup/Makefile
index 5775b38c65d5..a9112e3d9e6a 100644
--- a/databases/xtrabackup/Makefile
+++ b/databases/xtrabackup/Makefile
@@ -2,15 +2,14 @@
# $FreeBSD$
PORTNAME= xtrabackup
-DISTVERSION= 2.4.12
-PORTREVISION= 1
+DISTVERSION= 2.4.15
CATEGORIES= databases
MASTER_SITES= https://www.percona.com/downloads/XtraBackup/Percona-XtraBackup-${PORTVERSION}/source/tarball/:xtrabackup \
SF/boost/boost/1.59.0/:boost
DISTFILES= percona-${PORTNAME}-${PORTVERSION}.tar.gz:xtrabackup \
boost_1_59_0.tar.bz2:boost
-MAINTAINER= aleks@twindb.com
+MAINTAINER= samm@os2.kiev.ua
COMMENT= OpenSource version of InnoDB backup with support of Percona extensions
LICENSE= GPLv2
@@ -34,7 +33,7 @@ USES= alias autoreconf:build bison cmake:noninja compiler:c++11-lang \
cpe gettext libtool perl5 shebangfix
CPE_VENDOR= percona
SHEBANG_FILES= storage/innobase/xtrabackup/xbcloud_osenv.sh
-CMAKE_ARGS= -DWITH_BOOST=${WRKDIR}/boost_1_59_0
+CMAKE_ARGS= -DWITH_BOOST=${WRKDIR}/boost_1_59_0 -DWITH_VERSION_CHECK=OFF
WRKSRC= ${WRKDIR}/percona-${PORTNAME}-${PORTVERSION}
diff --git a/databases/xtrabackup/distinfo b/databases/xtrabackup/distinfo
index 044dd6c6be1c..27e8bc3210b5 100644
--- a/databases/xtrabackup/distinfo
+++ b/databases/xtrabackup/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1533575308
-SHA256 (percona-xtrabackup-2.4.12.tar.gz) = de02cfd5bde96ddbf50339ef3a4646004dde52239698df45c19ed3e8ee40738e
-SIZE (percona-xtrabackup-2.4.12.tar.gz) = 57232309
+TIMESTAMP = 1570253950
+SHA256 (percona-xtrabackup-2.4.15.tar.gz) = ea8e50b50ff7230220329431339a1f3d97af2365a31f2afe6533d13ff95c20db
+SIZE (percona-xtrabackup-2.4.15.tar.gz) = 57357749
SHA256 (boost_1_59_0.tar.bz2) = 727a932322d94287b62abb1bd2d41723eec4356a7728909e38adb65ca25241ca
SIZE (boost_1_59_0.tar.bz2) = 70389425
diff --git a/databases/xtrabackup/files/patch-cmake-install_layout.cmake b/databases/xtrabackup/files/patch-cmake-install_layout.cmake
index 19d6bd955454..f4d8a3f77fdf 100644
--- a/databases/xtrabackup/files/patch-cmake-install_layout.cmake
+++ b/databases/xtrabackup/files/patch-cmake-install_layout.cmake
@@ -1,6 +1,6 @@
--- cmake/install_layout.cmake 2017-02-06 18:02:22.189764000 +0000
+++ cmake/install_layout.cmake 2017-02-06 18:02:29.642407000 +0000
-@@ -162,7 +162,7 @@
+@@ -160,7 +160,7 @@
#
SET(INSTALL_SHAREDIR_STANDALONE "share")
SET(INSTALL_MYSQLSHAREDIR_STANDALONE "share")
diff --git a/databases/xtrabackup/files/patch-plugin_keyring_common_system__keys__container.cc b/databases/xtrabackup/files/patch-plugin_keyring_common_system__keys__container.cc
deleted file mode 100644
index d347c6f77f33..000000000000
--- a/databases/xtrabackup/files/patch-plugin_keyring_common_system__keys__container.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugin/keyring/common/system_keys_container.cc.orig 2018-08-27 16:50:01 UTC
-+++ plugin/keyring/common/system_keys_container.cc
-@@ -125,7 +125,7 @@ void System_keys_container::store_or_upd
- if (is_system_key_with_version(key, system_key_id, key_version))
- {
- if (system_key_id_to_system_key.count(system_key_id) == 0) // add a new system key
-- system_key_id_to_system_key.insert(std::make_pair<std::string, System_key_adapter*>(system_key_id, new System_key_adapter(key_version, key)));
-+ system_key_id_to_system_key.insert(std::make_pair(system_key_id, new System_key_adapter(key_version, key)));
- else
- update_system_key(key, system_key_id, key_version);
- }
diff --git a/databases/xtrabackup/files/patch-storage_innobase_row_row0sel.cc b/databases/xtrabackup/files/patch-storage_innobase_row_row0sel.cc
deleted file mode 100644
index 9cb615e95b9e..000000000000
--- a/databases/xtrabackup/files/patch-storage_innobase_row_row0sel.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- storage/innobase/row/row0sel.cc.orig 2018-08-27 16:21:56 UTC
-+++ storage/innobase/row/row0sel.cc
-@@ -5175,7 +5175,7 @@ rec_loop:
- reporting due to search views etc. */
- if (prev_rec != NULL
- && prebuilt->m_mysql_handler->end_range != NULL
-- && prebuilt->idx_cond == false && end_loop >= 100) {
-+ && prebuilt->idx_cond == NULL && end_loop >= 100) {
-
- dict_index_t* key_index = prebuilt->index;
- bool clust_templ_for_sec = false;
diff --git a/databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_CMakeLists.txt b/databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_CMakeLists.txt
deleted file mode 100644
index 5b10686b37d3..000000000000
--- a/databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_CMakeLists.txt
+++ /dev/null
@@ -1,31 +0,0 @@
---- storage/innobase/xtrabackup/src/CMakeLists.txt.orig 2018-08-09 13:51:49 UTC
-+++ storage/innobase/xtrabackup/src/CMakeLists.txt
-@@ -28,13 +28,6 @@ FIND_GCRYPT()
- MYSQL_CHECK_CURL()
- FIND_EV()
-
--# xxd is needed to embed version_check script
--FIND_PROGRAM(XXD_PATH xxd)
--
--IF(NOT XXD_PATH)
-- MESSAGE(FATAL_ERROR "xxd not found. Try to install vim-common.")
--ENDIF(NOT XXD_PATH)
--
- INCLUDE_DIRECTORIES(
- ${CMAKE_SOURCE_DIR}/include
- ${CMAKE_SOURCE_DIR}/storage/innobase/include
-@@ -56,14 +49,6 @@ ADD_DEFINITIONS(${SSL_DEFINES})
- ########################################################################
- CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/xtrabackup_version.h.in
- ${CMAKE_CURRENT_BINARY_DIR}/xtrabackup_version.h )
--
--ADD_CUSTOM_COMMAND(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/version_check_pl.h
-- COMMAND ${XXD_PATH} --include version_check.pl
-- ${CMAKE_CURRENT_BINARY_DIR}/version_check_pl.h
-- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR})
--
--ADD_CUSTOM_TARGET(GenVersionCheck
-- DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/version_check_pl.h)
-
- INCLUDE_DIRECTORIES(
- ${CMAKE_SOURCE_DIR}/plugin/keyring
diff --git a/databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_backup__copy.cc b/databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_backup__copy.cc
deleted file mode 100644
index c1bd9ef1b35b..000000000000
--- a/databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_backup__copy.cc
+++ /dev/null
@@ -1,46 +0,0 @@
---- storage/innobase/xtrabackup/src/backup_copy.cc.orig 2018-08-09 14:07:34 UTC
-+++ storage/innobase/xtrabackup/src/backup_copy.cc
-@@ -53,7 +53,6 @@ Place, Suite 330, Boston, MA 02111-1307 USA
- #include <string>
- #include <mysqld.h>
- #include <my_default.h>
--#include <version_check_pl.h>
- #include <sstream>
- #include <algorithm>
- #include "fil_cur.h"
-@@ -2296,35 +2295,4 @@ decrypt_decompress()
- sync_check_close();
-
- return(ret);
--}
--
--void
--version_check()
--{
-- if (opt_password != NULL) {
-- setenv("option_mysql_password", opt_password, 1);
-- }
-- if (opt_user != NULL) {
-- setenv("option_mysql_user", opt_user, 1);
-- }
-- if (opt_host != NULL) {
-- setenv("option_mysql_host", opt_host, 1);
-- }
-- if (opt_socket != NULL) {
-- setenv("option_mysql_socket", opt_socket, 1);
-- }
-- if (opt_port != 0) {
-- char port[20];
-- snprintf(port, sizeof(port), "%u", opt_port);
-- setenv("option_mysql_port", port, 1);
-- }
--
-- FILE *pipe = popen("perl", "w");
-- if (pipe == NULL) {
-- return;
-- }
--
-- fwrite((const char *) version_check_pl, version_check_pl_len, 1, pipe);
--
-- pclose(pipe);
- }
diff --git a/databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_xtrabackup.cc b/databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_xtrabackup.cc
deleted file mode 100644
index 06c32621e83f..000000000000
--- a/databases/xtrabackup/files/patch-storage_innobase_xtrabackup_src_xtrabackup.cc
+++ /dev/null
@@ -1,13 +0,0 @@
---- storage/innobase/xtrabackup/src/xtrabackup.cc.orig 2018-08-09 13:53:57 UTC
-+++ storage/innobase/xtrabackup/src/xtrabackup.cc
-@@ -8236,10 +8236,6 @@ xb_init()
-
- if (xtrabackup_backup) {
-
-- if (!opt_noversioncheck) {
-- version_check();
-- }
--
- if ((mysql_connection = xb_mysql_connect()) == NULL) {
- return(false);
- }