aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-07-31 06:54:09 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-07-31 06:54:09 +0000
commit0c32f397115d6a7e639ed1f8b4228848bd5cc96c (patch)
treece66d6984b8e2580d19a3e478f618b13623e3080 /databases
parentc37aa810ab6b2dec5c29293ea60ad8f84d8effda (diff)
downloadports-0c32f397115d6a7e639ed1f8b4228848bd5cc96c.tar.gz
ports-0c32f397115d6a7e639ed1f8b4228848bd5cc96c.zip
- Convert to new Uses/perl5.mk framework
- Resolve issues with implicit lang/perl in extract and patch dependencies - Trim Makefile header Reviewed by: bapt@ (exp-run) Approved by: bapt@ (portmrg@)
Notes
Notes: svn path=/head/; revision=324007
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-Cache-Memcached-Managed/Makefile9
-rw-r--r--databases/p5-DBD-Oracle/Makefile3
-rw-r--r--databases/p5-DBIx-Class-DigestColumns/Makefile3
-rw-r--r--databases/p5-DBIx-Class-EncodedColumn/Makefile3
-rw-r--r--databases/p5-DBIx-Recordset/Makefile6
-rw-r--r--databases/p5-POE-Component-LaDBI/Makefile9
-rw-r--r--databases/p5-POE-Component-RRDTool/Makefile9
-rw-r--r--databases/p5-Text-Query-SQL/Makefile9
-rw-r--r--databases/py-sqlrelay/Makefile9
9 files changed, 22 insertions, 38 deletions
diff --git a/databases/p5-Cache-Memcached-Managed/Makefile b/databases/p5-Cache-Memcached-Managed/Makefile
index 3673225b26ab..06762871b2f7 100644
--- a/databases/p5-Cache-Memcached-Managed/Makefile
+++ b/databases/p5-Cache-Memcached-Managed/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Cache-Memcached-Managed
-# Date created: 2006-01-02
-# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
-#
+# Created by: Lars Balker Rasmussen <lbr@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Cache-Memcached-Managed
PORTVERSION= 0.24
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-Cache-Memcached>=0:${PORTSDIR}/databases/p5-Cache-Memcached
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= memcached:${PORTSDIR}/databases/memcached
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure extract
MAN3= Cache::Memcached::Managed.3 \
Cache::Memcached::Managed::Inactive.3 \
diff --git a/databases/p5-DBD-Oracle/Makefile b/databases/p5-DBD-Oracle/Makefile
index 18dc44ddec80..d085306a5a5d 100644
--- a/databases/p5-DBD-Oracle/Makefile
+++ b/databases/p5-DBD-Oracle/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= OCI8 EXAMPLES
OCI8_DESC= Use OCI8
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
CONFIGURE_ENV= ORACLE_HOME="${ORACLE_HOME}"
MAN1= ora_explain.1
diff --git a/databases/p5-DBIx-Class-DigestColumns/Makefile b/databases/p5-DBIx-Class-DigestColumns/Makefile
index dd0556d088c2..f790bf2676d0 100644
--- a/databases/p5-DBIx-Class-DigestColumns/Makefile
+++ b/databases/p5-DBIx-Class-DigestColumns/Makefile
@@ -14,7 +14,8 @@ COMMENT= Automatic digest columns
RUN_DEPENDS= p5-DBIx-Class>=0.06002:${PORTSDIR}/databases/p5-DBIx-Class
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild extract
MAN3= DBIx::Class::DigestColumns.3
diff --git a/databases/p5-DBIx-Class-EncodedColumn/Makefile b/databases/p5-DBIx-Class-EncodedColumn/Makefile
index 6e59756cca48..fb0c398ed64b 100644
--- a/databases/p5-DBIx-Class-EncodedColumn/Makefile
+++ b/databases/p5-DBIx-Class-EncodedColumn/Makefile
@@ -21,7 +21,8 @@ TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-Dir-Self>=0:${PORTSDIR}/devel/p5-Dir-Self
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure extract
MAN3= DBIx::Class::EncodedColumn.3 \
DBIx::Class::EncodedColumn::Crypt.3 \
diff --git a/databases/p5-DBIx-Recordset/Makefile b/databases/p5-DBIx-Recordset/Makefile
index 53c417fc6a39..44071b44b794 100644
--- a/databases/p5-DBIx-Recordset/Makefile
+++ b/databases/p5-DBIx-Recordset/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: DBIx::Recordset
-# Date created: 29 Apr 2001
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= DBIx-Recordset
PORTVERSION= 0.26
diff --git a/databases/p5-POE-Component-LaDBI/Makefile b/databases/p5-POE-Component-LaDBI/Makefile
index a01a5d60add1..4c6e0489ad58 100644
--- a/databases/p5-POE-Component-LaDBI/Makefile
+++ b/databases/p5-POE-Component-LaDBI/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: POE-Component-LaDBI
-# Date created: 09 February 2004
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= POE-Component-LaDBI
PORTVERSION= 1.2.1
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
MAN3= POE::Component::LaDBI.3 POE::Component::LaDBI::Commands.3 \
POE::Component::LaDBI::Engine.3 \
diff --git a/databases/p5-POE-Component-RRDTool/Makefile b/databases/p5-POE-Component-RRDTool/Makefile
index c525b6dc1883..67853f5b7e4d 100644
--- a/databases/p5-POE-Component-RRDTool/Makefile
+++ b/databases/p5-POE-Component-RRDTool/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: POE-Component-RRDTool
-# Date created: 05 July 2002
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= POE-Component-RRDTool
PORTVERSION= 0.18
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
${LOCALBASE}/bin/rrdtool:${PORTSDIR}/databases/rrdtool
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
CONFIGURE_ARGS= </dev/null
MAN3= POE::Component::RRDTool.3
diff --git a/databases/p5-Text-Query-SQL/Makefile b/databases/p5-Text-Query-SQL/Makefile
index 79e938e3654a..e2520d4d4466 100644
--- a/databases/p5-Text-Query-SQL/Makefile
+++ b/databases/p5-Text-Query-SQL/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: databases/p5-Text-Query-SQL
-# Date created: 31 December 2000
-# Whom: Anton Berezin <tobez@tobez.org>
-#
+# Created by: Anton Berezin <tobez@tobez.org>
# $FreeBSD$
-#
PORTNAME= Text-Query-SQL
PORTVERSION= 0.09
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-Text-Query>=0:${PORTSDIR}/textproc/p5-Text-Query
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
MAN3= Text::Query::BuildSQLMifluz.3 Text::Query::BuildSQLMySQL.3 \
Text::Query::BuildSQLFulcrum.3 Text::Query::BuildSQL.3 \
diff --git a/databases/py-sqlrelay/Makefile b/databases/py-sqlrelay/Makefile
index e7517cfd634d..9313ebad04fe 100644
--- a/databases/py-sqlrelay/Makefile
+++ b/databases/py-sqlrelay/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Python module for SQL Relay
-# Date created: 2 July 2001
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
+# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
-#
PORTNAME= ${SQLRELAY_PORTNAME}
PORTVERSION= ${SQLRELAY_PORTVERSION}
@@ -20,7 +16,8 @@ EXTRACT_DEPENDS= ${NONEXISTENT}:${SQLRELAY_PORTDIR}:patch
LIB_DEPENDS= sqlrclient.0:${SQLRELAY_PORTDIR}
USE_PYTHON= yes
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build patch
WRKSRC= ${WRKDIR}/${PORTNAME}
BUILD_WRKSRC= ${WRKSRC}/src/api/python