aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2020-10-21 22:58:51 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2020-10-21 22:58:51 +0000
commit1061308ba7160b89e64adf0349a3a297137e9a8b (patch)
tree7759eddebe7bd2de031762b7cab386e48e4b52b4 /databases
parent93f3c1aa069f89a5fbd0b32fa4e9e851cc62e84b (diff)
downloadports-1061308ba7160b89e64adf0349a3a297137e9a8b.tar.gz
ports-1061308ba7160b89e64adf0349a3a297137e9a8b.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/php80-dba/Makefile11
-rw-r--r--databases/php80-dba/files/patch-config.m450
-rw-r--r--databases/php80-mysqli/Makefile11
-rw-r--r--databases/php80-mysqli/files/patch-mysqli__api.c12
-rw-r--r--databases/php80-mysqli/files/patch-php_mysqli_structs.h20
-rw-r--r--databases/php80-odbc/Makefile11
-rw-r--r--databases/php80-odbc/files/patch-config.m4111
-rw-r--r--databases/php80-pdo/Makefile11
-rw-r--r--databases/php80-pdo_dblib/Makefile11
-rw-r--r--databases/php80-pdo_firebird/Makefile11
-rw-r--r--databases/php80-pdo_mysql/Makefile11
-rw-r--r--databases/php80-pdo_odbc/Makefile11
-rw-r--r--databases/php80-pdo_pgsql/Makefile11
-rw-r--r--databases/php80-pdo_sqlite/Makefile11
-rw-r--r--databases/php80-pgsql/Makefile11
-rw-r--r--databases/php80-sqlite3/Makefile11
16 files changed, 325 insertions, 0 deletions
diff --git a/databases/php80-dba/Makefile b/databases/php80-dba/Makefile
new file mode 100644
index 000000000000..ac2d9ccad359
--- /dev/null
+++ b/databases/php80-dba/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -dba
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php80-dba/files/patch-config.m4 b/databases/php80-dba/files/patch-config.m4
new file mode 100644
index 000000000000..30f662138374
--- /dev/null
+++ b/databases/php80-dba/files/patch-config.m4
@@ -0,0 +1,50 @@
+--- config.m4.orig 2016-01-06 15:14:47 UTC
++++ config.m4
+@@ -324,6 +324,38 @@ if test "$PHP_DB4" != "no"; then
+ THIS_PREFIX=$i
+ THIS_INCLUDE=$i/include/db5.3/db.h
+ break
++ elif test -f "$i/include/db5/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db5/db.h
++ break
++ elif test -f "$i/include/db48/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db48/db.h
++ break
++ elif test -f "$i/include/db47/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db47/db.h
++ break
++ elif test -f "$i/include/db46/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db46/db.h
++ break
++ elif test -f "$i/include/db44/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db44/db.h
++ break
++ elif test -f "$i/include/db43/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db43/db.h
++ break
++ elif test -f "$i/include/db42/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db42/db.h
++ break
++ elif test -f "$i/include/db41/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db41/db.h
++ break
+ elif test -f "$i/include/db5.1/db.h"; then
+ THIS_PREFIX=$i
+ THIS_INCLUDE=$i/include/db5.1/db.h
+@@ -366,7 +398,7 @@ if test "$PHP_DB4" != "no"; then
+ break
+ fi
+ done
+- PHP_DBA_DB_CHECK(4, db-5.3 db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
++ PHP_DBA_DB_CHECK(4, db-5 db-5.3 db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
+ fi
+ PHP_DBA_STD_RESULT(db4,Berkeley DB4)
+
diff --git a/databases/php80-mysqli/Makefile b/databases/php80-mysqli/Makefile
new file mode 100644
index 000000000000..29dd8411d1e2
--- /dev/null
+++ b/databases/php80-mysqli/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -mysqli
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php80-mysqli/files/patch-mysqli__api.c b/databases/php80-mysqli/files/patch-mysqli__api.c
new file mode 100644
index 000000000000..a100e8205fb6
--- /dev/null
+++ b/databases/php80-mysqli/files/patch-mysqli__api.c
@@ -0,0 +1,12 @@
+--- mysqli_api.c.orig 2020-09-29 22:36:51 UTC
++++ mysqli_api.c
+@@ -29,7 +29,9 @@
+ #include "zend_smart_str.h"
+ #include "php_mysqli_structs.h"
+ #include "mysqli_priv.h"
++#if defined(MYSQLI_USE_MYSQLND)
+ #include "ext/mysqlnd/mysql_float_to_double.h"
++#endif
+
+ #define ERROR_ARG_POS(arg_num) (getThis() ? (arg_num-1) : (arg_num))
+
diff --git a/databases/php80-mysqli/files/patch-php_mysqli_structs.h b/databases/php80-mysqli/files/patch-php_mysqli_structs.h
new file mode 100644
index 000000000000..68568dd214fd
--- /dev/null
+++ b/databases/php80-mysqli/files/patch-php_mysqli_structs.h
@@ -0,0 +1,20 @@
+--- php_mysqli_structs.h.orig 2010-07-26 15:52:54.000000000 +0200
++++ php_mysqli_structs.h 2010-07-26 15:53:14.000000000 +0200
+@@ -36,7 +36,7 @@
+ #define FALSE 0
+ #endif
+
+-#ifdef MYSQLI_USE_MYSQLND
++#if defined(MYSQLI_USE_MYSQLND)
+ #include "ext/mysqlnd/mysqlnd.h"
+ #include "mysqli_mysqlnd.h"
+ #else
+@@ -53,6 +53,8 @@
+ #undef HAVE_MBSTATE_T
+ #define WE_HAD_MBSTATE_T
+ #endif
++
++typedef zend_ulong ulong;
+
+ #if defined(ulong) && !defined(HAVE_ULONG)
+ #define HAVE_ULONG
diff --git a/databases/php80-odbc/Makefile b/databases/php80-odbc/Makefile
new file mode 100644
index 000000000000..3f3763a6893c
--- /dev/null
+++ b/databases/php80-odbc/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -odbc
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php80-odbc/files/patch-config.m4 b/databases/php80-odbc/files/patch-config.m4
new file mode 100644
index 000000000000..04efc6ded7c9
--- /dev/null
+++ b/databases/php80-odbc/files/patch-config.m4
@@ -0,0 +1,111 @@
+--- config.m4.orig 2019-08-06 06:54:18 UTC
++++ config.m4
+@@ -91,6 +91,9 @@ AC_DEFUN([PHP_ODBC_FIND_EMPRESS_BCS_LIBS
+ dnl
+ dnl configure options
+ dnl
++PHP_ARG_ENABLE(odbc,,
++[ --enable-odbc Enable ODBC support with selected driver])
++
+
+ PHP_ARG_WITH([odbcver],,
+ [AS_HELP_STRING([[--with-odbcver[=HEX]]],
+@@ -102,7 +105,7 @@ PHP_ARG_WITH([odbcver],,
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH([adabas],,
+ [AS_HELP_STRING([[--with-adabas[=DIR]]],
+- [Include Adabas D support [/usr/local]])])
++ [Include Adabas D support [/usr/local]])], [no], [no])
+
+ AC_MSG_CHECKING([for Adabas support])
+ if test "$PHP_ADABAS" != "no"; then
+@@ -132,7 +135,7 @@ fi
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH([sapdb],,
+ [AS_HELP_STRING([[--with-sapdb[=DIR]]],
+- [Include SAP DB support [/usr/local]])])
++ [Include SAP DB support [/usr/local]])], [no], [no])
+
+ AC_MSG_CHECKING([for SAP DB support])
+ if test "$PHP_SAPDB" != "no"; then
+@@ -153,7 +156,7 @@ fi
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH([solid],,
+ [AS_HELP_STRING([[--with-solid[=DIR]]],
+- [Include Solid support [/usr/local/solid]])])
++ [Include Solid support [/usr/local/solid]])], [no], [no])
+
+ AC_MSG_CHECKING(for Solid support)
+ if test "$PHP_SOLID" != "no"; then
+@@ -181,7 +184,7 @@ fi
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH([ibm-db2],,
+ [AS_HELP_STRING([[--with-ibm-db2[=DIR]]],
+- [Include IBM DB2 support [/home/db2inst1/sqllib]])])
++ [Include IBM DB2 support [/home/db2inst1/sqllib]])], [no], [no])
+
+ AC_MSG_CHECKING(for IBM DB2 support)
+ if test "$PHP_IBM_DB2" != "no"; then
+@@ -222,7 +225,7 @@ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH([empress],,
+ [AS_HELP_STRING([[--with-empress[=DIR]]],
+ [Include Empress support $EMPRESSPATH (Empress Version >= 8.60
+- required)])])
++ required)])], [no], [no])
+
+ AC_MSG_CHECKING(for Empress support)
+ if test "$PHP_EMPRESS" != "no"; then
+@@ -248,7 +251,7 @@ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH([empress-bcs],,
+ [AS_HELP_STRING([[--with-empress-bcs[=DIR]]],
+ [Include Empress Local Access support $EMPRESSPATH (Empress Version >=
+- 8.60 required)])])
++ 8.60 required)])], [no], [no])
+
+ AC_MSG_CHECKING(for Empress local access support)
+ if test "$PHP_EMPRESS_BCS" != "no"; then
+@@ -294,7 +297,7 @@ PHP_ARG_WITH([custom-odbc],,
+ your include dirs. For example, you should define following for Sybase SQL
+ Anywhere 5.5.00 on QNX, prior to running this configure script:
+ CPPFLAGS="-DODBC_QNX -DSQLANY_BUG" LDFLAGS=-lunix
+- CUSTOM_ODBC_LIBS="-ldblib -lodbc"])])
++ CUSTOM_ODBC_LIBS="-ldblib -lodbc"])], [no], [no])
+
+ AC_MSG_CHECKING(for a custom ODBC support)
+ if test "$PHP_CUSTOM_ODBC" != "no"; then
+@@ -317,7 +320,7 @@ fi
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH([iodbc],,
+ [AS_HELP_STRING([--with-iodbc],
+- [Include iODBC support])])
++ [Include iODBC support])], [no], [no])
+
+ AC_MSG_CHECKING(whether to build with iODBC support)
+ if test "$PHP_IODBC" != "no"; then
+@@ -335,7 +338,7 @@ fi
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH([esoob],,
+ [AS_HELP_STRING([[--with-esoob[=DIR]]],
+- [Include Easysoft OOB support [/usr/local/easysoft/oob/client]])])
++ [Include Easysoft OOB support [/usr/local/easysoft/oob/client]])], [no], [no])
+
+ AC_MSG_CHECKING(for Easysoft ODBC-ODBC Bridge support)
+ if test "$PHP_ESOOB" != "no"; then
+@@ -358,7 +361,7 @@ fi
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH([unixODBC],,
+ [AS_HELP_STRING([--with-unixODBC],
+- [Include unixODBC support])])
++ [Include unixODBC support])], [no], [no])
+
+ AC_MSG_CHECKING(whether to build with unixODBC support)
+ if test "$PHP_UNIXODBC" != "no"; then
+@@ -386,7 +389,7 @@ fi
+ if test -z "$ODBC_TYPE"; then
+ PHP_ARG_WITH([dbmaker],,
+ [AS_HELP_STRING([[--with-dbmaker[=DIR]]],
+- [Include DBMaker support])])
++ [Include DBMaker support])], [no], [no])
+
+ AC_MSG_CHECKING(for DBMaker support)
+ if test "$PHP_DBMAKER" != "no"; then
diff --git a/databases/php80-pdo/Makefile b/databases/php80-pdo/Makefile
new file mode 100644
index 000000000000..5b7e2bdefdbd
--- /dev/null
+++ b/databases/php80-pdo/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -pdo
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php80-pdo_dblib/Makefile b/databases/php80-pdo_dblib/Makefile
new file mode 100644
index 000000000000..2f758fd1c6e5
--- /dev/null
+++ b/databases/php80-pdo_dblib/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -pdo_dblib
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php80-pdo_firebird/Makefile b/databases/php80-pdo_firebird/Makefile
new file mode 100644
index 000000000000..8296897b4c7c
--- /dev/null
+++ b/databases/php80-pdo_firebird/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -pdo_firebird
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php80-pdo_mysql/Makefile b/databases/php80-pdo_mysql/Makefile
new file mode 100644
index 000000000000..90750d910e58
--- /dev/null
+++ b/databases/php80-pdo_mysql/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -pdo_mysql
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php80-pdo_odbc/Makefile b/databases/php80-pdo_odbc/Makefile
new file mode 100644
index 000000000000..4076e183fec9
--- /dev/null
+++ b/databases/php80-pdo_odbc/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -pdo_odbc
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php80-pdo_pgsql/Makefile b/databases/php80-pdo_pgsql/Makefile
new file mode 100644
index 000000000000..26abe3104ede
--- /dev/null
+++ b/databases/php80-pdo_pgsql/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -pdo_pgsql
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php80-pdo_sqlite/Makefile b/databases/php80-pdo_sqlite/Makefile
new file mode 100644
index 000000000000..f5ad6819dc90
--- /dev/null
+++ b/databases/php80-pdo_sqlite/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -pdo_sqlite
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php80-pgsql/Makefile b/databases/php80-pgsql/Makefile
new file mode 100644
index 000000000000..6ed29ca82e99
--- /dev/null
+++ b/databases/php80-pgsql/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -pgsql
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php80-sqlite3/Makefile b/databases/php80-sqlite3/Makefile
new file mode 100644
index 000000000000..e377f0f21e6a
--- /dev/null
+++ b/databases/php80-sqlite3/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php80
+
+PKGNAMESUFFIX= -sqlite3
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"