aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-04-21 11:04:33 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-04-21 11:04:33 +0000
commit15675073012e6e3708509565277da2ff1bbd4f7e (patch)
tree0bba20f20c78ba8ac0eeb7f1fd80b333e31b95b1 /databases
parent76533f17366cac3d90151aef9f75a5f9db58b05b (diff)
- Mark OQGRAPH option BROKEN as it fails with both old and new boost
- Allow to disable it properly so the build doesn't break of boost is installed - Remove OQGRAPH-related cmake flags, as they do nothing PR: 207115 Submitted by: amdmi3 Approved by: maintainer timeout (never@nevermind.kiev.ua, 2 months)
Notes
Notes: svn path=/head/; revision=413724
Diffstat (limited to 'databases')
-rw-r--r--databases/mariadb100-server/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/databases/mariadb100-server/Makefile b/databases/mariadb100-server/Makefile
index 041c4da3a4e2..4caa7794f400 100644
--- a/databases/mariadb100-server/Makefile
+++ b/databases/mariadb100-server/Makefile
@@ -106,12 +106,12 @@ CMAKE_ARGS+= -DWITH_EMBEDDED_SERVER="ON" \
INNODB_CMAKE_OFF= -DWITHOUT_INNOBASE=1
MAXKEY_EXTRA_PATCHES+= ${FILESDIR}/extra-patch-include_my__compare.h
MROONGA_CMAKE_OFF= -DWITHOUT_MROONGA=1
-OQGRAPH_CMAKE_OFF= -DWITHOUT_OQGRAPH=1
OQGRAPH_LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libJudy.so:devel/judy
# Currently OQGraph does not build using clang.
# See See https://mariadb.atlassian.net/browse/MDEV-8051.
-OQGRPAH_USE= gcc
+OQGRAPH_USE= gcc
+OQGRAPH_BROKEN= does not build
post-install:
# Remove programs to avoid conflict with mariadb100-client
@@ -136,6 +136,9 @@ CMAKE_ARGS+= -DWITH_JEMALLOC="no"
USE_GCC= yes
.endif
+post-extract-OQGRAPH-off:
+ @${RM} -rf ${WRKSRC}/storage/oqgraph
+
post-patch:
@${REINPLACE_CMD} 's/*.1/${MAN1}/' ${WRKSRC}/man/CMakeLists.txt
@${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/mysys/my_default.c