aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2021-03-11 13:06:35 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2021-03-11 13:06:35 +0000
commit25b10db00018f2a795c27c404debf4203234a33f (patch)
treef01ddb47fdad269a8ece06d1d3bc4ec63de11519 /databases
parent59815b06049f92f35b2ed0c92e43dce1b2da9922 (diff)
downloadports-25b10db00018f2a795c27c404debf4203234a33f.tar.gz
ports-25b10db00018f2a795c27c404debf4203234a33f.zip
Add pg_hashids 1.3, postgreSQL extension for generates short, unique,
non-sequential ids from numbers. PR: 254180 Submitted by: dmitry.wagin@ya.ru
Notes
Notes: svn path=/head/; revision=568089
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pg_hashids/Makefile32
-rw-r--r--databases/pg_hashids/distinfo3
-rw-r--r--databases/pg_hashids/pkg-descr4
4 files changed, 40 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index d69e9f46044b..d0ca744e91fe 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -567,6 +567,7 @@
SUBDIR += pg_citus
SUBDIR += pg_dirtyread
SUBDIR += pg_ed25519
+ SUBDIR += pg_hashids
SUBDIR += pg_partman
SUBDIR += pg_qualstats
SUBDIR += pg_reorg
diff --git a/databases/pg_hashids/Makefile b/databases/pg_hashids/Makefile
new file mode 100644
index 000000000000..b92ac428cad3
--- /dev/null
+++ b/databases/pg_hashids/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= pg_hashids
+PORTVERSION= 1.3
+CATEGORIES= databases
+
+MAINTAINER= dmitry.wagin@ya.ru
+COMMENT= PostgreSQL extension for generates short, unique, non-sequential ids from numbers
+
+LICENSE= MIT
+
+USES= gmake pgsql:9.6+
+WANT_PGSQL= server
+
+USE_GITHUB= yes
+GH_ACCOUNT= iCyberon
+GH_TAGNAME= 83398bcb
+
+LLD_UNSAFE= yes
+
+PLIST_FILES= lib/postgresql/${PORTNAME}.so \
+ share/postgresql/extension/${PORTNAME}--${PORTVERSION}.sql \
+ share/postgresql/extension/${PORTNAME}--1.0--1.1.sql \
+ share/postgresql/extension/${PORTNAME}--1.1--1.2.sql \
+ share/postgresql/extension/${PORTNAME}--1.2--${PORTVERSION}.sql \
+ share/postgresql/extension/${PORTNAME}--1.2.1--${PORTVERSION}.sql \
+ share/postgresql/extension/${PORTNAME}.control
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/databases/pg_hashids/distinfo b/databases/pg_hashids/distinfo
new file mode 100644
index 000000000000..51e83daebf07
--- /dev/null
+++ b/databases/pg_hashids/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1589651186
+SHA256 (iCyberon-pg_hashids-1.3-83398bcb_GH0.tar.gz) = c113cca19288a3b313ac3695140ac1b42b889aa9a62a436b374a4b87a7ac8fa1
+SIZE (iCyberon-pg_hashids-1.3-83398bcb_GH0.tar.gz) = 10956
diff --git a/databases/pg_hashids/pkg-descr b/databases/pg_hashids/pkg-descr
new file mode 100644
index 000000000000..d826ad8d39d9
--- /dev/null
+++ b/databases/pg_hashids/pkg-descr
@@ -0,0 +1,4 @@
+PostgreSQL extension for generates short, unique,
+non-sequential ids from numbers.
+
+WWW: https://github.com/iCyberon/pg_hashids